Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Understanding the Transcoder (bitrate)

  1. #1

    Default Understanding the Transcoder (bitrate)

    Hello guys,

    Now I belive that the transcoder is almost functional. I still not know to do a player works with a bitrate less than the source stream but I'm getting closer.

    The error log shows:
    TranscoderStreamNameGroup.addInternal[live/_definst_/camjoi001.stream]: Name group was not added, it is empty: camjoi001.stream_all

    In the content folder I have a camjoi001.stream file with the rtsp address of the IP camera.
    In the transrate.xml I set to "true" the 360 and 240 bitrate options.
    In the StartupStreams.xml I have only the camjoi001.stream set.

    I did not understand how the player will use the bitrate that I want (240 per example) if I use the link below:
    http://server:1935/live/ngrp:camjoi0...l/manifest.f4m

    Thanks.

  2. #2

    Default

    The error message indicates that the transcoder is not transcoding any streams. It could be that all the Enable value for all Encode blocks are set to false. If you can post the transcoder template you are using and more of the relevant log entries we should be able to point out the issue.

    Charlie

  3. #3

    Default

    Hello Charlie,

    The transrate.xml is below.

    <Root>
    <Transcode>
    <Encodes>
    <!-- Example Encode block for source, not required unless Member of StreamNameGroup. -->
    <Encode>
    <Enable>true</Enable>
    <Name>source</Name>
    <StreamName>mp4:${SourceStreamName}_source</StreamName>
    <Video>
    <!-- H.264, PassThru -->
    <Codec>PassThru</Codec>
    <Bitrate>${SourceVideoBitrate}</Bitrate>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru -->
    <Codec>PassThru</Codec>
    <Bitrate>${SourceAudioBitrate}</Bitrate>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 720p, high bandwith, main profile for desktop or set-top box -->
    <Encode>
    <Enable>false</Enable>
    <Name>720p</Name>
    <StreamName>mp4:${SourceStreamName}_720p</StreamName>
    <Video>
    <!-- H.264, PassThru -->
    <Codec>H.264</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>1280</Width>
    <Height>720</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>main</Profile>
    <Bitrate>1300000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>true</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru -->
    <Codec>PassThru</Codec>
    <Bitrate>${SourceAudioBitrate}</Bitrate>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 360p, high bandwith, main profile for desktop -->
    <Encode>
    <Enable>true</Enable>
    <Name>360p</Name>
    <StreamName>mp4:${SourceStreamName}_360p</StreamName>
    <Video>
    <!-- H.264, PassThru -->
    <Codec>H.264</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>640</Width>
    <Height>360</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>main</Profile>
    <Bitrate>850000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>true</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru -->
    <Codec>PassThru</Codec>
    <Bitrate>${SourceAudioBitrate}</Bitrate>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 240p, medium bandwidth, baseline profile -->
    <Encode>
    <Enable>true</Enable>
    <Name>240p</Name>
    <StreamName>mp4:${SourceStreamName}_240p</StreamName>
    <Video>
    <!-- H.264, PassThru -->
    <Codec>H.264</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>360</Width>
    <Height>240</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>baseline</Profile>
    <Bitrate>350000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>true</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru -->
    <Codec>PassThru</Codec>
    <Bitrate>${SourceAudioBitrate}</Bitrate>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 160p, low bandwith, baseline profile for 3G mobile devices such as iOS, Android, Blackberry -->
    <Encode>
    <Enable>false</Enable>
    <Name>160p</Name>
    <StreamName>mp4:${SourceStreamName}_160p</StreamName>
    <Video>
    <!-- H.264, PassThru -->
    <Codec>H.264</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>284</Width>
    <Height>160</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>baseline</Profile>
    <Bitrate>200000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>true</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru -->
    <Codec>PassThru</Codec>
    <Bitrate>${SourceAudioBitrate}</Bitrate>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    </Encodes>
    <Decode>
    <Video>
    <Deinterlace>false</Deinterlace>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Properties>
    </Properties>
    </Decode>
    <StreamNameGroups>
    <!-- Note: Play stream using stream name ngrp:[stream-name] -->
    <StreamNameGroup>
    <Name>${SourceStreamName}_all</Name>
    <Members>
    <Member>
    <EncodeName>source</EncodeName>
    </Member>
    <Member>
    <EncodeName>720p</EncodeName>
    </Member>
    <Member>
    <EncodeName>360p</EncodeName>
    </Member>
    <Member>
    <EncodeName>240p</EncodeName>
    </Member>
    <Member>
    <EncodeName>160p</EncodeName>
    </Member>
    </Members>
    </StreamNameGroup>
    <StreamNameGroup>
    <Name>${SourceStreamName}_mobile</Name>
    <Members>
    <Member>
    <EncodeName>240p</EncodeName>
    </Member>
    <Member>
    <EncodeName>160p</EncodeName>
    </Member>
    </Members>
    </StreamNameGroup>
    </StreamNameGroups>
    <Properties>
    </Properties>
    </Transcode>]

    The error log has:
    TranscoderWorkerVideoDecoder.handlePacket[live/_definst_/camjoi001.stream]: Source stream frame rate could not be calculated. Using default source stream frame rate: 29.97
    TranscoderStreamNameGroup.validateMembers[live/_definst_/camjoi001.stream]: StreamNameGroup[source] audio codec is not valid for name group: UNKNOWN (unknown)
    TranscoderStreamNameGroup.validateMembers[live/_definst_/camjoi001.stream]: StreamNameGroup[360p] audio codec is not valid for name group: UNKNOWN (unknown)
    TranscoderStreamNameGroup.validateMembers[live/_definst_/camjoi001.stream]: StreamNameGroup[240p] audio codec is not valid for name group: UNKNOWN (unknown)
    TranscoderStreamNameGroup.addInternal[live/_definst_/camjoi001.stream]: Name group was not added, it is empty: camjoi001.stream_all
    TranscoderStreamNameGroup.validateMembers[live/_definst_/camjoi001.stream]: StreamNameGroup[240p] audio codec is not valid for name group: UNKNOWN (unknown)
    TranscoderStreamNameGroup.addInternal[live/_definst_/camjoi001.stream]: Name group was not added, it is empty: camjoi001.stream_mobile

    The access.log has:
    decoder-video-start transcoder INFO 200 camjoi001.stream {codec:H264, profile:66, level:40, frameSize:352x240, displaySize:352x240, frameRate:0.0}
    encoder-video-start transcoder INFO 200 camjoi001.stream {name:"240p", bitrate:350000, codec:H264, profile:66, level:13, frameSize:352x240, displaySize:352x240, frameRate:29.97}
    encoder-video-start transcoder INFO 200 camjoi001.stream {name:"360p", bitrate:850000, codec:H264, profile:77, level:30, frameSize:528x360, displaySize:528x360, frameRate:29.97}


    JNI:VideoDecoderH264.updateDecodeInfo[live/_definst_/camjoi001.stream]: aspect:16x9 frame:1280x720 display:1280x720 frameRate:15
    JNI:VideoDecoderH264.updateDecodeInfo[live/_definst_/camjoi001.stream]: aspect:22x15 frame:352x240 display:352x240 frameRate:29.97
    JNI:VideoDecoderH264.updateDecodeInfo[live/_definst_/camjoi001.stream]: aspect:16x9 frame:1280x720 display:1280x720 frameRate:15
    JNI:VideoDecoderH264.updateDecodeInfo[live/_definst_/camjoi001.stream]: aspect:22x15 frame:352x240 display:352x240 frameRate:29.97
    TranscoderStreamNameGroup.validateMembers[live/_definst_/camjoi001.stream]: StreamNameGroup[source] audio codec is not valid for name group: UNKNOWN (unknown)
    TranscoderStreamNameGroup.validateMembers[live/_definst_/camjoi001.stream]: StreamNameGroup[360p] audio codec is not valid for name group: UNKNOWN (unknown)
    TranscoderStreamNameGroup.validateMembers[live/_definst_/camjoi001.stream]: StreamNameGroup[240p] audio codec is not valid for name group: UNKNOWN (unknown)
    TranscoderStreamNameGroup.addInternal[live/_definst_/camjoi001.stream]: Name group was not added, it is empty: camjoi001.stream_all
    TranscoderStreamNameGroup.validateMembers[live/_definst_/camjoi001.stream]: StreamNameGroup[240p] audio codec is not valid for name group: UNKNOWN (unknown)
    TranscoderStreamNameGroup.addInternal[live/_definst_/camjoi001.stream]: Name group was not added, it is empty: camjoi001.stream_mobile
    LiveStreamPacketizerSmoothStreaming.handlePacket[live/_definst_/camjoi001.stream]: Fragment durations: [1.9,1.9,1.9]
    LiveStreamPacketizerSmoothStreaming.flushPendingVideo: Bitrate[live/_definst_/camjoi001.stream]: 510542
    LiveStreamPacketizerSmoothStreaming.addFragment[live/_definst_/camjoi001.stream]: Add chunk: type:video id:0 count:60 duration:1954

  4. #4
    Join Date
    May 2011
    Posts
    456

    Default

    Hello,
    The log shows error related to the audio codec. What is the source audio codec?

    Trascoder AddOn supports these codecs for audio decoding: AAC, MP3, MPEG-1 Part 1/2, Speez, G.711 (a-law and mu-law). Since is not able to transcode the stream, a StreamNameGroup is also not created.

    -Lisa

  5. #5

    Default

    Hello lisa_w

    You was correct. I set the ACC codec to audio and so I restarted the Wowza the
    group camjoi001.stream_all appeared. But when I played with the stream camjoi001.stream_all the video was all green and some blinks of the real imagem.
    How I use the transcoder to send less bitrate to the player?

  6. #6

    Default

    Bitrate is mentioned in the Transoder Tutorial.

    There is Video/Bitrate and Audio/Bitrate. You can explicitly play a lower bitrate stream by referencing it directly instead of an ngrp, for example play the stream named: [stream-name]_160p

  7. #7

    Default

    Hello guys,

    Thanks randall, now the transcoder is working but with some considerations. I am testind with the player (silverlight) in a notebook, but the bitrate is strange.

    Camjoi001.stream (without transcoder) - Bitrate of 560kbps input and output of the Wowza. The image appears correctly.
    ngrp:camjoi001.stream_all (with transcoder) - Bitrate input of 560kbps and output of 450kbps. In this case the player blink on green and the image does not appears correctly.
    Camjoi001.stream_720p (with transcoder) - Bitrate input of 560kbps and output of 450kbps. In this case the player blink on green and the image does not appears correctly.
    Camjoi001.stream_360p (with transcoder) - Bitrate input of 560kbps and output of 360kbps. In this case the player blink on green and the image does not appears correctly.
    Camjoi001.stream_240p (with transcoder) - Bitrate input of 560kbps and output of 240kbps. In this case the player blink on green and the image does not appears correctly.
    Camjoi001.stream_160p (with transcoder) - Bitrate input of 560kbps and output of 120kbps. In this case the player blink on green and the image does not appears correctly.

    I thought that the transcoder diminished the bitrate but without harm the image. Is this correct?

  8. #8

    Default

    Hi alan,

    No, it should not harm the image. I can't really provide any insight without more information. Perhaps it has something to do with your codec or stream properties, or your transcoder template. You can post that info here. Do you see the green when streaming to a different client, like iOS or flash?

    Edit: What do the logs say now after the recent changes?
    Last edited by randall; 12-31-2011 at 06:17 PM.

  9. #9

    Default

    Hello randall,

    In the flash client happens the same problem (image blinks in green). I forgot to post the log error in the last message. There are a problem with the frame (unique line error).

    - TranscoderWorkerVideoDecoder.handlePacket[live/_definst_/camjoi001.stream]: Source stream frame rate could not be calculated. Using default source stream frame rate: 29.97

    The video codec is H264. Below I post the transrate.xml. It is the standard with few changes.

    Thanks for help me.

    - - - - - - - transrate.xml - - - - - -

    <!-- Example template for transrate, producing four new streams at different bitrates. Resultant streams can be played back individually or as a group. source, 360p and 160p encode blocks are enabled through the Enable property, other examples are not enabled. Add additional encode blocks to your template as needed. -->
    <Root>
    <Transcode>
    <Encodes>
    <!-- Example Encode block for source, not required unless Member of StreamNameGroup. -->
    <Encode>
    <Enable>true</Enable>
    <Name>source</Name>
    <StreamName>mp4:${SourceStreamName}_source</StreamName>
    <Video>
    <!-- H.264, PassThru -->
    <Codec>PassThru</Codec>
    <Bitrate>${SourceVideoBitrate}</Bitrate>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru -->
    <Codec>AAC</Codec>
    <Bitrate>64000</Bitrate>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 720p, high bandwith, main profile for desktop or set-top box -->
    <Encode>
    <Enable>true</Enable>
    <Name>720p</Name>
    <StreamName>mp4:${SourceStreamName}_720p</StreamName>
    <Video>
    <!-- H.264, PassThru -->
    <Codec>H.264</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>1280</Width>
    <Height>720</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>main</Profile>
    <Bitrate>1300000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>true</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru -->
    <Codec>AAC</Codec>
    <Bitrate>64000</Bitrate>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 360p, high bandwith, main profile for desktop -->
    <Encode>
    <Enable>true</Enable>
    <Name>360p</Name>
    <StreamName>mp4:${SourceStreamName}_360p</StreamName>
    <Video>
    <!-- H.264, PassThru -->
    <Codec>H.264</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>640</Width>
    <Height>360</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>main</Profile>
    <Bitrate>850000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>true</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru -->
    <Codec>AAC</Codec>
    <Bitrate>45000</Bitrate>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 240p, medium bandwidth, baseline profile -->
    <Encode>
    <Enable>true</Enable>
    <Name>240p</Name>
    <StreamName>mp4:${SourceStreamName}_240p</StreamName>
    <Video>
    <!-- H.264, PassThru -->
    <Codec>H.264</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>360</Width>
    <Height>240</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>baseline</Profile>
    <Bitrate>350000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>true</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru -->
    <Codec>AAC</Codec>
    <Bitrate>25000</Bitrate>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 160p, low bandwith, baseline profile for 3G mobile devices such as iOS, Android, Blackberry -->
    <Encode>
    <Enable>true</Enable>
    <Name>160p</Name>
    <StreamName>mp4:${SourceStreamName}_160p</StreamName>
    <Video>
    <!-- H.264, PassThru -->
    <Codec>H.264</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>284</Width>
    <Height>160</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>baseline</Profile>
    <Bitrate>200000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>true</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru -->
    <Codec>AAC</Codec>
    <Bitrate>15000</Bitrate>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    </Encodes>
    <Decode>
    <Video>
    <Deinterlace>false</Deinterlace>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Properties>
    </Properties>
    </Decode>
    <StreamNameGroups>
    <!-- Note: Play stream using stream name ngrp:[stream-name] -->
    <StreamNameGroup>
    <Name>${SourceStreamName}_all</Name>
    <Members>
    <Member>
    <EncodeName>source</EncodeName>
    </Member>
    <Member>
    <EncodeName>720p</EncodeName>
    </Member>
    <Member>
    <EncodeName>360p</EncodeName>
    </Member>
    <Member>
    <EncodeName>240p</EncodeName>
    </Member>
    <Member>
    <EncodeName>160p</EncodeName>
    </Member>
    </Members>
    </StreamNameGroup>
    <StreamNameGroup>
    <Name>${SourceStreamName}_mobile</Name>
    <Members>
    <Member>
    <EncodeName>240p</EncodeName>
    </Member>
    <Member>
    <EncodeName>160p</EncodeName>
    </Member>
    </Members>
    </StreamNameGroup>
    </StreamNameGroups>
    <Properties>
    </Properties>
    </Transcode>
    </Root>

  10. #10

    Default

    I saw from your previous post these lines:
    decoder-video-start transcoder INFO 200 camjoi001.stream {codec:H264, profile:66, level:40, frameSize:352x240, displaySize:352x240, frameRate:0.0}
    JNI:VideoDecoderH264.updateDecodeInfo[live/_definst_/camjoi001.stream]: aspect:16x9 frame:1280x720 display:1280x720 frameRate:15
    JNI:VideoDecoderH264.updateDecodeInfo[live/_definst_/camjoi001.stream]: aspect:22x15 frame:352x240 display:352x240 frameRate:29.97

    I'm curious about that. Are you sending two different streams to Wowza? I think the framerate is the problem. Can you post more information about the stream you are publishing to Wowza, or post a link to it? It's a camera, I take it? What model? What settings? Try playing the stream before it gets to Wowza in VLC and posting everything from Tools->Codec Information. Or do "ffmpeg -i [StreamName]".

    Posting more of the logs will help. You can post a large amount of info by wrapping the text in [ CODE ] [ / CODE ] blocks, without the spaces.

    Posting the log output from when you just start Wowza will help so we can see if you're running CUDA for example.

    Trying to play the transcoded streams via RTSP in VLC is a good test.

Page 1 of 2 12 LastLast

Similar Threads

  1. Adaptive Bitrate VOD Streaming w/ Transcoder
    By djsindt in forum Video On Demand Streaming Discussion
    Replies: 1
    Last Post: 01-24-2014, 08:34 AM
  2. Issue with AddOn Transcoder multiple bitrate
    By AlbertMac in forum AddOn: Transcoder
    Replies: 1
    Last Post: 12-11-2013, 10:25 AM
  3. Understanding of Transcoder AddOn
    By livonovo in forum AddOn: Transcoder
    Replies: 1
    Last Post: 10-07-2013, 06:07 AM
  4. Replies: 2
    Last Post: 08-16-2012, 05:15 PM
  5. Understanding output of transcoder
    By dmahoney in forum AddOn: Transcoder
    Replies: 2
    Last Post: 01-09-2012, 04:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •