Results 1 to 5 of 5

Thread: VLC RTSP client

  1. #1

    Default VLC RTSP client

    I'm publishing an RTMP stream to a wowza media server.
    Playback works fine with flash and android clients.
    However, if I try to play the RTSP stream through VLC, audio and video jitter a lot, especially at the beginning.

    I've tried to tweaks VLC settings but without success.
    Are there wowza settings that can help?

    Thanks for help!

  2. #2


    Hi Maurok,

    It should work. You'll have to provide more information to narrow down the problem. e.g. describe your setup, encoding, software versions, URLs, etc..

  3. #3


    Thanks Randall,
    I'm using the basic wowza 3 setup for a live stream.
    For encodiing I'm using FMLE 3.2:
    video: H.264 25fps 700kbps
    audio: HE-AAC stereo 64Kbps
    I'll provide you with the rtsp url via private message.
    Thanks for your help

  4. #4


    Thanks. I see the same thing you are. RTMP looks great in flash with your stream. But RTSP, is choppy/jitters/skips and even seems to speed up at certain points. Android seemed to play better, but it stopped playing the stream a few times, and there were slight infrequent hiccups.

    I am testing on FMLE 3.2 and it looks fine on my localhost with the following settings:

    H.264 Baseline Profile, Level 3.0, Keyframe every 2 seconds.
    AAC, Mono, 44.1khz, 128kbps
    Output Size: 640x480

    It looks fine. I tried it with your settings (AAC-HE), and your res: 768/432. And it played fine, though the quality was not as good, I think from resizing the resolution.

    One thing I noticed is that you have 4 streams when viewed in VLC Tools->Codec Information. Whereas in my tests it only ever reports 2 streams. (0 and 1)

    Try using my settings in FMLE. If you're not able to get it sorted out, send an email to with your stream URL, your conf and logs zipped up, and a link to this thread.

  5. #5


    It's not working with your settings either
    I forgot to mention that wowza is configured to render a separate audio-only stream, clearly this shouldn't be te problem.
    Anyway, I'm sending everything to the support.

Similar Threads

  1. RTSP no sound (VLC, Android), also with Wowza RTSP demo page
    By luvolondon in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 5
    Last Post: 04-29-2013, 12:44 PM
  2. RTSP stream works in VLC but not HLC in VLC
    By craigvansant in forum Live Streaming and Encoder Discussion
    Replies: 10
    Last Post: 01-11-2013, 04:50 PM
  3. VLC IE Plug-in that auto-invokes the VLC client Player
    By sgopalkr in forum Media Players and Devices Discussion
    Replies: 12
    Last Post: 11-14-2012, 08:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts