Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: VOD to Microsoft Mediaroom through smoothstreaming

  1. #1
    Join Date
    Jan 2012
    Posts
    3

    Default VOD to Microsoft Mediaroom through smoothstreaming

    I'm following the VOD tutorial to stream the sample.mp4 to a Microsoft Mediaroom. It works on the example silverlight player, but not on the STB. The box requests the manifest, the httpSmoothStreamingSession is created, but after a few seconds the stream is destroyed.

    Has anyone attempted this before?

  2. #2
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    I've haven't tried MS Mediaroom. I have tried Smooth streaming to WMP, and that did not work.

    Richard

  3. #3
    Join Date
    Jan 2012
    Posts
    3

    Default

    INFO stream create 300_p.mp4 -
    INFO server comment - onHTTPSessionCreate: 929565544
    INFO server comment - onHTTPSmoothStreamingSessionCreate: 929565544
    INFO server comment - onHTTPSmoothStreamingSessionCreate: 10.39.100.102
    INFO server comment - onHTTPSmoothStreamingSessionCreate: null
    DEBUG server comment - MediaReaderH264.mp4ReadAheadSize: 65536
    DEBUG server comment - MediaReaderH264.mp4ReadAheadTrigger: 32768
    DEBUG server comment - MediaReaderH264.mp4IndexBufferSize: 16384
    DEBUG server comment - MediaReaderH264.randomAccessReaderClass: com.wowza.io.Dir
    ectRandomAccessReader
    DEBUG server comment - audioDuration:183.5537188208617:44100:8094719
    DEBUG server comment - videoDuration:183.65434565434566:1001:183838
    DEBUG server comment - duration:183.65434565434566
    DEBUG server comment - MediaReaderH264.mp4ReadAheadSize: 65536
    DEBUG server comment - MediaReaderH264.mp4ReadAheadTrigger: 32768
    DEBUG server comment - MediaReaderH264.mp4IndexBufferSize: 16384
    DEBUG server comment - MediaReaderH264.randomAccessReaderClass: com.wowza.io.Dir
    ectRandomAccessReader
    DEBUG server comment - audioDuration:183.5537188208617:44100:8094719
    DEBUG server comment - videoDuration:183.65434565434566:1001:183838
    DEBUG server comment - duration:183.65434565434566
    INFO server comment - ServerHandler.exceptionCaught[[any]:1935:10.39.100.102]: j
    ava.io.IOException: An established connection was aborted by the software in you
    r host machine
    DEBUG server comment - HTTPStreamerAdapterCupertinoStreamer.canHandle[vod/300_p.
    mp4/QualityLevels(121340)/Fragments(audio=0)/Chunks({chunk]: false
    INFO server comment - HTTPStreamerAdapterSanJoseStreamer.canHandle[vod/300_p.mp4
    /QualityLevels(121340)/Fragments(audio=0)/Chunks({chunk]: false
    INFO server comment - HTTPStreamerAdapterDvrChunkStreamer.canHandle[vod/300_p.mp
    4/QualityLevels(121340)/Fragments(audio=0)/Chunks({chunk]: false
    DEBUG server comment - ServerHandler.handleSessionIdle: idleTimeout: 32
    DEBUG server comment - HTTPStreamerAdapterCupertinoStreamer.canHandle[vod/smil:3
    00_p.mp4/Manifest]: false
    This is what I'm getting in my logger. Does it ring a bell?

  4. #4
    Join Date
    Jan 2012
    Posts
    3

    Default

    I'm working on this again. I've tried feeding video to the STB using IIS and it works. After comparing the manifests generated by IIS and Wowza, and looking at the logger, I've concluded that the problem must be the way the STB is building the Url specified in the StreamIndex tag. In Wowza's manifest it has the following structure:

    <StreamIndex Type="video" Chunks="204" QualityLevels="1" MaxWidth="424" MaxHeight="240" DisplayWidth="424" DisplayHeight="240" Timescale="10000000" Url="QualityLevels({bitrate})/Fragments(video={start time})/Chunks({chunk id})/WowzaSessions(382630294).ismv">
    While on IIS it is generated this way:

    <StreamIndex Type="video" Name="video" Chunks="136" QualityLevels="8" MaxWidth="720" MaxHeight="480" DisplayWidth="720" DisplayHeight="480" Url="QualityLevels({bitrate})/Fragments(video={start time})">
    Using Wowza, the STB tries to access the url:

     vod/300_p.mp4/QualityLevels(121340)/Fragments(audio=0)/Chunks({chunk
    Is there any way I can change the URL structure generated in Wowza's manifest? Do you think implementing some sort of proxy between Wowza and the STB to fix the URLs would work?

    Thanks in advance.

  5. #5
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    There is not a way to change this in Wowza at present as far as I know

    Richard

  6. #6

    Default

    Quote Originally Posted by rrlanham View Post
    There is not a way to change this in Wowza at present as far as I know

    Richard
    Hi..

    Any news about this problem?

    This Manifest works in mediaroom:

    http://playready.directtaps.net/smoo...0.ism/Manifest

    The Manifest generated by Wowza doesn't work.

    Any solution.

    Both files are in smooth streaming

    Thanks

  7. #7

    Default

    Any news about this solution...Thank's.

  8. #8

    Default

    Try this patch. It includes smooth streaming changes for Windows 8. Probably same issue on MediaRoom:

    WowzaMediaServer3.1.1-patch9.zip

    Charlie

  9. #9
    Join Date
    Oct 2012
    Posts
    2

    Default

    Any news on this? As you know, Microsoft Mediaroom is the world's biggest IPTV platform... I'm sure you have a valid business case to support this...

    Also, is there any way you can support live MPEG-TS streams over HTTP? Mediaroom only supports live OTT MPEG-TS streams encapsulated in HTTP, not in RTP/RTSP... (Even if get you Smoothstreaming working on Mediaroom, officially Microsoft only supports SmoothStreaming for VOD content, not Live)
    Last edited by joaoserra; 10-10-2012 at 07:51 AM.

  10. #10
    Join Date
    Sep 2011
    Posts
    1,920

    Default

    Hi
    Did you try the patch posted by Charlie in post #8 for the MS Mediaroom issue?

    Jason

Page 1 of 2 12 LastLast

Similar Threads

  1. Streaming to a Microsoft Mediaroom set-top-box/emulator
    By edup_pt in forum Media Players and Devices Discussion
    Replies: 0
    Last Post: 12-20-2012, 09:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •