Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Streaming from S3 - file and/or bucket permissions

  1. #1

    Default Streaming from S3 - file and/or bucket permissions

    I am streaming using the vods3 package that comes with the wowza ami's. This only seems to work if the files are made public - available to all users. Is it really the case that I have to give access to my vod file to everyone in the world in order to stream using s3, or am I missing some permission requirement. Also, can I use a custom authentication module with vods3 wherein a token is passed by streaming clients?

    Thanks.

  2. #2
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    You have to set your AWS key and secret key in the /conf/Server.xml file /Properties.

    Richard

  3. #3

    Default

    Thanks Richard, I'll give that a go.

  4. #4

    Default

    I'm having same problem. I have added keys to Server.xml file but still not working. If I change file permissions directly on S3 it works. What might I be missing?

  5. #5
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Did you restart Wowza after changing Server.xml? That is necessary

    Richard

  6. #6

    Default

    Yes. Any other thoughts?

  7. #7
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Take a look at the access and error logs for clues.

    It is very helpful to run Wowza in stand-alone (/bin/startup.bat) mode instead of the service so you can see log output in the console.

    If you can't get it working, zip up conf and logs folders and send to support@wowza.com. Include a link to this thread for reference.

    Richard

  8. #8

    Default

    This is what I'm using. It works if I add "everyone" manually to S3. But if I remove everyone it stops working. Are these right?

    rtmp://xxx.xxxx.com/vods3
    mp4:amazons3/chrisjukes/test.mp4

    My /usr/local/WowzaMediaServer/conf/Server.xml file looks like this:


    <Root>
    <Server>
    <CommandInterface>
    <HostPort>
    <IpAddress>*</IpAddress>
    <Port>8083</Port>
    </HostPort>
    </CommandInterface>
    <AdminInterface>
    <ObjectList>Server,VHost,VHostItem,Application,ApplicationInstance,MediaCaster,Module,IdleWorker</ObjectList>
    </AdminInterface>
    <JMXRemoteConfiguration>
    <Enable>true</Enable>
    <IpAddress>${com.wowza.amazonaws.ec2.AWSEC2_METADATA_PUBLIC_HOSTNAME}</IpAddress>
    <RMIServerHostName>${com.wowza.amazonaws.ec2.AWSEC2_METADATA_PUBLIC_HOSTNAME}</RMIServerHostName>
    <RMIConnectionPort>8084</RMIConnectionPort>
    <RMIRegistryPort>8085</RMIRegistryPort>
    <Authenticate>true</Authenticate>
    <PasswordFile>${com.wowza.wms.ConfigHome}/conf/jmxremote.password</PasswordFile>
    <AccessFile>${com.wowza.wms.ConfigHome}/conf/jmxremote.access</AccessFile>
    <SSLSecure>false</SSLSecure>
    </JMXRemoteConfiguration>
    <UserAgents>Shockwave Flash|CFNetwork|MacNetwork/1.0 (Macintosh)</UserAgents>
    <ServerListeners>
    <ServerListener>
    <BaseClass>com.wowza.wms.plugin.amazonaws.ec2.env.ServerListenerEC2Variables</BaseClass>
    </ServerListener>
    <ServerListener>
    <BaseClass>com.wowza.wms.plugin.mediacache.impl.MediaCacheServerListener</BaseClass>
    </ServerListener>
    </ServerListeners>
    <VHostListeners>
    </VHostListeners>
    <HandlerThreadPool>
    <PoolSize>10</PoolSize>
    </HandlerThreadPool>
    <TransportThreadPool>
    <PoolSize>10</PoolSize>
    </TransportThreadPool>
    <RTP>
    <DatagramStartingPort>6970</DatagramStartingPort>
    <DatagramPortSharing>false</DatagramPortSharing>
    </RTP>
    <Properties>
    <Property>
    <Name>awsAccessKeyId</Name>
    <Value>xxxxxxxxxxxxxxxxxxxxxxx</Value>
    </Property>
    <Property>
    <Name>awsSecretAccessKey</Name>
    <Value>xxxxxxxxxxxxxxxxxxxxxxxxxxx</Value>
    </Property>
    </Properties>
    </Server>
    </Root>
    Last edited by chrisjukes; 02-08-2012 at 01:21 PM.

  9. #9

    Default

    This is the message I get when it fails:

    Failed to play amazons3/chrisjukes/test.mp4; stream not found.

  10. #10
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    I think the AWS keys are set in the /conf/MediaCache.xml file now. I don't have the latest AMI running to look.

    Richard

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 0
    Last Post: 05-12-2011, 02:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •