Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: RTSP + Android + Wowza.v3 = Keeps Cutting Out After 90 sec

  1. #1

    Default RTSP + Android + Wowza.v3 = Keeps Cutting Out After 90 sec

    After upgrading to v3 of Wowza, I am unable to keep video playing for more than a minute or so on an Android device (via RTSP). It starts to play and works for about a minute (90 seconds actually) then just stops.

    Can anyone give some guidance? I've tried it on a couple different Android devices. One of which has Android v2.3.6.

    Thank you,
    Steven

  2. #2
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Is it same playing on VLC? Any clue in the Wowza access log?

    Richard

  3. #3

    Default

    Quote Originally Posted by rrlanham View Post
    Is it same playing on VLC? Any clue in the Wowza access log?

    Richard
    I just tried it with VLC (same RTSP URL) and it works perfectly. Still running after 5 minutes of running. So, it's obviously an Android-related issue?

    Does it have anything to do with KeepAlive or UDP ports? I have all UDP ports on my firewall by the way.

    Thanks,
    Steven

  4. #4

    Default

    Possibly an encoding issue?

    What happens when you play the Wowza sample file?

    rtsp://[wowza-address]:1935/vod/mp4:sample.mp4
    Last edited by randall; 01-16-2012 at 09:21 PM.

  5. #5

    Default

    Quote Originally Posted by randall View Post
    Possibly an encoding issue?

    What happens when you play the Wowza sample file?

    rtsp://[wowza-address]:1935/vod/mp4:sample.mp4
    Same thing. It plays for about a minute -- then cuts out (on the Android). It must be something fairly simple I'm missing. Have any other suggestions?

    Steven

  6. #6

    Default

    Ok, then try some more troubleshooting to narrow down the problem:

    1. Play the Wowza VOD RTSP demo in your Android RTSP player. I use the free Doga player.
    rtsp://184.72.239.149/vod/mp4:BigBuckBunny_175k.mov

    If it works then it would point to a problem with your Wowza installation. If not, possibly a network issue on your end.

    2. Try playing the simple flash demo in your Android browser by going to:
    http://www.wowza.com/demo#

    Just browse to there and watch the demo right on that page. It works well for me in Android 2.2.1.

  7. #7

    Default

    I examined the Wowza log and found this interesting line:

    RTPStream.idle[1369684105:savideo/_definst_:sermons102/128081142583.mp4]: Close RTSP/RTP session. Session timeout: 90000

    Does this seem to indicate that Wowza is disconnecting the session because it thinks the client is no longer there? I found the corresponding "<RTSPSessionTimeout>90000</RTSPSessionTimeout>" value in the application.xml. But I don't know why it would be timing out. Unless whatever packets that the Android client is supposed to send (to keep-alive) are not making it to the server?

    I tried turning off the server firewall completely (running Windows 2008), but it still didn't work. There must be something else.

    Do you have any more ideas?

    Steven

  8. #8

    Default

    Yes, that must have something to do with it. What are the results of playing the streams I mentioned above?

  9. #9
    Join Date
    Sep 2011
    Posts
    1,919

    Default

    Hi
    You could try looking here,
    http://www.wowza.com/forums/content....-RTP-streaming
    This might get you started on the troubleshooting.

    There are some settings that you can play around with relating to the timeout but 90000ms is high as it is.

    Have any of the suggestions that Randall has made worked??

    Jason

  10. #10

    Default

    Quote Originally Posted by randall View Post
    Ok, then try some more troubleshooting to narrow down the problem:

    1. Play the Wowza VOD RTSP demo in your Android RTSP player. I use the free Doga player.
    rtsp://184.72.239.149/vod/mp4:BigBuckBunny_175k.mov

    If it works then it would point to a problem with your Wowza installation. If not, possibly a network issue on your end.

    2. Try playing the simple flash demo in your Android browser by going to:
    http://www.wowza.com/demo#

    Just browse to there and watch the demo right on that page. It works well for me in Android 2.2.1.
    I just tried playing your first link on the Android -- no problems.

    The second link (flash) didn't work -- it seems I don't have the latest flash plugin perhaps? It just showed an "X" where the flash part is supposed to go.

    It seems from this that the problem is with my server's installation? I guess the next question is, any ideas on what it could be? Possibly something to do with UDP packets being blocked? (But remember, my Windows firewall has all UDP ports open).

    Steven

Page 1 of 3 123 LastLast

Similar Threads

  1. RTSP stream stop every 13 sec.
    By scada2009 in forum Media Players and Devices Discussion
    Replies: 5
    Last Post: 08-21-2014, 12:08 PM
  2. RTSP no sound (VLC, Android), also with Wowza RTSP demo page
    By luvolondon in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 5
    Last Post: 04-29-2013, 12:44 PM
  3. Wowza cutting off the stream?
    By coskel22 in forum Live Streaming and Encoder Discussion
    Replies: 8
    Last Post: 12-23-2012, 04:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •