Results 1 to 3 of 3

Thread: Why Wowza3 does not play files from s3?

  1. #1

    Default Why Wowza3 does not play files from s3?

    I've already asked few questions about wowza support for http streaming. Today, I tried to play movies from s3 on iPhone using 'Wowza Server 3.0.0 for Amazon EC2' and failed. Please tell me what I did wrong?

    My actions:
    1. Take a file that I've already played locally on iPhone and put it to s3 bucket.
    2. Clone vods3 configuration and application folders ( I called it 'alls3' ) .
    3. Turn log level to DEBUG.
    4. Restart wowza
    5. Open link 'http://ec2-<server_ip>.compute-1.amazonaws.com:1935/alls3/_definst_/mp4:amazons3/movies-ios/WQK0.mp4/playlist.m3u8' on iPhone3 running iOS 3.1.3
    6. Now I see 'This movie could not be played' popup
    7. In wowza log file I see that wowza found s3 file, printed its metadata and stopped on the following mesage: 'MediaReaderH264Cupertino.indexFile[alls3/_definst_/amazons3/anyclipmovies/WQK0.mp4][avc1.77.21]: H.264 (Video may not be playable on older iPhone and iPod touch devices where Baseline/Level 3.0 or lower is required) Video info: {MediaCodecInfoVideo: codec:H264, profile:Main, level:2.1, frameSize:640x272, displaySize:640x272, frameRate:25.000000}'
    8. Next messages are already stream destroy and disconnect cupertino.

    Please explain why wowza does not coninue streaming?

  2. #2
    Join Date
    Sep 2011
    Posts
    1,931

    Default

    Hi
    Profile needs to be Baseline 3.0 not main
    I know that you are using Wowza 3 but you should at least consider upgrading as there are fixes for iOS streaming in 3.0.3 that you haven't got.

    Jason

  3. #3

    Default

    Upgrading to Wowza 3.0.3 solved the problem. Thanks. I have another problem now, but I'll open new thread for it.

    P.S. Profile is not relevant in this case, since I can play same movie on my iPhone.

Similar Threads

  1. Play recorded files
    By Lelik1985 in forum General Forum
    Replies: 1
    Last Post: 05-29-2013, 07:54 AM
  2. how to play .flv files instead of .mp4 files in wowza from flash player
    By malarprathap in forum Video On Demand Streaming Discussion
    Replies: 1
    Last Post: 08-07-2012, 04:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •