Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: RTP Multicast stream to Wowza

  1. #1

    Default RTP Multicast stream to Wowza

    hi,

    I have a multicast stream for more than one channel , each channel has different IP and same port number( 239.255.2.1:5004 , 239.255.2.2:5004 ,etc ) , this channels generated by VLC-DVBlast (encoder) , so how can I receive this RTP channels and restream them in RTSP ,RTMP or any other protocol .

    thanks

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

  3. #3

    Default

    thanks

  4. #4

    Default

    i tried to use the link , its not running on live stream , do you have any advice ?

  5. #5
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi
    Do you have any idea why this doesn't work?

    Can you post the start-up part of the Wowza logs so we can try and determine the problems you are having,
    this should give us a clue as to what the problem may be.

    What do you mean by "its not running on live stream"?

    Jason

  6. #6

    Default

    thanks for your support , my problem now is with the transcoder, log :


    INFO server comment - Wowza Media Server is started!
    INFO application app-start _definst_ live/_definst_
    INFO server comment - RTPMediaCaster.create[1062659565]
    INFO server comment - RTPMediaCaster.init[1062659565]
    INFO server comment - RTPMediaCaster.Reconnector[1062659565:live/_definst_:myStream]: start: 1
    INFO server comment - HTTPStreamManager.onHTTPRequest: Publish stream successfully started [live/_definst_]: flv:myStream
    INFO server comment - RTPSessionDescriptionDataProviderBasic.getStreamInfo[live/_definst_]: /usr/local/WowzaMediaServer/content/myStream
    INFO stream create - -
    INFO stream publish myStream -
    INFO server comment - RTPMediaCaster.Reconnector[1062659565:live/_definst_:myStream]: done: 1
    INFO server comment - RTPMediaCaster.streamTimeout[1062659565:live/_definst_:myStream]: timeout:12000 diff:12019 reason:101
    INFO server comment - RTPMediaCaster.resetConnection[1062659565:live/_definst_:myStream]:
    INFO server comment - RTPMediaCaster.closeRTPSession[1062659565:live/_definst_:myStream]
    INFO stream unpublish myStream -
    INFO stream destroy myStream -

    - myStream file is created in content/ and it contains rtp://239.255.1.3:5004
    - stream name myStream
    - I copied the transcoder.xml and transrate.xml to conf/live
    - when i try to play the stream no error appears rtmp://myip/live/myStream (stream name )
    - I've read the article about creating a template and use the transcode.xml

    please advice , many thanks

  7. #7

    Default

    Quote Originally Posted by ehuman View Post
    thanks for your support , my problem now is with the transcoder, log :


    INFO server comment - Wowza Media Server is started!
    INFO application app-start _definst_ live/_definst_
    INFO server comment - RTPMediaCaster.create[1062659565]
    INFO server comment - RTPMediaCaster.init[1062659565]
    INFO server comment - RTPMediaCaster.Reconnector[1062659565:live/_definst_:myStream]: start: 1
    INFO server comment - HTTPStreamManager.onHTTPRequest: Publish stream successfully started [live/_definst_]: flv:myStream
    INFO server comment - RTPSessionDescriptionDataProviderBasic.getStreamInfo[live/_definst_]: /usr/local/WowzaMediaServer/content/myStream
    INFO stream create - -
    INFO stream publish myStream -
    INFO server comment - RTPMediaCaster.Reconnector[1062659565:live/_definst_:myStream]: done: 1
    INFO server comment - RTPMediaCaster.streamTimeout[1062659565:live/_definst_:myStream]: timeout:12000 diff:12019 reason:101
    INFO server comment - RTPMediaCaster.resetConnection[1062659565:live/_definst_:myStream]:
    INFO server comment - RTPMediaCaster.closeRTPSession[1062659565:live/_definst_:myStream]
    INFO stream unpublish myStream -
    INFO stream destroy myStream -

    - myStream file is created in content/ and it contains rtp://239.255.1.3:5004
    - stream name myStream
    - I copied the transcoder.xml and transrate.xml to conf/live
    - when i try to play the stream no error appears rtmp://myip/live/myStream (stream name )
    - I've read the article about creating a template and use the transcode.xml

    please advice , many thanks

    and I tried to change the stream file to udp://239.255.1.3:5004

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    The usual problem is blocked UDP ports. You need to allow UDP ports 0 - 65335 (or at least 6970 - 9999) through your firewall, and map (port-forward) UDP port to your Wowza server in your router or other network devices as necessary.

    Richard

  9. #9

    Default

    is there any other reason that may cause this problem , I already disabled the firewall on Ubuntu o.s that contains the Wowza , and I'm testing between my device and Wowza server in the same network and same subnet (no firewall), I've tested the source of the stream rtp://239.255.1.3:5004 on vlc and everything is great , my problem is with transcoding , so please advice .

  10. #10
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    We can take a look at what you are doing. First, delete or rename your current access log, then restart Wowza, then start the UDP stream in StreamManager, then try to play it back in a Flash client, use the Wowza LiveVideoStreaming player. Then zip up and send the conf and logs folders to support@wowza.com. Include a link to this thread.

    It is important that you send us what you tested, that we are looking at logs that are consistent with the configuration you send.

    Richard

Page 1 of 2 12 LastLast

Similar Threads

  1. TS h.264 5mbps multicast stream in to wowza and needs to be rtmp 500k multicast out
    By panzer in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 05-15-2013, 12:16 PM
  2. Can wowza injest a RTP/MPEG2-TS Multicast stream
    By silver2003tl in forum General Forum
    Replies: 2
    Last Post: 03-22-2013, 02:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •