Results 1 to 5 of 5

Thread: tricaster -> wowza -> iphone

  1. #1
    Join Date
    Aug 2011
    Posts
    8

    Default tricaster -> wowza -> iphone

    We use a tricaster box to record our graduation, and we'd like to stream it as well. So we need mobile device compatibility...

    Using VLC and a webcam, I can stream to flash players and iPhone/iPad no problem thru wowza.

    However, using the tricaster to generate the stream, I can stream to the flash players but the iphone reports that the stream is unplayable.

    Any ideas as to what profile I need to use on the tricaster to stream to idevices thru wowza? I've tried all of the h264 options, none of 'em work.

    Thanks!

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    It's not clear how you are using the recording with tricaster? Are you streaming the recording to Wowza as a live stream?

    When a live stream starts that is configured for Cupertino playback, Wowza reports details about the video and audio codec in the access log. What do you see?

    For vod playback, copy the file to the content folder, and make sure that the Application.xml /StreamType is "default" and LiveStreamPacketizers is empty

    For live streaming of static content, you can use Wowza Stream class instead of the encoder. For example:
    http://www.wowza.com/forums/content....t-in-smil-file


    Richard

  3. #3
    Join Date
    Aug 2011
    Posts
    8

    Default

    We've been using a second computer to grab the tricaster output live via a capture card and then stream it to a DSS box. Need to support i-Devices, so DSS is out and Wowza is in... using the built in live streaming in the tricaster, sending to the Wowza box. I stopped the wowza server, renamed the logs, started it back up, and tried to play the stream.

    access log - http://people.sfcollege.edu/steve.je...access.log.txt

    Nothing in the error log...

    note that using VLC as a source and sending to the wowza box, streaming to the iphone works fine. So I'm thinking it is a profile selection in the tricaster settings...

    Thanks
    Last edited by sjensen; 02-02-2012 at 09:19 AM.

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    What is the MP3 audio codec details? Try 44100Hz, 128kbs, Stereo.

    You might have to wait a few more seconds to start playback. You started playback in the iphone 15 seconds after publish, which might not be enough.

    If you are not doing Smooth or Sanjose, you can take those out of the LiveStreamPacketizers list. This should help with latency, because there were no Cupertino chunks when you started playback in IPhone from what I see in the logs. There has to be 3 chunks, and Wowza had just created the 3rd when you disconnected.

    I do see two identical connections with different user-agents, that are created and destroyed at the same time and have the same sc-bytes value on the destroy. It is common to see a 2nd empty session when you use m3u8 url directly in a browser, but I don't think it would be so identical and have same sc-bytes value.

    I can't reach that server, I assume it is a private edu lan. Is there anyway to make it accessible? If so, you can send link to support@wowza.com. Include a link to this thread for reference.

    If you are opening m3u8 directly or in anchor (<a>) tag, then try with HTML5 video tag instead

    <html>
    <head> 
      <title>Cupertino Streaming</title>
    </head>
    
    <body>
    <video controls src="http://[wowza-address]:1935/vod/sample.mp4/playlist.m3u8">
    </video>
    
    </body>
    </html>
    Also take a look at this article:
    http://www.wowza.com/forums/content....rameters-(iOS)

    Richard

  5. #5
    Join Date
    Aug 2011
    Posts
    8

    Default

    Using the <video> tag doesn't change anything...

    And yes, the server is here on our LAN only and has no outside access.

    I've done some other reading, and it seems that I may need to create a new profile in the tricaster streaming settings...

    Thanks

Similar Threads

  1. Live streaming from Tricaster to Wowza
    By rpsroslyn in forum Live Streaming and Encoder Discussion
    Replies: 3
    Last Post: 03-07-2013, 07:36 AM
  2. Replies: 19
    Last Post: 03-22-2012, 01:11 AM
  3. Bad results streaming live Flash from Tricaster via Wowza
    By egoff3 in forum Live Streaming and Encoder Discussion
    Replies: 3
    Last Post: 02-15-2012, 02:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •