Results 1 to 9 of 9

Thread: Push Addon does not work with streaming using

  1. #1

    Default Push Addon does not work with streaming using

    I use the schedule/playlist to create a stream. The stream works fine. Then I use the Push Addon to Push this stream to another Wowza server, but it won't work. I have tested the Push Addon with FMLE and it works perfectly. However, it won't work with schedule/playlist SMIL file. Is it possible to Push the stream created from SMIL to another wowza server?

    Thanks

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    If you configure Push Publishing addon in the same application, the push should start when the scheduled stream starts.

    Richard

  3. #3
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    btw, it would be a lot easier and make more sense to use Liverepeater in this case: one Wowza server to another that you have full control of.

    http://www.wowza.com/forums/content....er-Quick-Start

    Just change the StreamType in the application that is configured with the scheduler to "liverepeater-origin", and follow the above guide with that server as the origin.

    Richard

  4. #4

    Default

    It only works about 20%. Out of 5 times, it pushes for 1 time. My developer told me the smil playlist does not create onPublish event while using FMLE does this job. That is why it does not work with playlist very well. Do you have any idea on how to make the smil playlist to create onPublish event all the time? In my case I can't use the liverepeater-edge-origin setup. Thanks

  5. #5
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    The IMediaStreamActionNotify3.onPublish event does fire when this kind of stream is started. What is the source, are you streaming files, live rtmp streams, MediCaster streams, some combo of those?

    Richard

  6. #6

    Default

    I have a list of files put in the /content folder to stream to I guess this is file streaming. I use the smil playlist to publish the stream to the /app application, then trying to use the PushAddon to push to another Wowza server.

  7. #7
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Re-start Wowza and test your setup. Make sure a module that implements IMediaStreamActionNotify3 is in place, and try to add some getLogger statement to the onPublish handler for this test.

    Then zip up conf and logs folders and send to support@wowza.com. Include a link to this thread for reference

    Richard

  8. #8

    Default

    Right now the only Module in place is PushAddon. Can you please tell me what module has ImediaStreamActionNotify3? I will include that module in Application.xml to further test.

    Thanks

  9. #9
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    You do have to build it in the IDE, there is not a pre-built module with IMediaStreamActionNotify3 because it doesn't do anything useful by itself, it is just a notifier of other events to which you can react to.

    http://www.wowza.com/forums/content....-of-codec-info

    Richard

Similar Threads

  1. Push Publishing Addon to youtube
    By andalus in forum Live Streaming and Encoders
    Replies: 3
    Last Post: 03-04-2014, 03:06 PM
  2. Push Publish Addon Unsuccessful
    By globalsites in forum AddOn: Other AddOns
    Replies: 1
    Last Post: 07-08-2012, 06:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •