Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: Wowza 3 + nDVR + OSMF Strobe Player + Android

  1. #1

    Default Wowza 3 + nDVR + OSMF Strobe Player + Android

    Hello to all,

    I am playing with the Strobe Media Playback, and was wondering why when I try to open it in Android, it doesn't play.

    I am streaming H264 (Main or Baseline) to rtmp://server/dvr/streamname.

    The stream works on Desktop + iOS, but if I try to open the Strobe player from the Android device, it is buffering forever. It shows in the beginning how long is the stream in the bottombar, but never starts playing.

    Strobe used to work like a charm with FMS, so I guess it has something to do with the encoding of my stream when using Wowza.

    Any help is appreciated.

    Thank you,
    Anton

  2. #2
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Anton,

    It could be a bandwidth issue. That's what it sounds like. Do you see log output in Wowza when you start the stream in the device, is it connecting? Run Wowza in stand-alone (/bin/startup.bat) mode instead of the service so you can see log output in the console.

    Richard

  3. #3

    Default

    I don't think it is a bandwidth issue. I've been using the same connection for a long time and never had problems, and now i'm testing with much lower bitrate. I also tested on local LAN, using Developer edition of Wowza... testing also on Amazon EC2 with lickey edition.

    Even the LiveVideoStreaming example with rtmp://server/app ; and then streamname, doesn't work.

    I noticed that if I change a bit the buffering values, or remove them all together, I get sound, but no picture on Android. My version of flash on AND is 11,1,112,61 (Flash-AS3) (according to LiveVideoStreaming example).

    There are only a few parameters to be changed at Application.xml so I'm feeling a bit lost.

    I test both LIVE app and DVR app...

    <LiveStreamPacketizers>smoothstreamingpacketizer,cupertinostreamingpacketizer,sanjosestreamingpacket izer</LiveStreamPacketizers>

    sanjosestreamingpacketizer is always present in the LiveStreamPacketizers,

    <HTTPStreamers>cupertinostreaming,smoothstreaming,sanjosestreaming</HTTPStreamers>

    it is present in the HTTPStreamers as well.

    I'm starting to fell that the problem is in my device, but as I said - it is working with FMS streams, so I feel like it is a config issue.

    In the log files on local, everything seems fine.. I see the following lines when I start broadcasting:

    INFO server comment - LiveStreamPacketizerSanJose.init[dvr/_definst_/tonyy]: chunkDurationTarget: 10000
    INFO server comment - LiveStreamPacketizerSanJose.init[dvr/_definst_/tonyy]: chunkDurationTolerance: 500
    INFO server comment - LiveStreamPacketizerSanJose.init[dvr/_definst_/tonyy]: playlistChunkCount:4
    INFO server comment - MediaStreamMap.getLiveStreamPacketizer: Create live stream packetizer: sanjosestreamingpacketizer:tonyy

    When I connect via the Android device, I see:

    INFO sanjose connect 1973510429 -
    INFO stream create tonyy -
    INFO stream play tonyy -

    no Errors whatsoever.

    I tried both with those params:

    expandedBufferTime: 5,
    liveBufferTime: 12,
    liveDynamicStreamingBufferTime: 14,
    dvrBufferTime: 12,
    dvrDynamicStreamingBufferTime: 14,
    dynamicStreamBufferTime: 14,

    and without them.

    RTSP url does work on Android. Adobe Flash Player 11 installed... Strobe on other pages (for example FMS VOD) working.

    Any ideas?

    Best,
    Anton

  4. #4

    Default

    Even RTMP url works if added to a Video player, but does not show at all in Strobe :/

    best,
    Anton

  5. #5
    Join Date
    Sep 2011
    Posts
    1,921

    Default

    Hi
    What version of Wowza 3 are you using?

    Have you tried the sample.mp4 file that comes with Wowza?

    Jason

  6. #6
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Try JW Player instead of Strobe. It handles RTMP very well. If you want to do Sanjose (Flash HTTP) streaming, you will need Strobe or Flash Media Playback (hosted version of Strobe).

    Richard

  7. #7

    Default

    JWPlayer doesnt't support DVR. Also I am pretty sure it is a config issue not to be able to load Strobe on Android, so I will continue to test, in order to nail why is it happening.

    I use Wowza 3.0.4 on EC2. Will try sample.mp4 now, but I wanted to test LIVE and DVR... VOD is not of particular interest for me right now.

    Best,
    Anton

  8. #8
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Anton,

    You do need to use Sanjose (Flash HTTP) streaming in that case, rtmp does not work with DVR. Have you tested with the Wowza DVR example players?

    Richard

  9. #9

    Default

    Sorry for misleading you.

    I know DVR works only with Sanjose. I publish the stream via the rtmp://server/app ; streamname, but in Strobe, I use the Sanjose URL: http://server:1935/app/streamname/manifest.f4m?DVR

    As I said - it is working on a browser, it is working for iPhone and iPad (of course, not Strobe, but the iOS url's that open the native player), but on Android, Strobe is not working... only RTSP url with a native video player. On Android I manage to get only sound. The picture is black - I tried H264 Baseline, H264 Main.

    I want to get Strobe inside an Android browser if possible.

    I checked a few Android devices, and a few different ROMs (Gingerbread + Android 4.0) - it is not working anywhere... just manage to hear the sound.

    Best,
    Anton

  10. #10

    Default

    Just tried StrobeMediaPlayback_1.6.328 , debug-mobile.html

    Doing a Sanjose DVR - which again works on browser. On Android I get:

    Build 1.6.328 for Flash Player 10.1
    Flash Player version: AND 11,1,102,69
    Hardware Video Decoding: Yes
    Hardware Video Rendering: No

    Frame rate: 0.00 fps Dropped frames: 0
    Buffer length / time: 7.32s / 4.00s
    Memory usage: 10.05mb

    Stream state: buffering

Page 1 of 4 123 ... LastLast

Similar Threads

  1. Captions + HLS + OSMF Strobe Media Player
    By machado19 in forum Closed Captioning
    Replies: 1
    Last Post: 05-23-2014, 08:29 PM
  2. OSMF/Strobe Media Live Stream with Fallback
    By Petercarnyx in forum Media Players and Devices Discussion
    Replies: 1
    Last Post: 06-24-2013, 02:53 PM
  3. nDVR playback issues when using Strobe Media Player
    By tavius in forum AddOn: Wowza nDVR
    Replies: 6
    Last Post: 12-28-2012, 07:49 AM
  4. Adaptive Bitrate, nDVR, SMIL and OSMF Strobe
    By nonsense in forum AddOn: Wowza nDVR
    Replies: 3
    Last Post: 06-28-2012, 02:38 PM
  5. Play and Pause OSMF Strobe Media Playeur - RTMP Live with playlist
    By louminsk in forum Server-side Modules and Code Samples Discussion
    Replies: 0
    Last Post: 06-19-2012, 06:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •