Results 1 to 2 of 2

Thread: Cupertino streaming playlist shows mp3 instead of ts chunks

  1. #1
    Join Date
    Feb 2012
    Posts
    4

    Default Cupertino streaming playlist shows mp3 instead of ts chunks

    I'm live streaming audio only from a Shoutcast server through Wowza 3.0.3. I've set up secure streaming based on the instructions for the "internal method" and added ModuleEncryptionHandlerCupertinoStreaming. I'm able to successfully play the stream on an iPhone and iPad using an HTTPS url.

    I'm trying to do the steps outlined in the guide for verifying AES encryption. When I down load the playlist, I don't see "ts" segements, but "mp3" ones.

    Date: Thu, 16 Feb 2012 20:33:00 GMT
    Content-Type: application/vnd.apple.mpegurl
    Server: FlashCom/3.5.7
    Cache-Control: no-cache
    Content-Length: 382

    #EXTM3U
    #EXT-X-VERSION:2
    #EXT-X-ALLOW-CACHE:NO
    #EXT-X-TARGETDURATION:10
    #EXT-X-MEDIA-SEQUENCE:238
    #EXT-X-KEY:METHOD=AES-128,URI="https://media.hireindex.com/live/_definst_/stream1.stream/key.m3u8key?wowzasessionid=1360968800"
    #EXTINF:10,
    media_238.mp3?wowzasessionid=1360968800
    #EXTINF:10,
    media_239.mp3?wowzasessionid=1360968800
    #EXTINF:10,
    media_240.mp3?wowzasessionid=1360968800

    Is this correct or should they be "ts" segments as outlined in the AES verification?

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    That's correct for audio-only m3u8 playlist: either .mp3 or .aac chunks

    Richard

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •