Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Streaming Problem

  1. #1
    Join Date
    Feb 2012
    Posts
    8

    Default Streaming Problem

    http://localhost:1935/
    Display this message
    Wowza Media Server 3 Developer Edition (Expires: ago 19, 2012) 3.0.5 build1220

    http://[wowza-ip-address]:1935> I put this one > http://127.0.0.1:1935/
    Display this message
    Wowza Media Server 3 Developer Edition (Expires: ago 19, 2012) 3.0.5 build1220

    with Flash Encoder configurate as rtmp://127.0.0.1/live and streamer = livestream

    Connection via http://localhost:1935 and with external flash player in my personal web in my computer are works fine,
    but any external computer not work. (server not found: rtmp://127.0.0.1/live )

    ????

  2. #2

    Default

    If the encoder is running on a different machine than the server running Wowza Media Server then you cannot use localhost to address the Wowza Media Server. You must instead use the Wowza Media Server external or NAT IP address. Also, be sure that TCP port 1935 is open on the machine running Wowza Media Server. You can test connectivity to the server from the machine running the encoding software by opening a web browser and entering the address:

    http://[wowza-ip-address]:1935

    Where [wowza-ip-address] is the external or NAT Ip address of the server running Wowza Media Server. Once you get this working then use this same address in your rtmp URL.

    Charlie

  3. #3
    Join Date
    Feb 2012
    Posts
    8

    Default

    Thank you for your reply.

    this is my web site player configu.
    <td width="18%" align="center"><img src="img/Poster/tv01.JPG" width="170" height="430" /></td>
    <td width="65%" align="center"><script type='text/javascript' src='http://mediacp2.comcities.com/system/misc/jwplayer/swfobject.js'></script>
    <div id='mediaspace'></div>
    <p>
    <script type='text/javascript'>
    var so = new SWFObject('http://mediacp2.comcities.com/system/misc/jwplayer/player.swf','mpl','608','431','9');
    so.addParam('allowfullscreen','true');
    so.addParam('allowscriptaccess','always');
    so.addParam('wmode','opaque');
    so.addVariable('file','livestream');
    so.addVariable( 'image', 'http://www.mahamevnawaeurope.org/img/Buttons/backtv1.png');
    so.addVariable('streamer','rtmp://127.0.0.1:1935/live');
    so.write('mediaspace');
    </script>



    this is wowsa server when activated.




    VHost.xml

    - <Root>
    - <VHost>
    - <HostPortList>
    - <HostPort>
    <ProcessorCount>4</ProcessorCount>
    <IpAddress>*</IpAddress>
    - <!-- Separate multiple ports with commas
    -->
    - <!-- 80: HTTP, RTMPT
    -->
    - <!-- 554: RTSP
    -->
    <Port>1935</Port>
    - <SocketConfiguration>
    <ReuseAddress>true</ReuseAddress>
    - <!-- suggested settings for video on demand applications
    -->
    <ReceiveBufferSize>24000</ReceiveBufferSize>
    <SendBufferSize>65000</SendBufferSize>
    - <!--
    suggest settings for low latency chat and video recording applications
    <ReceiveBufferSize>16000</ReceiveBufferSize>
    <SendBufferSize>16000</SendBufferSize>


    -->
    <KeepAlive>true</KeepAlive>
    - <!-- <TrafficClass>0</TrafficClass>
    -->
    - <!-- <OobInline>false</OobInline>
    -->
    - <!-- <SoLingerTime>-1</SoLingerTime>
    -->
    - <!-- <TcpNoDelay>false</TcpNoDelay>
    -->
    <AcceptorBackLog>100</AcceptorBackLog>
    </SocketConfiguration>
    <HTTPStreamerAdapterIDs>cupertinostreaming,smoothstreaming,sanjosestreaming,dvrchunkstreaming</HTTPStreamerAdapterIDs>
    - <HTTPProviders>
    - <HTTPProvider>
    <BaseClass>com.wowza.wms.http.HTTPCrossdomain</BaseClass>
    <RequestFilters>*crossdomain.xml</RequestFilters>
    <AuthenticationMethod>none</AuthenticationMethod>
    </HTTPProvider>
    - <HTTPProvider>
    <BaseClass>com.wowza.wms.http.HTTPClientAccessPolicy</BaseClass>
    <RequestFilters>*clientaccesspolicy.xml</RequestFilters>
    <AuthenticationMethod>none</AuthenticationMethod>

    What is the probelem that not work with extenal web page?

    Thanx be patient
    Last edited by siri49; 02-20-2012 at 01:52 AM.

  4. #4
    Join Date
    Sep 2011
    Posts
    1,931

    Default

    Hi
    The [Wowza-IP] needs to be the IP of the server not "127.0.0.1:1935" this IP is local to the computer you are using.

    See Charlie's instructions,
    If the encoder is running on a different machine than the server running Wowza Media Server then you cannot use localhost to address the Wowza Media Server. You must instead use the Wowza Media Server external or NAT IP address. Also, be sure that TCP port 1935 is open on the machine running Wowza Media Server. You can test connectivity to the server from the machine running the encoding software by opening a web browser and entering the address:

    http://[wowza-ip-address]:1935

    Where [wowza-ip-address] is the external or NAT Ip address of the server running Wowza Media Server. Once you get this working then use this same address in your rtmp URL.

    Charlie
    Jason

  5. #5
    Join Date
    Feb 2012
    Posts
    8

    Default

    let me try. thanx
    Last edited by siri49; 02-20-2012 at 09:13 AM.

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    This site will tell you:

    http://dnsstuff.com/dnsreport/

    Look at top where it says "Your IP Address: ......"

    Richard

  7. #7
    Join Date
    Feb 2012
    Posts
    8

    Default

    Thank you

  8. #8
    Join Date
    Feb 2012
    Posts
    8

    Default

    The port is working correctly. because We streaming with this server rtmp://mediacp2.comcities.com:1935 . we are streaming fine.
    I found some Ip addresses but, I can not find a Wowsa IP Address. yet
    Flash Encoder erro PROBLEM WITH PRIMARY SERVER.

  9. #9
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    The server is running at that IP, port 1935 is open, but there does not appear to be an application named "live".

    Take a look at this tutorial:

    http://www.wowza.com/forums/content....based-encoder)

    In steps 1, 2 and 3 you create and configure an application, named "live"

    Then make the FMS URL:
    rtmp://mediacp2.comcities.com:1935/live
    Richard

  10. #10

    Default

    I did try your server and VOD works. So the server is up and running. I tried the following:

    Server: rtmp://mediacp2.comcities.com/vod
    Stream: mp4:sample.mp4
    Charlie

Page 1 of 2 12 LastLast

Similar Threads

  1. problem in streaming
    By joinvisions in forum General Forum
    Replies: 1
    Last Post: 07-06-2013, 07:00 AM
  2. Streaming problem
    By Fedora15_user in forum Live Streaming and Encoder Discussion
    Replies: 4
    Last Post: 03-03-2013, 09:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •