Results 1 to 6 of 6

Thread: Problem with G711_MULAW while transcoding from video server GV-VS12 (rtsp, h.264)

  1. #1
    Join Date
    Feb 2012
    Posts
    3

    Default Problem with G711_MULAW while transcoding from video server GV-VS12 (rtsp, h.264)

    Hi all,

    I have problem with my video server GV-VS12 and restreaming it to flash. Flash player crashed while trying to open the stream

    my error log:

    WARN server comment 2012-02-23 14:43:11 - - - - - 870.267 - - - - - - - - CupertinoPacketHandler.handleHolder[live/_definst_/camera.stream]: Invalid video/audio codec combination for iPhone/iPod: video:H264 audio:G711_MULAW
    WARN server comment 2012-02-23 14:43:11 - - - - - 870.268 - - - - - - - - CupertinoPacketHandler.handleHolder[live/_definst_/camera.stream]: Invalid audio codec for iPhone/iPod:G711_MULAW

    my transcode.xml file

    <Root>
    <Transcode>
    <Encodes>
    <!-- Setup for 720p, high bandwith, main profile for desktop or set-top box -->
    <Encode>
    <Enable>false</Enable>
    <Name>720p</Name>
    <StreamName>mp4:${SourceStreamName}_720p</StreamName>
    <Video>
    <!-- H.264, PassThru, Disable -->
    <Codec>H.264</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <GPUID>-1</GPUID>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>1280</Width>
    <Height>720</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>main</Profile>
    <Bitrate>96000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>false</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>AAC</Codec>
    <Bitrate>48000</Bitrate>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 360p, high bandwith, main profile for desktop -->
    <Encode>
    <Enable>true</Enable>
    <Name>360p</Name>
    <StreamName>mp4:${SourceStreamName}_360p</StreamName>
    <Video>
    <!-- H.264, PassThru, Disable -->
    <Codec>H.264</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <GPUID>-1</GPUID>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>640</Width>
    <Height>360</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>main</Profile>
    <Bitrate>48000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>false</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>AAC</Codec>
    <Bitrate>48000</Bitrate>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 240p, medium bandwidth, baseline profile -->
    <Encode>
    <Enable>false</Enable>
    <Name>240p</Name>
    <StreamName>mp4:${SourceStreamName}_240p</StreamName>
    <Video>
    <!-- H.264, PassThru, Disable -->
    <Codec>H.264</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <GPUID>-1</GPUID>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>360</Width>
    <Height>240</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>baseline</Profile>
    <Bitrate>48000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>false</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>AAC</Codec>
    <Bitrate>48000</Bitrate>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    <!-- Setup for 160p, low bandwith, baseline profile for 3G mobile devices such as iOS, Android, Blackberry. -->
    <Encode>
    <Enable>true</Enable>
    <Name>160p</Name>
    <StreamName>mp4:${SourceStreamName}_160p</StreamName>
    <Video>
    <!-- H.264, PassThru, Disable -->
    <Codec>H.264</Codec>
    <!-- default, CUDA, QuickSync -->
    <Transcoder>default</Transcoder>
    <GPUID>-1</GPUID>
    <FrameSize>
    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    <FitMode>fit-height</FitMode>
    <Width>284</Width>
    <Height>160</Height>
    <!-- <Crop>0,0,0,0</Crop> -->
    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    </FrameSize>
    <Profile>baseline</Profile>
    <Bitrate>48000</Bitrate>
    <KeyFrameInterval>
    <FollowSource>false</FollowSource>
    <Interval>60</Interval>
    </KeyFrameInterval>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Audio>
    <!-- AAC, PassThru, Disable -->
    <Codec>AAC</Codec>
    <Bitrate>48000</Bitrate>
    </Audio>
    <Properties>
    </Properties>
    </Encode>
    </Encodes>
    <Decode>
    <Video>
    <Deinterlace>false</Deinterlace>
    <Overlays>
    <Overlay>
    <Enable>false</Enable>
    <Index>0</Index>
    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    <Opacity>100</Opacity>
    <Location>
    <X>5</X>
    <Y>5</Y>
    <Width>${ImageWidth}</Width>
    <Height>${ImageHeight}</Height>
    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    <Align>left,top</Align>
    </Location>
    </Overlay>
    </Overlays>
    <Parameters>
    </Parameters>
    </Video>
    <Properties>
    </Properties>
    </Decode>
    <StreamNameGroups>
    <!-- Note: Play stream using stream name ngrp:[stream-name]. -->
    <StreamNameGroup>
    <Name>${SourceStreamName}_all</Name>
    <Members>
    <Member>
    <EncodeName>720p</EncodeName>
    </Member>
    <Member>
    <EncodeName>360p</EncodeName>
    </Member>
    <Member>
    <EncodeName>240p</EncodeName>
    </Member>
    <Member>
    <EncodeName>160p</EncodeName>
    </Member>
    </Members>
    </StreamNameGroup>
    <StreamNameGroup>
    <Name>${SourceStreamName}_mobile</Name>
    <Members>
    <Member>
    <EncodeName>240p</EncodeName>
    </Member>
    <Member>
    <EncodeName>160p</EncodeName>
    </Member>
    </Members>
    </StreamNameGroup>
    </StreamNameGroups>
    <Properties>
    </Properties>
    </Transcode>
    </Root>

    Do you have any clue what may be wrong?

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    camera.stream contains the source stream which has ulaw audio track. So this WARN can be ignored, because you are going to use this stream in any client, you will only use the transcoded streams. They will AAC audio

    Richard

  3. #3
    Join Date
    Feb 2012
    Posts
    3

    Default

    Thx for replay but I don't understand your answer.

    WARN can be ignored, OK but it doesn't resolve my problem. My stream cannot be played, flash player is crushing while trying to play it.

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Play "camera.stream_360p", which is one of the transcoded streams you have enabled. In LiveVideoStream Wowza example Flash player:

    Server: rtmp://[wowza-address]:1935/live
    Stream: camera.stream_360p

    Richard

  5. #5
    Join Date
    Feb 2012
    Posts
    3

    Default

    I see. Thanks a lot. It works now!

    Works nice video and sound too.

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Great! Thanks for the update. Glad it's working

    Richard

Similar Threads

  1. Mux/Combine separate H.264 video from RTSP source and AAC audio from RTSP Source
    By IPVSINC in forum Wowza Streaming Engine functionality
    Replies: 2
    Last Post: 12-05-2013, 06:01 AM
  2. Publishing recorded video H.264+AAC problem
    By heronman in forum General Forum
    Replies: 4
    Last Post: 06-11-2012, 06:46 AM
  3. Replies: 1
    Last Post: 05-07-2012, 05:29 AM
  4. Fixing video stutter problem in handbrake encoded h.264 video's
    By janvandenberg in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 12-14-2011, 11:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •