Results 1 to 3 of 3

Thread: WowzaMediaServer logging not working

  1. #1

    Default WowzaMediaServer logging not working

    Hi!

    Since yesterday my server has stopped appending to the log file. All I did was adding a new custom module to the server (such module uses the Amazon Web Services SDK which does automatic logging so maybe there could be an issue).

    When I start the server manually using the startup.sh script I get the following:

    /usr/local/WowzaMediaServer/lib/
    Configure logging: file:///usr/local/WowzaMediaServer/conf/log4j.properties
    log4j:ERROR setFile(null,true) call failed.
    java.io.FileNotFoundException: /usr/local/WowzaMediaServer/logs/wowzamediaserver_access.log (Read-only file system)
    	at java.io.FileOutputStream.openAppend(Native Method)
    	at java.io.FileOutputStream.<init>(FileOutputStream.java:207)
    	at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
    	at org.apache.log4j.FileAppender.setFile(Unknown Source)
    	at org.apache.log4j.FileAppender.activateOptions(Unknown Source)
    	at org.apache.log4j.DailyRollingFileAppender.activateOptions(Unknown Source)
    	at org.apache.log4j.config.PropertySetter.activate(Unknown Source)
    	at org.apache.log4j.config.PropertySetter.setProperties(Unknown Source)
    	at org.apache.log4j.config.PropertySetter.setProperties(Unknown Source)
    	at org.apache.log4j.PropertyConfigurator.parseAppender(Unknown Source)
    	at org.apache.log4j.PropertyConfigurator.parseCategory(Unknown Source)
    	at org.apache.log4j.PropertyConfigurator.configureRootCategory(Unknown Source)
    	at org.apache.log4j.PropertyConfigurator.doConfigure(Unknown Source)
    	at org.apache.log4j.PropertyConfigurator.configure(Unknown Source)
    	at com.wowza.wms.logging.WMSLoggerFactory.initializeLogging(Unknown Source)
    	at com.wowza.wms.logging.WMSLoggerFactory.initializeLogging(Unknown Source)
    	at com.wowza.wms.server.Server.b(Unknown Source)
    	at com.wowza.wms.server.Server.start(Unknown Source)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    	at java.lang.reflect.Method.invoke(Method.java:616)
    	at com.wowza.wms.bootstrap.Bootstrap.startServer(Unknown Source)
    	at com.wowza.wms.bootstrap.Bootstrap.main(Unknown Source)
    log4j:ERROR Either File or DatePattern options are not set for appender [serverAccess].
    The same error is repeated for the error log.

    Is there a way to force Wowza to recreate the log files? I tried to erase the log file but it won't let me due to the Read only file system...

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    It should not be read-only. You have to adjust the permissions on that folder.

    Richard

  3. #3
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Also ensure that you are logged in as root when running wowza:

    sudo su -

Similar Threads

  1. WowzaMediaServer too much use memories.
    By scdmd78 in forum Server Administration Discussion
    Replies: 9
    Last Post: 01-23-2013, 01:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •