Results 1 to 6 of 6

Thread: PushPublishing - "Failed to get the session" Error

  1. #1
    Join Date
    Jan 2012
    Posts
    7

    Question PushPublishing - "Failed to get the session" Error

    Hi all,

    I am using the PushPublishing AddOn to publish to several streaming services. My class is working fine with:
    • YouTube Live
    • Ustream
    • Livestream
    • Justin TV
    • FredoCast
    • Dinozap


    But I have a problem with:
    • Wii-Cast
    • Scity TV


    I allways get this errors:
    ERROR   server  comment 2012-02-29      11:52:41        -       -       -       -       -       720.764 -       -       -       -       -       -       -       -       execute: java.util.concurrent.RejectedExecutionException
    WARN    server  comment 2012-02-29      11:52:41        -       -       -       -       -       721.305 -       -       -       -       -       -       -       -       NetConnectionConnection.connect: Failed to connect[origin.scity.tv:1935]: org.apache.mina.common.RuntimeIOException: Failed to get the session[java.util.concurrent.RejectedExecutionException].
    WARN    server  comment 2012-02-29      11:52:41        -       -       -       -       -       721.317 -       -       -       -       -       -       -       -       NetConnectionConnection.connect: Failed to connect[stream.wii-cast.eu:1935]: org.apache.mina.common.RuntimeIOException: Failed to get the session[java.util.concurrent.RejectedExecutionException].
    These both services use Wowza servers (2.2.4 build27452 and 3.0.3 build882) and I can connect perfectly with FMLE, so the connection strings are OK.

    Anyone knows why I obtain this "Failed to get the session" error and what can I do to avoid it?

    Thank you in advance!

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Can you get logs from their side?

    Richard

  3. #3
    Join Date
    Jan 2012
    Posts
    7

    Default

    Hi Richard,

    Unfortunately I don't have any log from their side.

    Regards.

  4. #4

    Default

    The error indicates that the Wowza Media Server is not able to make a TCP connection to the Wowza Media Server on the other side. So it is some sort of TCP port 1935 communication problem. I would focus your attention there to start.

    Charlie

  5. #5
    Join Date
    Jan 2012
    Posts
    7

    Default

    Thank you, Charlie.

    Is very strange because I can connect without problems from FMLE and port TCP 1935 returns information via HTTP (http://stream.wii-cast.eu:1935/ and http://origin.scity.tv:1935/).

  6. #6

    Default

    Are you connecting from the same machine that is running Wowza Media Server? Is there any other firewall or protection getting in the way? There could be something on their end that is blocking the connection but I have no idea how or why.

    Charlie

Similar Threads

  1. Replies: 1
    Last Post: 05-18-2014, 04:00 PM
  2. Getting "Session not accepted" with HLS streaming
    By cladmin in forum Live Streaming and Encoder Discussion
    Replies: 3
    Last Post: 05-08-2013, 11:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •