Results 1 to 7 of 7

Thread: Out of sync: 0x80

  1. #1
    Join Date
    Oct 2011
    Posts
    6

    Default Out of sync: 0x80

    when I use vlc or ffmpeg stream to wowza ,it use a.stream file,then there is many WARN logs.But play is good。
    How can i solve it?

    WARN server comment - RTPDePacketizerMPEGTS.handleRTPPacket: Out of sync: 0x80

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Are there many of these WARN lines? If not, and if streaming is okay, then I wouldn't worry about it.

    Richard

  3. #3
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    It could be two encoder sending stream to same port. It could also be that stream is not aligned. What version of Wowza are you using?

    Richard

  4. #4
    Join Date
    Oct 2011
    Posts
    6

    Default

    There are many WARN lines,I check the config file aging。Tank you。

  5. #5
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Do you have two streams using the same port? Please describe in detail what you are doing. What encoder? How are you starting streams?

    Richard

  6. #6
    Join Date
    Apr 2013
    Posts
    3

    Default

    Although is not my thread, I prefer dont create another one about the same error.

    I have made a little application with live555 (something like testH264VideoStreamer.cpp but as unicast instead of multicast) and wowza server shows in the console:

    INFO server comment - RTPUDPTransport.bind[live/_definst_]: /0.0.0.0:10000
    INFO stream publish mpegts1.stream -
    INFO server comment - RTPMediaCaster.Reconnector[991552899:live/_definst_:mpegts1.stream]: done: 4
    WARN server comment - RTPDePacketizerMPEGTS.handleRTPPacket: Out of sync: 0x80
    INFO server comment - UDPTransport.firstPacket: bind:/0.0.0.0:10000 msg:/192.168.3.2:18888
    WARN server comment - RTPDePacketizerMPEGTS.handleRTPPacket: Out of sync: 0x80
    WARN server comment - RTPDePacketizerMPEGTS.handleRTPPacket: Out of sync: 0x80
    WARN server comment - RTPDePacketizerMPEGTS.handleRTPPacket: Out of sync: 0x80
    WARN server comment - RTPDePacketizerMPEGTS.handleRTPPacket: Out of sync: 0x80
    INFO server comment - RTPMediaCaster.streamTimeout[991552899:live/_definst_:mpegts1.stream]: timeout:12000 diff:12009 reason:101
    INFO server comment - RTPMediaCaster.resetConnection[991552899:live/_definst_:mpegts1.stream]:
    INFO server comment - RTPMediaCaster.closeRTPSession[991552899:live/_definst_:mpegts1.stream]
    INFO server comment - [WowzaTest]: onRTPSessionDestroy: 1854594024
    INFO server comment - RTPUDPTransport.unbind[live/_definst_]: /0.0.0.0:10000 sent:0 recv:12167
    INFO stream unpublish mpegts1.stream -
    INFO server comment - [WowzaTest]: onStreamDestroy: [-1]: 4
    INFO stream destroy mpegts1.stream -
    INFO server comment - RTPMediaCaster.Reconnector[991552899:live/_definst_:mpegts1.stream]: start: 5
    INFO server comment - RTPSessionDescriptionDataProviderBasic.getStreamInfo[live/_definst_]: URI: udp://0.0.0.0:10000
    INFO server comment - [WowzaTest]: onRTPSessionCreate: 1054811735
    INFO server comment - [WowzaTest]: onStreamCreate: [-1]: 5
    INFO stream create - -
    INFO server comment - RTPUDPTransport.bind[live/_definst_]: /0.0.0.0:10000
    INFO stream publish mpegts1.stream -
    INFO server comment - RTPMediaCaster.Reconnector[991552899:live/_definst_:mpegts1.stream]: done: 5
    WARN server comment - RTPDePacketizerMPEGTS.handleRTPPacket: Out of sync: 0x80
    INFO server comment - UDPTransport.firstPacket: bind:/0.0.0.0:10000 msg:/192.168.3.2:18888
    WARN server comment - RTPDePacketizerMPEGTS.handleRTPPacket: Out of sync: 0x80
    WARN server comment - RTPDePacketizerMPEGTS.handleRTPPacket: Out of sync: 0x80
    WARN server comment - RTPDePacketizerMPEGTS.handleRTPPacket: Out of sync: 0x80
    Any suggestion?

    Many thanks in advance!

  7. #7
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    It could be packet loss in the network before Wowza, that's what it looks like. Take a look at the Wowza Jitter Buffer. It cannot fix this for mpeg-ts stream but it can log packet loss that is helpful for debuging:

    http://www.wowza.com/forums/content....P-and-MPEG-TS)

    Richard

Similar Threads

  1. Wowza Streaming out of sync.. VLC in sync
    By WebDev4Life in forum Media Players and Devices Discussion
    Replies: 4
    Last Post: 07-25-2013, 06:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •