Results 1 to 2 of 2

Thread: LiveMediaStreamReceiver.connect: failure

  1. #1

    Default LiveMediaStreamReceiver.connect: failure

    I've always used devpay instances in the past, but in order to configure a server for a customer I set up my first lickey (Daily license) instance today. Since I need to configure Transcoder add-on for my customer I created a large instance. My overall goal is to configure a large instance with transcoder and load balancing listener & sender, and a small instance with load balancing sender.

    I set up an application named live. I've use the approach I've used before to configure origin/edge and load balancing. I start Wowza running, then I start a stream running from a Windows machine with FMLE. In the error log I see:

    INFO server comment - Wowza Media Server is started!
    INFO server comment - LoadBalancerServer.handleMessage[b1a16fdc-393e-4565-ad40-cbc1603812f0]: status: RUNNING
    INFO server comment - ServerListenerEC2Variables#ApplicationInstanceNotify.onApplicationInstanceCreate[live/_definst_]: Auto-set application RTSP addresses: internal[bind]:10.118.70.42 external[origin,connection]:107.21.230.170
    INFO application app-start _definst_ live/_definst_
    INFO session connect-pending 75.57.217.11 -
    INFO session connect 75.57.217.11 -
    INFO stream create - -
    INFO stream publish avatar -
    INFO session connect-pending 75.57.217.11 -
    INFO session connect 75.57.217.11 -
    INFO stream create - -
    INFO stream create - -
    WARN server comment - LiveMediaStreamReceiver.connect: failure
    INFO server comment - MediaStreamMediaCasterPlay: startPlay


    I am disturbed by that LiveMediaStreamReceiver.connect: failure. What does that message indicate?

    I then stopped and restarted the encoder. I then saw in the log:

    INFO server comment - MediaStreamMediaCasterPlay: close
    INFO stream unpublish avatar -
    INFO stream destroy avatar -
    INFO stream create - -
    INFO stream publish avatar -
    java.lang.NullPointerException
    at com.wowza.wms.stream.live.LivePlayer.playAllInternal(Unknown Source)
    at com.wowza.wms.stream.live.LivePlayer.playAll(Unknown Source)
    at com.wowza.wms.stream.live.LivePlayer.play(Unknown Source)
    at com.wowza.wms.stream.live.MediaStreamLivePlayAbstract.play(Unknown Source)
    at com.wowza.wms.stream.mediacaster.MediaStreamMediaCasterPlay.play(Unknown Source)
    at com.wowza.wms.response.ResponseStreams.output(Unknown Source)
    at com.wowza.wms.request.RTMPRequestAdapter.service(Unknown Source)
    at com.wowza.wms.server.ServerHandler.a(Unknown Source)
    at com.wowza.wms.server.ServerHandler.a(Unknown Source)
    at com.wowza.wms.server.ServerHandler.sessionIdle(Unknown Source)
    at com.wowza.wms.server.ServerHandlerThreadedSession.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
    at java.lang.Thread.run(Thread.java:679)
    INFO server comment - MediaStreamMediaCasterPlay: close
    INFO stream unpublish avatar -
    INFO stream destroy avatar -
    INFO stream create - -
    INFO stream publish avatar -
    INFO session comment 1936083762 client connectionClosed [1936083762] pingtimeout
    INFO server comment - MediaStreamMediaCasterPlay: close
    INFO stream destroy avatar -

    Any clue what I most likely misconfigured?

  2. #2
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    I suggest to start with a simple live application with Transcoder enabled. Get that working first, then add in LiveRepeater

    Richard

Similar Threads

  1. Replies: 4
    Last Post: 06-01-2012, 03:09 PM
  2. Errors with LiveMediaStreamReceiver
    By grantk in forum Server-side Modules and Code Samples Discussion
    Replies: 2
    Last Post: 01-27-2012, 08:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •