Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Wowza doesn't stream to android device

  1. #1

    Default Wowza doesn't stream to android device

    I've tried to stream content to Android device, but I have following error:
    This page contains the following errors:
    
    error on line 3 at column 83: EntityRef: expecting ';'
    Below is a rendering of the page up to the first error.
    Source of the page is( I replaced names by [...] ) :
    <?xml version="1.0" encoding="utf-8"?>
    <manifest xmlns="http://ns.adobe.com/f4m/1.0">
    	<id>amazons3/[bucket_name]/[movie].mp4?wowzaplaystart=5515300&wowzaplayduration=60100</id>
    	<width>320</width>
    	<height>240</height>
    	<duration>60.56</duration>
    	<mimeType>video/mp4</mimeType>
    	<streamType>recorded</streamType>
    	<deliveryType>streaming</deliveryType>
    	<bootstrapInfo profile="named" id="bootstrap1">[data]</bootstrapInfo>
    	<media streamId="1" bootstrapInfoId="bootstrap1" width="320" height="240" bitrate="485" url="media_b497407_w1713054599_ps5515300_pd60100.abst/">
    		<metadata>[data]</metadata>
    	</media>
    </manifest>
    Column 83 in error message is '=' character after 'wowzaplayduration' parameter.

    Can somebody explain to me why it happens? I use Wowza 3.0.0 for Amazon EC2.

  2. #2

    Default

    Hello greenf,

    What is the stream URI you are trying to play?

  3. #3

    Default

    http://<host>:1935/vods3/WZsCuubu2htmb/manifest.f4m
    We also use ModuleStreamNameAsAlias to translate the mp4:amazons3/<bucket_name>/<movie>.mp4?wowzaplaystart=<timeIn>&wowzaplayduration=<duration>. I've checked logs and saw that code has been translated to correct bucket name, movie name, time in and duration.

  4. #4

    Default

    What Flash client are you using to play this stream?

  5. #5

    Default

    FlashPlayer 11.1 at 'Samsung Galaxy S, GT-I9000' smartphone. I've just copied the link above into default browser. Firmware version 2.2, kernel version 2.6.32.9. Perhaps it will be usefull too.
    Another usefult facts:
    After I've opened this post, I've created wowza application without encryption and modulestreamnameasalias, to narrow the issue. Ina ddition I tried to play rtsp link too.
    1. Link 'http://<host>:1935/alls3/_definst_/mp4:amazons3/<bucket_name>/<movie>.mp4/manifest.f4m' does not report any error, but also doesn't play movie. It just displays XML returned from wowza. So the initial issue related to '&' and/or '=' characters. However, even if it will be solved, other issue is that device identifies the link as file and not as stream.
    2. Link 'rtsp://<host>:1935/alls3/_definst_/mp4:amazons3/<bucket_name>/<movie>.mp4' causes player start but it reports 'movie cannot be played', but it is not encoding issue, since we also have ApacheHttpServer with streaming plugin and I can stream same movie to the device above from it.

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    You need a Flash player to play a sanjosestream (The manifest.f4m url)

    The easiest option is Flash Media Playback (hosted Strobe player):

    http://www.wowza.com/forums/content....h-Wowza-Server

    Make sure to check the box labeled "In the Flash Media Playback configurator, you have to check "Are you using HTTP Streaming or Flash Access 2.0?". Then enter your URL

    Richard
    Last edited by rrlanham; 03-08-2012 at 02:54 PM.

  7. #7

    Default

    Sorry, but I don't understand your answer. As I wrote my device has Flash Player 11.1 installed, but it still doesn't play. In addition, your link is to article about about encoding with VLC. I don't know how it helps to play content on android devices with Wowza. Can you explain again.

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Sorry, wrong link. This is the one:

    http://www.wowza.com/forums/content....h-Wowza-Server

    You have to add the http manifest.f4m url in that, then use the embed tag on your web page, then navigate to that web page in the device

    Richard

  9. #9

    Default

    I'm also use manifest.f4m, but I made request directly from browser address bar and it didn't work. Is embed tag will work? In addition, I try to use http protocol and all examples in your link are RTMP.

  10. #10
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    There is this configurator, you have to follow the links and instructions. You enter the manifest.f4m URL in the configurator, in the "Video Source (url)" field, then click Preview and it generates embed code. You copy the embed that is generated to a web page on your server. That will be the player page. You will then navigate to that page in the mobile device.

    Richard

Page 1 of 2 12 LastLast

Similar Threads

  1. Stream video live from Android device
    By deepanjanghosh16 in forum Live Streaming and Encoders
    Replies: 4
    Last Post: 04-28-2014, 09:26 AM
  2. Live Stream is very slow from android device
    By Chandani in forum Media Players and Devices Discussion
    Replies: 1
    Last Post: 03-21-2014, 02:02 AM
  3. Live Stream is very slow from android device
    By Chandani in forum Media Players and Devices Discussion
    Replies: 0
    Last Post: 03-21-2014, 02:02 AM
  4. Replies: 1
    Last Post: 02-21-2014, 07:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •