Results 1 to 8 of 8

Thread: Wowza DVR stores not all content because wowza reconnects to streams.

  1. #1

    Default Wowza DVR stores not all content because wowza reconnects to streams.

    Hi,

    We use DVR recording API to writing our incoming multicast channels per day. Recently I wrote that we can't get 24 hours of recording and we learned that the problem refers to garbage in our streams and wowza just skipping that packets. But then we switched to very clean source and we see that garbage just disappear. So we expected that we get our 24 hours of recording per day but not. Only ~22.

    I've searched for a while for logs and see that our UDP incoming multicast streams restarting after timeout of 12 sec. And I think that this is key for our problem but I can't solve it.

    restarting messages like:
    INFO server comment - RTPMediaCaster.streamTimeout[1604382968:live/_definst_:kids_co_360p.stream]: timeout:12000 diff:17044 reason:101
    INFO server comment - RTPMediaCaster.streamTimeout[1521938905:live/_definst_:expert_tv_270p.stream]: timeout:12000 diff:17054 reason:101
    INFO server comment - RTPMediaCaster.streamTimeout[1437066670:live/_definst_:hd_travelch_360p.stream]: timeout:12000 diff:13539 reason:101
    INFO server comment - RTPMediaCaster.streamTimeout[1450492277:live/_definst_:france24_576p.stream]: timeout:12000 diff:15566 reason:101

    How do you think what's wrong?
    Is it problem with our incoming streams or in wowza configuration?


    I've started to use MediaCasterStreamMonitorAdvanced http://www.wowza.com/forums/content....onitorAdvanced with its default settings to see what's wrong and the problem is here:

    2012-03-23      16:59:14        MSK     comment server  INFO    200     -       ModuleMediaCasterStreamMonitorAdvanced.onValidateMediaCaster[live/_definst_] Stream not healthy [stream timeout]: flv:pervii_kanal.stream       -       -       -       523.795 -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -
    But why wowza thinks that stream timeout??? I've monitored in next console by tcpdump that all packets continiously send to wowza.

    I've already tried to switch between wowza versions: Wowza Media Server 3.0.5.02 build1257 and latest Wowza 2. This problem exists.

    I change option RTPTransportMode to UDP (also try with interleave):
                           <RTP>
                                  <RTSP>
                                          <!-- udp, interleave -->
                                          <RTPTransportMode>udp</RTPTransportMode>
                                  </RTSP>
                          </RTP>
    And I try to dump our udp multicast mpeg-ts incoming streams with mplayer:

    mplayer udp://228.8.10.1:10001 -v -dumpstream -dumpfile 1.ts
    and it dumps fine without any interruptions.

    Here is a piece of our dumped stream:
    http://www.sendspace.com/file/sqr3w2

    Here is my debug screenlog. And confs and logs that tared:

    http://www.sendspace.com/filegroup/x...mWfO84XjKiVtcU


    So there is 1 problem that as I think due to another:

    Problem is: dvr stores not all stream
    Because: (as I think) wowza reconnects after timeout to our streams and then a piece of stream get lost.

    Please help to solve this problem. Thanks.
    Last edited by xzerth; 03-23-2012 at 07:21 AM.

  2. #2
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Did you try to do anything with the Watchdog example I suggested in the ticket?

    For testing and comparison, have you tried taking nDVR out and just doing simple recording by making the StreamType "live-record"?

    Richard

  3. #3

    Default

    Richard,
    I've post it here because I haven't get any response from you.

    I've searched in spam but there is no message.
    Please send me again. Thank you.


    About your auestion - we don't need "just recording". We need exactly nDVR with that features that it's support and even more. So I can of course, but should we need to do this?

  4. #4
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    I suggested you take a look at this watchdog example:
    http://www.wowza.com/forums/content....tream-Watchdog

    You might extend it a little to log timestamps, and its basic feature of watching the stream might be useful to debug this problem.

    The other suggestion is to try without nDVR, just simple recording with StreamType "live-record", just to see if that is expected length. If there are interruptions you should see more versioned recordings. myStream_01.mp4, etc. for each interuption.

    (for reference, the ticket is 25276)

    Richard

  5. #5

    Default

    Well, I can't extend this module...

    But I try to record through Live Stream Record and it interrupts when server restart incoming connections.

    Anything else?

  6. #6
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Sounds like there is a network problem. Any restart will mean you are going to come up short for the 24 hour period.

    Richard

  7. #7
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    If possible, try a test that is all local, i.e. take the network out.

    Richard

  8. #8

    Default

    Richard,

    All this time we investigate this problem and you're right. It's our network problem between encoder and wowza. So problem is not in wowza.

    Thanks!

Similar Threads

  1. Getting a list of DVR Stores
    By jdrwor in forum Wowza nDVR
    Replies: 1
    Last Post: 07-21-2014, 01:35 PM
  2. Uploading and serving Wowza DVR content from AWS S3.
    By benbowler in forum Wowza nDVR
    Replies: 1
    Last Post: 05-14-2014, 06:22 AM
  3. Deleting DVR content
    By tavius in forum AddOn: Wowza nDVR
    Replies: 3
    Last Post: 03-06-2014, 09:08 PM
  4. Replies: 1
    Last Post: 11-15-2012, 04:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •