Results 1 to 5 of 5

Thread: application not reponding to ios request

  1. #1
    Join Date
    Aug 2011
    Posts
    116

    Default application not reponding to ios request

    Hi
    I have a vlc encoder with baseline of 3.0 like you recommend.
    Also i am using wowza 3.0.3.
    I have several applications with the same configuration.

    every couple of days my users (ios users) can't watch the streams.
    the strange thing about it that it happens every time in different a application.

    so even if the applications are identical from one application(stream) it keeps working and
    i can view the stream from all ios devices but from anther application(stream) i can't even tow they are identical.
    only when i restart the application it fixes it.

    is that a known problem?
    Last edited by asaf32; 03-25-2012 at 10:53 AM.

  2. #2
    Join Date
    Aug 2011
    Posts
    116

    Default

    Hi
    I have anther question.
    is there a way to disconnect users?
    for example if they have connected to my wowza ans passe the security check.
    can i disconnect them if i know the details like session id?
    maybe to pass the session id with get (httputils) and then somehow disconnect the user?

    thx
    asaf

  3. #3
    Join Date
    Aug 2011
    Posts
    116

    Default

    Hi
    please get back to me regarding ios users, it's affecting all of my clients and each time i need to restart the application.
    nothing is written in the logs. and the onlt solution for me right know is to restart the application.
    please get back to me
    /thanks

  4. #4
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    Apologies for not getting back to you sooner.
    Even though there may not be any errors or such in the logs, please send zip conf/ and logs/ folders to support@wowza.com
    so we can take a look and track what is happening. Please indicate some time frame when this problem is occurring.
    Please reference this thread in the support email that you send.
    I would also suggest moving to the latest Wowza Media Server version, 3.0.5

    - Daren
    Last edited by daren_j; 03-27-2012 at 02:16 PM.

  5. #5
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Re: Disconnecting users:

    You could use
    httpSession.shutdown();

    Example: the following will disconnect every http session:

     List<IHTTPStreamerSession> HTTPClients = appInstance.getHTTPStreamerSessions();
        Iterator<IHTTPStreamerSession> HTTPClientIter = HTTPClients.iterator();
        while ( HTTPClientIter.hasNext() )  
        {  
       try {
        IHTTPStreamerSession client = HTTPClientIter.next();
    
        if ( client == null ) 
         continue;
        client.shutdown();
        totalDisconnect++;
        } catch (Exception E) {}
        }
    - Daren
    Last edited by daren_j; 03-27-2012 at 01:54 PM.

Similar Threads

  1. SMIL request playlist multi bitrate with iOS Audio Only rendition
    By Meinaart in forum Video On Demand Streaming Discussion
    Replies: 2
    Last Post: 01-27-2014, 02:53 PM
  2. Application.xml settings for IOS
    By kmax1940 in forum General Forum
    Replies: 5
    Last Post: 09-05-2013, 11:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •