Results 1 to 4 of 4

Thread: Transcoder exception

  1. #1
    Join Date
    May 2010
    Posts
    7

    Default Transcoder exception

    I have 2 identical machines in every way. Both have 16 cores, 48GB RAM, latest version of Wowza, identical config & application files (except IP addresses).

    On machine 1, when I run my application.xml with push publish and transcoder, everything works as it's supposed to. On machine 2, I run the identical application.xml and transrate.xml files and get the following error. Any clue on what might be causing this? I checked and all of the lib files in all of the folders are identical.

    INFO stream unpublish stream2 -
    INFO stream create - -
    INFO stream publish stream2 -
    Exception in thread "VHostHandler._defaultVHost_.351" java.lang.NoClassDefFoundError: Could not initialize class com.wowza.wm
    s.transcoder.model.TranscoderSessionNative
    at com.wowza.wms.transcoder.model.TranscoderSession.<init>(Unknown Source)
    at com.wowza.wms.transcoder.model.LiveStreamTranscoder.<init>(Unknown Source)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:525)
    at java.lang.Class.newInstance0(Class.java:372)
    at java.lang.Class.newInstance(Class.java:325)
    at com.wowza.wms.stream.livetranscoder.LiveStreamTranscoderFactory.createInstance(Unknown Source)
    at com.wowza.wms.stream.live.LiveReceiver.a(Unknown Source)
    at com.wowza.wms.stream.live.LiveReceiver.initPacketizers(Unknown Source)
    at com.wowza.wms.stream.live.LiveReceiver.newOnMetadata(Unknown Source)
    at com.wowza.wms.stream.live.LiveReceiver.addDataData(Unknown Source)
    at com.wowza.wms.stream.live.MediaStreamLive.addDataData(Unknown Source)
    at com.wowza.wms.request.RequestProcessData.processNextRequest(Unknown Source)
    at com.wowza.wms.client.ClientWorker.processNextReq(Unknown Source)
    at com.wowza.wms.request.RTMPRequestAdapter.service(Unknown Source)
    at com.wowza.wms.server.ServerHandler.a(Unknown Source)
    at com.wowza.wms.server.ServerHandler.a(Unknown Source)
    at com.wowza.wms.server.ServerHandler.messageReceived(Unknown Source)
    at com.wowza.wms.server.ServerHandlerThreadedSession.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
    at java.lang.Thread.run(Thread.java:722)

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Check the requirements in this list

    http://www.wowza.com/forums/content.php?304#hwDriverReq

    The Windows you need .NET Framework 3.5.1, Desktop Experience

    Richard

  3. #3
    Join Date
    May 2010
    Posts
    7

    Default

    Thanks. I'll try that

  4. #4
    Join Date
    May 2010
    Posts
    7

    Default

    Very odd. .NET 3.5.1 is installed. A reboot solved the problem. Strange thing is, I rebooted after installing Wowza. Possible 3.5.1 choked?

    Thanks for the excellent guidance (as usual)!

Similar Threads

  1. transcoder java exception
    By sgtring in forum AddOn: Transcoder
    Replies: 3
    Last Post: 06-03-2013, 12:08 PM
  2. nDVR Exception
    By ozgurdeniz in forum AddOn: Wowza nDVR
    Replies: 3
    Last Post: 04-09-2013, 07:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •