Results 1 to 2 of 2

Thread: No response from Wowza

  1. #1

    Default No response from Wowza

    Hi,

    I setup Wowza on CentOS. It was working. Then, I upgraded some packages and restarted the server. Now, Wowza doesn't respond.

    When Wowza is started, the browser takes a long time to return "No data received". When Wowza is not started, it takes very short to return an error message. iptables is turned of, and the virtual host is configured for port 80.

    What may be wrong?

    Unfortunately, the log file does not change after Wowza starts up:

    Configure logging: file:///usr/local/WowzaMediaServer/conf/log4j.properties
    INFO server server-start Wowza Media Server 3 Trial Edition (Expires: Nis 17, 2012) 3.0.5 build1220 -
    INFO server comment - Server License Key: SVRT3-XXXXX-XXXXX-XXXXX-XXXXX-B7kup
    INFO server comment - Maximum Connections: Unlimited
    INFO server comment - Transcoder Streams Available: Unlimited
    INFO server comment - Transcoder Watermark: Yes
    INFO server comment - nDVR Available: Yes
    INFO server comment - DRM Available: Yes
    INFO server comment - Hardware Available Processors: 1
    INFO server comment - Hardware Physical Memory: 3215MB/3824MB
    INFO server comment - Hardware Swap Space: 1983MB/1983MB
    INFO server comment - Max File Descriptor Count: 20000
    INFO server comment - Open File Descriptor Count: 46
    INFO server comment - OS Name: Linux
    INFO server comment - OS Version: 2.6.32-220.7.1.el6.x86_64
    INFO server comment - OS Architecture: amd64
    INFO server comment - Java Name: OpenJDK 64-Bit Server VM
    INFO server comment - Java Vendor: Sun Microsystems Inc.
    INFO server comment - Java Version: 1.6.0_22
    INFO server comment - Java VM Version: 20.0-b11
    INFO server comment - Java Spec Version: 1.6
    INFO server comment - Java Home: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre
    INFO server comment - Java Max Heap Size: 1160MB
    INFO server comment - Java Architecture: 64
    INFO server comment - Java Locale[user.language]: tr
    INFO server comment - Java Locale[user.country]: TR
    INFO server comment - Java Locale[file.encoding]: UTF-8
    INFO server comment - Java Args[0]: -Xmx1200M
    INFO server comment - Java Args[1]: -Djava.net.preferIPv4Stack=true
    INFO server comment - Java Args[2]: -Dcom.sun.management.jmxremote=true
    INFO server comment - Java Args[3]: -Dcom.wowza.wms.runmode=standalone
    INFO server comment - Java Args[4]: -Dcom.wowza.wms.native.base=linux
    INFO server comment - Java Args[5]: -Dcom.wowza.wms.AppHome=/usr/local/WowzaMediaServer
    INFO server comment - Java Args[6]: -Dcom.wowza.wms.ConfigURL=
    INFO server comment - Java Args[7]: -Dcom.wowza.wms.ConfigHome=/usr/local/WowzaMediaServer
    INFO server comment - Server runmode: standalone
    INFO server comment - Server native.platform: linux
    INFO server comment - Server threads[h/t]: 10/10
    INFO server comment - CMDInterface now listening: [any]:8083
    INFO vhost vhost-start _defaultVHost_ -
    INFO server comment - _defaultVHost_ threads[h/t]:120/80 home:/usr/local/WowzaMediaServer
    INFO vhost comment _defaultVHost_ Bind attempt ([any]:80:4)
    INFO vhost comment _defaultVHost_ Bind successful ([any]:80)
    INFO vhost comment _defaultVHost_ Bind attempt ([any]:8086:1)
    INFO vhost comment _defaultVHost_ Bind successful ([any]:8086)
    INFO server comment - Wowza Media Server is started!
    In the output of
    netstat -an
    I see the following lines:

    tcp        0      0 0.0.0.0:80                  0.0.0.0:*                   LISTEN      
    tcp        0      0 0.0.0.0:8083                0.0.0.0:*                   LISTEN      
    tcp        0      0 0.0.0.0:8086                0.0.0.0:*                   LISTEN      
    tcp        0      0 SERVER_IP:80             MY_IP:28536          ESTABLISHED
    Last edited by mustihi83; 03-31-2012 at 12:59 PM.

  2. #2

    Default

    Try with a default 3.0.5 VHost.xml:
    <?xml version="1.0"?>
    -<Root> -<VHost> -<HostPortList> -<HostPort> <ProcessorCount>4</ProcessorCount> <IpAddress>*</IpAddress> 
    <!-- Separate multiple ports with commas -->
     
    <!-- 80: HTTP, RTMPT -->
     
    <!-- 554: RTSP -->
     <Port>1935</Port> -<SocketConfiguration> <ReuseAddress>true</ReuseAddress> 
    <!-- suggested settings for video on demand applications -->
     <ReceiveBufferSize>24000</ReceiveBufferSize> <SendBufferSize>65000</SendBufferSize> 
    <!-- suggest settings for low latency chat and video recording applications <ReceiveBufferSize>16000</ReceiveBufferSize> <SendBufferSize>16000</SendBufferSize> -->
     <KeepAlive>true</KeepAlive> 
    <!-- <TrafficClass>0</TrafficClass> -->
     
    <!-- <OobInline>false</OobInline> -->
     
    <!-- <SoLingerTime>-1</SoLingerTime> -->
     
    <!-- <TcpNoDelay>false</TcpNoDelay> -->
     <AcceptorBackLog>100</AcceptorBackLog> </SocketConfiguration> <HTTPStreamerAdapterIDs>cupertinostreaming,smoothstreaming,sanjosestreaming,dvrchunkstreaming</HTTPStreamerAdapterIDs> -<HTTPProviders> -<HTTPProvider> <BaseClass>com.wowza.wms.http.HTTPCrossdomain</BaseClass> <RequestFilters>*crossdomain.xml</RequestFilters> <AuthenticationMethod>none</AuthenticationMethod> </HTTPProvider> -<HTTPProvider> <BaseClass>com.wowza.wms.http.HTTPClientAccessPolicy</BaseClass> <RequestFilters>*clientaccesspolicy.xml</RequestFilters> <AuthenticationMethod>none</AuthenticationMethod> </HTTPProvider> -<HTTPProvider> <BaseClass>com.wowza.wms.http.HTTPProviderMediaList</BaseClass> <RequestFilters>*jwplayer.rss|*medialist.smil|*manifest-rtmp.f4m</RequestFilters> <AuthenticationMethod>none</AuthenticationMethod> </HTTPProvider> -<HTTPProvider> <BaseClass>com.wowza.wms.http.HTTPServerVersion</BaseClass> <RequestFilters>*</RequestFilters> <AuthenticationMethod>none</AuthenticationMethod> </HTTPProvider> </HTTPProviders> </HostPort> 
    <!-- 443 with SSL -->
     
    <!-- <HostPort> <ProcessorCount>4</ProcessorCount> <IpAddress>*</IpAddress> <Port>443</Port> <SSLConfig> <KeyStorePath>${com.wowza.wms.context.VHostConfigHome}/conf/keystore.cert</KeyStorePath> <KeyStorePassword>[password]</KeyStorePassword> <KeyStoreType>JKS</KeyStoreType> <SSLProtocol>TLS</SSLProtocol> <Algorithm>SunX509</Algorithm> <CipherSuites></CipherSuites> <Protocols></Protocols> </SSLConfig> <SocketConfiguration> <ReuseAddress>true</ReuseAddress> <ReceiveBufferSize>24000</ReceiveBufferSize> <SendBufferSize>65000</SendBufferSize> <KeepAlive>true</KeepAlive> <AcceptorBackLog>100</AcceptorBackLog> </SocketConfiguration> <HTTPStreamerAdapterIDs>cupertinostreaming,smoothstreaming,sanjosestreaming,dvrchunkstreaming</HTTPStreamerAdapterIDs> <HTTPProviders> <HTTPProvider> <BaseClass>com.wowza.wms.http.HTTPCrossdomain</BaseClass> <RequestFilters>*crossdomain.xml</RequestFilters> <AuthenticationMethod>none</AuthenticationMethod> </HTTPProvider> <HTTPProvider> <BaseClass>com.wowza.wms.http.HTTPClientAccessPolicy</BaseClass> <RequestFilters>*clientaccesspolicy.xml</RequestFilters> <AuthenticationMethod>none</AuthenticationMethod> </HTTPProvider> <HTTPProvider> <BaseClass>com.wowza.wms.http.HTTPProviderMediaList</BaseClass> <RequestFilters>*jwplayer.rss|*medialist.smil|*manifest-rtmp.f4m</RequestFilters> <AuthenticationMethod>none</AuthenticationMethod> </HTTPProvider> <HTTPProvider> <BaseClass>com.wowza.wms.http.HTTPServerVersion</BaseClass> <RequestFilters>*</RequestFilters> <AuthenticationMethod>none</AuthenticationMethod> </HTTPProvider> </HTTPProviders> </HostPort> -->
     
    <!-- Admin HostPort -->
     -<HostPort> <ProcessorCount>1</ProcessorCount> <IpAddress>*</IpAddress> <Port>8086</Port> -<SocketConfiguration> <ReuseAddress>true</ReuseAddress> <ReceiveBufferSize>16000</ReceiveBufferSize> <SendBufferSize>16000</SendBufferSize> <KeepAlive>true</KeepAlive> <AcceptorBackLog>100</AcceptorBackLog> </SocketConfiguration> <HTTPStreamerAdapterIDs/> -<HTTPProviders> -<HTTPProvider> <BaseClass>com.wowza.wms.http.streammanager.HTTPStreamManager</BaseClass> <RequestFilters>streammanager*</RequestFilters> <AuthenticationMethod>admin-digest</AuthenticationMethod> </HTTPProvider> -<HTTPProvider> <BaseClass>com.wowza.wms.http.HTTPServerInfoXML</BaseClass> <RequestFilters>serverinfo*</RequestFilters> <AuthenticationMethod>admin-digest</AuthenticationMethod> </HTTPProvider> -<HTTPProvider> <BaseClass>com.wowza.wms.http.HTTPConnectionInfo</BaseClass> <RequestFilters>connectioninfo*</RequestFilters> <AuthenticationMethod>admin-digest</AuthenticationMethod> </HTTPProvider> -<HTTPProvider> <BaseClass>com.wowza.wms.http.HTTPConnectionCountsXML</BaseClass> <RequestFilters>connectioncounts*</RequestFilters> <AuthenticationMethod>admin-digest</AuthenticationMethod> </HTTPProvider> -<HTTPProvider> <BaseClass>com.wowza.wms.transcoder.httpprovider.HTTPTranscoderThumbnail</BaseClass> <RequestFilters>transcoderthumbnail*</RequestFilters> <AuthenticationMethod>admin-digest</AuthenticationMethod> </HTTPProvider> -<HTTPProvider> <BaseClass>com.wowza.wms.http.HTTPProviderMediaList</BaseClass> <RequestFilters>medialist*</RequestFilters> <AuthenticationMethod>admin-digest</AuthenticationMethod> </HTTPProvider> -<HTTPProvider> <BaseClass>com.wowza.wms.http.HTTPServerVersion</BaseClass> <RequestFilters>*</RequestFilters> <AuthenticationMethod>none</AuthenticationMethod> </HTTPProvider> </HTTPProviders> </HostPort> </HostPortList> -<HTTPStreamerAdapters> -<HTTPStreamerAdapter> <ID>smoothstreaming</ID> <Name>smoothstreaming</Name> <Properties> </Properties> </HTTPStreamerAdapter> -<HTTPStreamerAdapter> <ID>cupertinostreaming</ID> <Name>cupertinostreaming</Name> <Properties> </Properties> </HTTPStreamerAdapter> -<HTTPStreamerAdapter> <ID>sanjosestreaming</ID> <Name>sanjosestreaming</Name> <Properties> </Properties> </HTTPStreamerAdapter> -<HTTPStreamerAdapter> <ID>dvrchunkstreaming</ID> <Name>dvrchunkstreaming</Name> <Properties> </Properties> </HTTPStreamerAdapter> </HTTPStreamerAdapters> -<HandlerThreadPool> <PoolSize>120</PoolSize> </HandlerThreadPool> -<TransportThreadPool> <PoolSize>80</PoolSize> </TransportThreadPool> -<IdleWorkers> <WorkerCount>4</WorkerCount> <CheckFrequency>50</CheckFrequency> <MinimumWaitTime>5</MinimumWaitTime> </IdleWorkers> -<NetConnections> <ProcessorCount>4</ProcessorCount> <IdleFrequency>250</IdleFrequency> -<SocketConfiguration> <ReuseAddress>true</ReuseAddress> <ReceiveBufferSize>65000</ReceiveBufferSize> <SendBufferSize>24000</SendBufferSize> <KeepAlive>true</KeepAlive> 
    <!-- <TrafficClass>0</TrafficClass> -->
     
    <!-- <OobInline>false</OobInline> -->
     
    <!-- <SoLingerTime>-1</SoLingerTime> -->
     
    <!-- <TcpNoDelay>false</TcpNoDelay> -->
     <AcceptorBackLog>100</AcceptorBackLog> </SocketConfiguration> </NetConnections> -<HTTPTunnel> <KeepAliveTimeout>2000</KeepAliveTimeout> </HTTPTunnel> -<Client> <ClientTimeout>90000</ClientTimeout> <IdleFrequency>250</IdleFrequency> </Client> 
    <!-- RTP/Authentication/Methods defined in Authentication.xml. Default setup includes; none, basic, digest -->
     -<RTP> <IdleFrequency>75</IdleFrequency> -<DatagramConfiguration> -<Incoming> <ReuseAddress>true</ReuseAddress> <ReceiveBufferSize>1024000</ReceiveBufferSize> <SendBufferSize>65000</SendBufferSize> 
    <!-- <MulticastBindToAddress>true</MulticastBindToAddress> -->
     
    <!-- <MulticastInterfaceAddress>192.168.1.22</MulticastInterfaceAddress> -->
     
    <!-- <TrafficClass>0</TrafficClass> -->
     <MulticastTimeout>50</MulticastTimeout> <DatagramMaximumPacketSize>4096</DatagramMaximumPacketSize> </Incoming> -<Outgoing> <ReuseAddress>true</ReuseAddress> <ReceiveBufferSize>65000</ReceiveBufferSize> <SendBufferSize>65000</SendBufferSize> 
    <!-- <MulticastBindToAddress>true</MulticastBindToAddress> -->
     
    <!-- <MulticastInterfaceAddress>192.168.1.22</MulticastInterfaceAddress> -->
     
    <!-- <TrafficClass>0</TrafficClass> -->
     <MulticastTimeout>50</MulticastTimeout> <DatagramMaximumPacketSize>4096</DatagramMaximumPacketSize> </Outgoing> </DatagramConfiguration> -<UnicastIncoming> <ProcessorCount>4</ProcessorCount> </UnicastIncoming> -<UnicastOutgoing> <ProcessorCount>8</ProcessorCount> </UnicastOutgoing> -<MulticastIncoming> <ProcessorCount>4</ProcessorCount> </MulticastIncoming> -<MulticastOutgoing> <ProcessorCount>4</ProcessorCount> </MulticastOutgoing> </RTP> -<Application> <ApplicationTimeout>60000</ApplicationTimeout> <PingTimeout>12000</PingTimeout> <ValidationFrequency>20000</ValidationFrequency> <MaximumPendingWriteBytes>0</MaximumPendingWriteBytes> <MaximumSetBufferTime>60000</MaximumSetBufferTime> </Application> <StartStartupStreams>true</StartStartupStreams> 
    <!-- Properties defined here will be added to the IVHost.getProperties() collection -->
     <Properties> </Properties> </VHost> </Root>
    Try updating to the latest Sun SDK 1.7 instead of openjdk.

    You might try renaming the Wowza dir (not the symlink) and reinstalling from scratch.

    The only OS package (dependency) that is involved with Wowza is Java. Maybe something changed in your OS/network stack when you did the system update.

Similar Threads

  1. unable to get response from wowza
    By imManish in forum Wowza Streaming Engine in the Cloud
    Replies: 1
    Last Post: 05-26-2014, 06:30 AM
  2. Replies: 1
    Last Post: 02-25-2013, 11:05 AM
  3. Getting Quicker Response
    By dougwolf in forum Performance Tuning Discussion
    Replies: 4
    Last Post: 03-18-2012, 03:47 PM
  4. wowza 3.0.5 "no-chache" setting of response header
    By digicon in forum General Forum
    Replies: 4
    Last Post: 03-08-2012, 11:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •