Results 1 to 7 of 7

Thread: FMS restream

  1. #1

    Default FMS restream


    I'm trying to restream a FMS stream.
    I've seen this tutorial
    My FMS stream is a H.264 video and mp3 audio: is there a way to restream this kind of stream, or the source must be a aac audio?



  2. #2


    Wowza can re-stream MP3 audio, such as from FMLE. Give it a try. If you get it working and think the tutorial needs to be altered, please report back.

  3. #3


    Hi Randall,

    now restreaming is working even if after few seconds it stops.
    On the console I see always this warn: LiveMediaStreamReceiver.doWatchdog: streamTimeout: Resetting connection
    It's seems that WMS loose the connection to the FMS.

    On my pc I use 2 JWplayer: the first is watching the FMS stream, the second is on the WMS stream.
    The first player shows the FMS stream without any problem, the second player after few seconds stops.

    Another problem is the screen format: the WMS stream is less wide than the original.
    This screen resize could it be caused by the video codec? The FMS stream is a VP6 video stream.

    About the tutorial
    in the configuration section, step A and step B are the same.

    The preconfigured application.xml file that you invite to download from the tutorial is not fully configured: step F (mediacaster/properties) is not present on the xml file (probably this was my first problem).

    Is there a way to check why the connection to the FMS server is lost after few seconds? Or, there is a way to make a "stronger" connection?

    Thnaks a lot for your help.


  4. #4
    Join Date
    Sep 2011


    Thanks for pointing that out I'm sure it will be corrected soon.

    I don't think you can get a "stronger" connection it rather is connected or it isn't there may be a problem with FMS or something like that,
    Wowza will make a connection and wait for a response if it doesn't get one or the response isn't what was expected then the connection will drop


  5. #5


    Evrytime I start the restream i get this error after few seconds:
    ConnectionConnection.connect: Failed to connect[]: org.apache.mina.common.RuntimeIOException: Invalid argument: no further information
    There is no tuning problem and I've tried on Windows 2008 64bit and Windows 2003 32 bit: same result.
    The restream works for few seconds, than I get the error.

    I've tried to restream a Wowza video stream and it works without any problem.
    So, the problem appears when I try to restream a FMS stream.
    Are there some parameters that I have to set on the FMS server?
    Could it be a problem if the FMS stream is a flv codec stream and not an h.264?

    thanks for your help

  6. #6
    Join Date
    Dec 2007


    If it is unprotected, you should be able to re-stream following this guide:


  7. #7



    I've followed your guide, loook my previous post in this thread.
    Can I send you the FMS url, so you can tiry to restream it on your server?


Similar Threads

  1. Restream from shoutcast
    By tujixx in forum Live Streaming and Encoder Discussion
    Replies: 14
    Last Post: 11-03-2012, 04:05 PM
  2. restream RTSP
    By ManGood in forum Tutorials Discussion
    Replies: 1
    Last Post: 03-04-2012, 06:29 PM
  3. restream from m3u
    By michael401 in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 01-04-2012, 05:08 PM
  4. FMS code to pull a stream from Wowza to FMS
    By charlie in forum Hidden
    Replies: 0
    Last Post: 09-28-2010, 12:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts