Results 1 to 2 of 2

Thread: wowza gstreamer frameRate:1.0E9

  1. #1

    Default wowza gstreamer frameRate:1.0E9


    When I stream from gstreamer a simple pipeline like

    gst-launch-0.10 videotestsrc is-live=true ! x264enc byte-stream=true ! queue ! ffmux_mpegts ! udpsink host= port=10000 -v

    I see on the wowza server following logs

    INFO server comment - CupertinoPacketHandler.startStream[myapplication/_definst_/]
    INFO server comment - LiveStreamPacketizerCupertino.handlePacket[myapplication/_definst_/]: Video codec:H264 isCompatible:true
    INFO server comment - LiveStreamPacketizerCupertino.handlePacket[myapplication/_definst_/][avc1.77.21]: H.264 (Video may not be playable on older iPhone and iPod touch devices where Baseline/Level 3.0 or lower is required) Video info: {H264CodecConfigInfo: codec:H264, profile:Main, level:2.1, frameSize:320x240, displaySize:320x240, frameRate:1.0E9, PAR:1:1}
    INFO server comment - MediaStreamMap.getLiveStreamPacketizer: Create live stream packetizer:

    For some reasons wowza seems to detect the framerate as 1.0E9 ? Can you please let me know why this maybe happening ?

    P.S: Wowza Version - 3.1.1.


  2. #2
    Join Date
    Dec 2007



    I'm not sure, but Wowza is just reflecting the stream, not transcoding.


Similar Threads

  1. Fantastic design with Wowza and gstreamer
    By Carlos Eduardo in forum General Forum
    Replies: 0
    Last Post: 03-28-2014, 08:00 AM
  2. GStreamer + RTSP
    By rodolfospalenza in forum Live Streaming and Encoder Discussion
    Replies: 0
    Last Post: 12-20-2011, 05:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts