Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Multiple Live Streams Playlist

  1. #1

    Default Multiple Live Streams Playlist

    So I am attempting multiple, simultaneous live streams. Right now I have one working, and a second one that claims it is working, but when I try to connect I get stream not found error. Here is how I have my smil file structred:

    <smil>
    <head>
    </head>
    <body>

    <stream name="hit"></stream>
    <stream name="hat"></stream>

    <playlist name="pl1" playOnStream="ividz" repeat="true" scheduled="2009-12-11 16:00:00">
    <video src="mp4:tc.mp4" start="5" length="5" system-bitrate="450000"/>
    <video src="mp4:sample.mp4" start="50" length="5" system-bitrate="450000"/>
    <video src="mp4:bb.mp4" start="150" length="5" system-bitrate="450000"/>
    </playlist>
    <playlist name="pl2" playOnStream="hat" repeat="true" scheduled="2009-12-11 16:00:00">
    <video src="mp4:tr.mp4" start="5" length="5" system-bitrate="450000"/>
    <video src="mp4:sample.mp4" start="50" length="5" system-bitrate="450000"/>
    <video src="mp4:br.mp4" start="150" length="5" system-bitrate="450000"/>
    </playlist>
    </body>
    </smil>

    Is this not correct?

  2. #2

    Default

    "but when I try to connect I get stream not found error"

    How are you trying to connect? What is the stream URI you are trying to play?

    I see that you have playOnStream="ividz". Perhaps that should be playOnStream="hit".

  3. #3

    Default

    That's a typo in my example. In the real smil file they all match. I am using the client example to test the streams.
    When I try to play using the client test player it says "Failed to play hat; stream not found.".
    If I look at the error log file it says "WARN server comment 2012-05-11 07:42:16 - - - - - 50540.334 - - - - - - - hat open: java.io.FileNotFoundException: C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.1.1\content\hat.flv (The system cannot find the file specified) yet when I start the server it says the stream is running.
    When I look at the access log after trying to connect, it says "2012-05-11 07:42:16 EDT comment server WARN 404 hat open: java.io.FileNotFoundException: C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.1.1\content\hat.flv (The system cannot find the file specified)".
    Last edited by haarvik; 05-11-2012 at 04:46 AM.

  4. #4
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi
    Have you set the stream type to live in the Application.xml?
    Like this - [Wowza-Install]/conf/[application]/Application.xml
    <StreamType>live</StreamType>
    Jason

  5. #5

    Default

    Yep, it's in there and set to live. The file not found error has gone away, but the client still says file not found.
    rtmp://[server-IP]/hat/hat is what I am using to play the stream.
    At the server console, it now says:

    INFO application app-start _definst_ hat/_definst_
    INFO session connect-pending [my ip] -
    INFO session connect [my ip] -
    INFO stream create - -

    And then nothing. I did notice this:

    INFO application app-start _definst_ hit/_definst_

    but there is no entry for hat like that. This may be grasping at straws, but does each stream have to be on it's own port?
    Last edited by haarvik; 05-11-2012 at 05:32 AM.

  6. #6

    Default

    Ok, getting closer. Now I see where both apps are being published. However, I never see this:

    INFO server comment - scheduled playlist: hat on stream: hat for:Fri Dec 11 16:00:00 EST 2009

    Like I do for hit. But then I noticed that hit would not stream live.

    I added:

    <Property>
    <Name>PublishToApplication</Name>
    <Value>hat</Value>
    </Property>

    to server.xml so there was two of them, one for hit and one for hat. Apparently that broke the server and the player complained it couldn't find 'clip' hit.
    is there instructions anywhere on this site to show how to do multiple live streams from top to bottom?

  7. #7
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    You cannot have to two PublishToApplication Properties with this example, as it is. Just one. Make sure the one you designated has StreamType "live"

    Richard

  8. #8

    Default

    So then how do you accomplish multiple, simultaneous live streams?? Do I just set both streams with one name and different playlists? Do I have to start multiple instances of WOWZA with different configs?

  9. #9
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    The examples shows two streams in the .smil file: Stream1 and Stream2. They will be published to the same application/instance You can extend that indefinitely.

    Richard

  10. #10

    Default

    Yes, but it also show pl1 and pl2. So how would I connect to the other one? If I do rtsp://[ip]:1935/hit/hat I get file not found.

Page 1 of 2 12 LastLast

Similar Threads

  1. Multiple Live Streams
    By sculver in forum General Forum
    Replies: 1
    Last Post: 04-26-2013, 04:12 AM
  2. Multiple smil files for multiple live streams
    By haarvik in forum Live Streaming and Encoder Discussion
    Replies: 4
    Last Post: 05-23-2012, 06:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •