Results 1 to 4 of 4

Thread: Java confusion

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default Java confusion

    Hello,

    I have a bit of a mystery with the application files for my Wowza app. Well, it might not be such a mystery to someone who actually understands what is going on.

    I used the IDE to build an app. The app runs fine. However, there are no files being saved to my 'applications/{myApp}' folder.

    I found this out when I tried to upload the app to my server and it didn't work.

    So, here are my questions:

    If the app is not being saved to my 'applications/{myApp}' folder, then where is it being saved to?
    If it is not being saved, then how is Wowza able to find and run it?
    How do I find the compiled app so I can upload it to my server?

    take care,
    lee

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Lee,

    The IDE writes a jar file to the Wowza /lib folder. It is named [yourProject].jar

    That is the file you move to production, also to the Wowza /lib folder. Be sure to restart Wowza after you add a jar file

    Richard

  3. #3

    Default

    Hello,

    Ok. Thanks.

    This makes me wonder if I am configuring things correctly.

    From what I can see, when I add an app, I have to deal with 3 folders;

    Applications - add a folder named after my app
    Conf - add a folder named after my app
    bin - My app.

    Is this correct or is there a way to combine all of these into 1 folder? Or is there some advantage to having the app distributed like this?

    take care,
    lee

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    You do not need the Wowza IDE to create applications, it is for creating extensions to Wowza. And the bin folder is not involved in creating a Wowza application. The /applications and /conf folders are involved.

    Take a look at the Quickstart Guide here:
    http://www.wowza.com/forums/content....ck-start-guide

    Start at the top: Application Configuration.

    Richard

Similar Threads

  1. Stream name confusion on transcode
    By fly135 in forum AddOn: Transcoder
    Replies: 3
    Last Post: 07-20-2013, 06:35 PM
  2. MediaCaster system confusion
    By RomanSaveljev in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 05-09-2013, 05:07 AM
  3. StartupStreamx.XML confusion
    By azrilnazli in forum General Forum
    Replies: 4
    Last Post: 03-15-2012, 06:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •