Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: wowza dont use first core??

  1. #1

    Default wowza dont use first core??

    hi, monitoring a wowza server on high load i noticed that dont use the first core (quad with hyperthreading = 8 cores)



    is a bug or what?? (i already followed this http://www.wowza.com/forums/content....general-tuning based on 8 cores..)

    thx

    EDIT: is the Wowza Media Server 3.1.1
    Last edited by capostrike93; 06-03-2012 at 03:37 PM.

  2. #2

    Default

    That's odd. Wowza is using both of my cores. Can you post the output of your logs/console when you first start Wowza so we can see your OS, Java, Processor count, etc..

    Thanks.

  3. #3

    Default

    sure

    2012-05-27 16:38:22 CEST comment server INFO 200 - Hardware Available Processors: 8 - - - 0.68 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Hardware Physical Memory: 23117MB/24147MB - - - 0.682 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Hardware Swap Space: 510MB/510MB - - - 0.682 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Max File Descriptor Count: 100000 - - - 0.683 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Open File Descriptor Count: 45 - - - 0.684 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - OS Name: Linux - - - 0.685 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - OS Version: 2.6.38.2-grsec-xxxx-grs-ipv6-64 - - - 0.685 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - OS Architecture: amd64 - - - 0.686 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Name: Java HotSpot(TM) 64-Bit Server VM - - - 0.686 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Vendor: Oracle Corporation - - - 0.687 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Version: 1.7.0_04 - - - 0.688 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java VM Version: 23.0-b21 - - - 0.688 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Spec Version: 1.7 - - - 0.689 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Home: /usr/java/jdk1.7.0_04/jre - - - 0.689 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Max Heap Size: 13333MB - - - 0.69 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Architecture: 64 - - - 0.691 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Locale[user.language]: es - - - 0.691 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Locale[user.country]: ES - - - 0.692 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Locale[file.encoding]: ISO-8859-1 - - - 0.692 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Timezone[user.timezone]: Europe/Paris - - - 0.693 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Args[0]: -Xmx15000M - - - 0.694 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Args[1]: -Djava.net.preferIPv4Stack=true - - - 0.694 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Args[2]: -Dcom.sun.management.jmxremote=true - - - 0.695 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Args[3]: -Dcom.wowza.wms.runmode=service - - - 0.695 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Args[4]: -Dcom.wowza.wms.native.base=linux - - - 0.696 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Args[5]: -Dcom.wowza.wms.AppHome=/usr/local/WowzaMediaServer - - - 0.697 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Args[6]: -Dcom.wowza.wms.ConfigURL= - - - 0.697 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Java Args[7]: -Dcom.wowza.wms.ConfigHome=/usr/local/WowzaMediaServer - - - 0.698 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Server runmode: service - - - 0.698 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Server native.platform: linux - - - 0.699 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - Server threads[h/t]: 10/10 - - - 0.7 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:22 CEST comment server INFO 200 - CMDInterface now listening: [any]:8083 - - - 1.57 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:23 CEST vhost-start vhost INFO 200 _defaultVHost_ - - - - 2.297 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:23 CEST comment server INFO 200 - _defaultVHost_ threads[h/t]:480/320 home:/usr/local/WowzaMediaServer - - - 2.365 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:23 CEST comment vhost INFO 200 _defaultVHost_ Bind attempt ([any]:1935:16) - - - 2.369 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:23 CEST comment vhost INFO 200 _defaultVHost_ Bind successful ([any]:1935) - - - 2.376 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:23 CEST comment vhost INFO 200 _defaultVHost_ Bind attempt ([any]:8086:1) - - - 2.379 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:23 CEST comment vhost INFO 200 _defaultVHost_ Bind successful ([any]:8086) - - - 2.381 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:23 CEST comment server INFO 200 - Server.startShutdownHook: Start server shutdown hook - - - 2.385 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-05-27 16:38:23 CEST comment server INFO 200 - Wowza Media Server is started! - - - 2.387 - - - - - - - - - - - - - - - - - - - - - - - - -

  4. #4

    Default

    Have you set processor affinity and/or priority for any other processes?

  5. #5

    Default

    Quote Originally Posted by randall View Post
    Have you set processor affinity and/or priority for any other processes?
    not, is a simple service WowzaMediaServer start

    without affinity settings..

  6. #6
    Join Date
    Sep 2011
    Posts
    1,920

    Default

    Hi
    You have allocated 13Gb to Java and it is stated in the tuning guide that you shouldn't exceed 10Gb
    For the problem above I believe that this may be an OS problem, can you try using the same set-up on a standard distribution of Linux.

    Jason

  7. #7

    Default

    Quote Originally Posted by JasonH View Post
    Hi
    You have allocated 13Gb to Java and it is stated in the tuning guide that you shouldn't exceed 10Gb
    For the problem above I believe that this may be an OS problem, can you try using the same set-up on a standard distribution of Linux.

    Jason
    the heapsize not is the problem, wowzateam recommended that dont set more that 10 gb, but anyways you can put more if u really need that

    im using centos, i dont thinks is a OS problem..

    anyways during normal load y view the same use of all cores, i need wait to another high load to check that there is a problem.

    I'll be testing a few days and tell them what happens.

  8. #8
    Join Date
    Sep 2011
    Posts
    1,920

    Default

    Hi
    If you allocate more than 10Gb to Java you will start seeing server problems.
    If you can reproduce this problem with 10Gb or less allocated to Java then I'm sure we'll be happy to help.

    10Gb is the maximum Java can handle going over this will not improve performance and can cause performance degradation.
    Let us know of your results after these changes have been made.

    Jason

  9. #9

    Default

    Quote Originally Posted by JasonH View Post
    Hi
    If you allocate more than 10Gb to Java you will start seeing server problems.
    If you can reproduce this problem with 10Gb or less allocated to Java then I'm sure we'll be happy to help.

    10Gb is the maximum Java can handle going over this will not improve performance and can cause performance degradation.
    Let us know of your results after these changes have been made.

    Jason
    now i have Xmx=10000

    and still having the problem...

    --------------

    normal load:


    high load:

  10. #10

    Default

    capostrike93,

    Thanks for the extra info. I see three things:
    1. 788% of the CPU is being used by Wowza it seems. See if any Wowza threads are on CPU 0.
    Check with: ps -p [Wowza-javaPID] -L -o pid,tid,psr,pcpu
    2. 80% of your 1st CPU is being used by "si". Which is time spent handling software interrupts.

    This is something that could be tuned. It is likely related to your network card and number of connections. You may be able to lower the time spent on si, leaving more of your first CPU available to Wowza, or you may be able to spread the si load across multiple CPUs if it is a bottleneck (like if clients are being dropped).

    Places where tuning/adjustment/replacement might help: different kernel, different NIC, network stack tuning. See this thread for a start.

Page 1 of 2 12 LastLast

Similar Threads

  1. CPU Dual Quad-Core 2.10 GHz is enough for Wowza 4 ?
    By carambola in forum General Forum
    Replies: 3
    Last Post: 03-17-2014, 06:39 AM
  2. Replies: 0
    Last Post: 09-24-2012, 01:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •