Results 1 to 2 of 2

Thread: Stream.createInstance is not working for Cupertino

  1. #1
    Join Date
    Jun 2012

    Default Stream.createInstance is not working for Cupertino


    I'm trying to use create a stream from a local file to test IMediaStream.send and other metadata capabilities.

    The stream is being created in wowza as follows:

    IVHost vhost = VHostSingleton.getInstance(VHost.VHOST_DEFAULT, true);
    IApplication app = vhost.getApplication("Teste1");
    IApplicationInstance appInstance = app.getAppInstance("_definst_");
    Stream stream1 = Stream.createInstance(vhost, app.getName(), "Stream1");"mp4:sample.mp4", 0, -1, true);
    stream1.addListener(new StreamListener(appInstance));
    To test the stream I'm using the jwplayer, what worked very well for RTMP on Chrome/IE/etc, but it's giving the following error for HTTP on iPad's Safari.

    INFO server comment - onHTTPSessionCreate: 202670035
    INFO server comment - onHTTPCupertinoStreamingSessionCreate: 202670035
    WARN server comment Stream1[1]: C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.1.1\applications\Teste1\ondemand\Stream1 (O sistema não pode encontrar o arquivo especificado)
    ERROR server comment - MediaReaderH264Cupertino.indexFile:java.lang.NullPointerException
    When I point the URL directly for a saved file on StorageDir directory It's played properly on Safari, but I need to have a live stream being generated to be able to add the metadata/cuepoints.

    Does someone have any idea?


  2. #2
    Join Date
    Jun 2012


    It worked adding cupertinostreamingpacketizer to LiveStreamPacketizers item from Application.xml.

    Moving for metadata issue now!

Similar Threads

  1. Module Limit Stream Viewers seems not working for cupertino connection
    By steveitl in forum Server-side Modules and Code Samples Discussion
    Replies: 3
    Last Post: 08-02-2013, 06:51 AM
  2. Stream.createInstance and HTTP live streaming
    By robw21 in forum General Forum
    Replies: 12
    Last Post: 04-11-2012, 11:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts