Results 1 to 3 of 3

Thread: pushpublish-pulgin to Level3 issue

  1. #1
    Join Date
    Jul 2011
    Posts
    13

    Default pushpublish-pulgin to Level3 issue

    Hi,

    I am currently pushing 3 streams(multibitrate) to level-3 using pushpublish-pulgin(latest version).
    Strangely the first stream frame rate fluctuates always, while the other 2 streams push at constant frame rate.

    any ideas? is this a known issue?

    here is the code snippet i am using to publish to level3

    PushPublisherRTMP publisher = new PushPublisherRTMP(); 
    						
    						// Source stream
    						publisher.setAppInstance(appInstance);
    						publisher.setRemoveDefaultAppInstance(true);
    						
    						
    						
    						publisher.setSrcStreamName(streamName);	
    					
    						// Destination stream
    						publisher.setHostname(objConfiguration.confModulePushPublish.primaryhost);
    						publisher.setPort(1935);
    						publisher.setDstApplicationName(objConfiguration.confModulePushPublish.applicationName);
    						publisher.setDstStreamName(objConfiguration.confModulePushPublish.streamnamePrefix+"_" + destinationStreamName);
    						publisher.setConnectionFlashVerion(PushPublisherRTMP.CURRENTFMLEVERSION);
    						
    					
    
    						publisher.setSendFCPublish(true);
    						publisher.setSendReleaseStream(true);
    						publisher.setSendOnMetadata(true);
    
    						
    						publisher.addListener(this);
    						publisher.connect();
    					    
    						publishers.put(stream, publisher);
    thank you

  2. #2
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi
    This could be an encoding problem as Wowza doesn't change the frame rate unless you're using the transcoder.
    If you're using the transcoder and the machine isn't powerful enough this could make one of the streams fluctuate in frame rate.

    A test would be to push only two streams (including the fluctuating frame rate stream) and see if it still occurs.
    If you are transcoding, how many streams are being transcoded in total?

    Jason

  3. #3
    Join Date
    Jul 2011
    Posts
    13

    Default

    thanks for a quick reply,
    i am not transcoding(not using the transcoder pluging),
    i am only pushing directly to wowza and then from wowza to level 3 (using pushpublish plugin).
    It's always the first stream that fluctuates dispite the number of streams i am pushing 1, 2 or 3 streams.
    When publishing directly to level 3 from the same machine all streams work fine.

Similar Threads

  1. pushpublish
    By brayster99 in forum Wowza Streaming Server Java API
    Replies: 1
    Last Post: 03-07-2014, 09:26 AM
  2. Flash Media Live Encoder and PushPublish issue
    By sdabhi in forum Live Streaming and Encoder Discussion
    Replies: 2
    Last Post: 07-16-2013, 05:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •