Results 1 to 3 of 3

Thread: Wowza Service stops after logoff on Windows Server 2003 R2 x64

  1. #1
    Join Date
    May 2010
    Posts
    10

    Default Wowza Service stops after logoff on Windows Server 2003 R2 x64

    We have a Wowza Service running on a Windows Server 2003 R2 x64 with jdk-7u3 JDK installed. As soon as the Administrator (or a user with admin rights) logs off, the Wowza service stops. The Eventlog logs "The Wowza Media Server service terminated unexpectedly", in the Wowza Service log the following is loged:
    STATUS | wrapper  | 2012/06/29 18:07:07 | --> Wrapper Started as Service
    STATUS | wrapper  | 2012/06/29 18:07:07 | Launching a JVM...
    ERROR  | wrapper  | 2012/06/29 18:07:58 | Shutdown failed: Timed out waiting for signal from JVM.
    ERROR  | wrapper  | 2012/06/29 18:07:58 | JVM did not exit on request, terminated
    STATUS | wrapper  | 2012/06/29 18:07:58 | <-- Wrapper Stopped
    The service is running as the local System account.

    Does anybody know any fixed for this issue?

    Thanks,
    Peter

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Please zip up and send /conf and /logs folders that show this to support@wowza.com First restart Wowza, then logoff so we can see this.

    Include a link to this post for reference.

    Richard

  3. #3
    Join Date
    May 2010
    Posts
    10

    Default

    Wowza support supplied us with the fix for this behaviour:

    Edit the file:
    /bin/WowzaMediaServer-Service.conf
    Add this parameter:
    wrapper.java.additional.9=-Xrs
    If wrapper.java.additional.9 is already used, use the next free number (or lower number).

    Thanks to Wowza support for the quick help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •