Results 1 to 2 of 2

Thread: CupertinoStreamerLiveRepeaterReceiver.addVideoData error in logs

  1. #1
    Join Date
    Apr 2012

    Default CupertinoStreamerLiveRepeaterReceiver.addVideoData error in logs


    Previously I wrote on this forum thread
    but didn't get response.

    In our setup (origin, failover origin and edge servers). On one of the edge servers logs there are a lot of errors like this about 80-100 in the same second.

    CupertinoStreamerLiveRepeaterReceiver.addVideoData[add:3:[ApplicationName]/_definst_/myStream.sdp_240p:cupertinostreamingpacketizer]: java.lang.NullPointerException
    CupertinoStreamerLiveRepeaterReceiver.addVideoData[add:3:[ApplicationName]/_definst_/myStream.sdp_360p:cupertinostreamingpacketizer]: java.lang.NullPointerException
    Also we noticed that this messages had appered lately in the same log (maybe there is some relation with the above).

    HTTPStreamerAdapterCupertinoStreamer.service: Request timeout: 8000
    LiveMediaStreamReceiver.doWatchdog: streamTimeout: Resetting connection
    Info for the servers: they all running on version 3.1.1 build1479. Also for this application there is a transcoder activated doing a transrate. Clients connecting to this application are mainly HLS players.

  2. #2
    Join Date
    Dec 2007


    Sorry for the delay. I responded to the first one.


Similar Threads

  1. Error in logs BufferUtils and show logs in terminal
    By livesreamingforall in forum General Forum
    Replies: 7
    Last Post: 06-30-2015, 06:53 AM
  2. Error logs after installing Wowza 4
    By dhamibirendra in forum General Forum
    Replies: 2
    Last Post: 08-28-2014, 08:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts