Results 1 to 5 of 5

Thread: AAC audio not coming through WOWZA, but working in vlc

  1. #1

    Default AAC audio not coming through WOWZA, but working in vlc

    We are trying to stream an rtsp stream from a video server but struggle to get audio. When playing the stream in vlc it works fine and the codec indicated is:

    MPEG AAC Audio (mp4a), stereo, 32,000 Hz

    When playing the rtsp (form: rtsp://[IP-address]/0/usernameassword/main) through WOWZA (2.2.4, rtp-live stream type) with the included flash player the video plays fine but no audio comes through. Audio from other video servers (Axis, Vivotek) played through the same application plays fine.

    For those willing to help check what might cause this I can provide the exact URL, but as bandwidth is limited at source I can not post them here.

    Any help would be greatly appreciated.

    Thanks,

    Peter

  2. #2

    Default

    Two things:

    1. You can post here the output of "ffmpeg -show_streams <media>"

    Maybe we can identify a problem if we see more complete info.

    2. You can try with the latest version of Wowza.

    This issue may have been resolved.

    Can you clarify what you mean by "video servers" and "application"? Do you mean you played this problem stream through some other "server"? Or do you mean you played a different stream through Wowza?

  3. #3

    Question

    Thanks Randall, am using the latest WOWZA build now 3.1.2 build 1624

    ffmpeg output connecting to the WOWZA server (rtmp://[IP address/[application]/audiotest.stream):

    Metadata:
    audiochannels 1.00
    audiosamplerate 8000.00
    audiocodecid mp4a
    videocodecid avc1
    width 352.00
    height 240.00
    frameWidth 352.00
    frameHeight 240.00
    displayWidth 352.00
    displayHeight 240.00
    trackinfo:
    timescale 8000.00
    language eng
    sampledescription:
    sampletype mpeg4-generic
    type audio
    timescale 90000.00
    language eng
    sampledescription:
    sampletype H264
    type video
    profile-level-id 42e014
    sprop-parameter-sets Z0LgFNoFh8Q=,aM4wpIA=
    description {H264CodecConfigInfo: codec:H264, profile:Baseline, level:2.0, frameSize:352x240, displaySize:352x240}
    rtpsessioninfo:
    information rtsp server
    name RTSP Session
    origin rtsp 1345147344 1623870206 IN IP4 0.0.0.0
    timing 0 0
    protocolversion 0
    attributes:


    From the WOWZA log on the server:

    2012-09-11 10:48:58 BST comment server INFO 200 - CupertinoPacketHandler.startStream[rtsp-ingest/_definst_/audiotest.stream] - - - 124.555 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-09-11 10:48:58 BST comment server INFO 200 - LiveStreamPacketizerCupertino.handlePacket[rtsp-ingest/_definst_/audiotest.stream]: Video codec:H264 isCompatible:true - - - 124.555 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-09-11 10:48:58 BST comment server INFO 200 - LiveStreamPacketizerCupertino.handlePacket[rtsp-ingest/_definst_/audiotest.stream]: Audio codec:AAC isCompatible:true - - - 124.555 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-09-11 10:48:58 BST comment server INFO 200 - LiveStreamPacketizerCupertino.handlePacket[rtsp-ingest/_definst_/audiotest.stream][avc1.66.20]: H.264 Video info: {H264CodecConfigInfo: codec:H264, profile:Baseline, level:2.0, frameSize:352x240, displaySize:352x240} - - - 124.555 - - - - - - - - - - - - - - - - - - - - - - - - -


    The rtsp-ingest application is set up exactly as per the rtsp-restreaming tutorial on the forum.


    Still, it does not play it though, but only the video stream.

    What could be the reason?

    Peter

  4. #4
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi
    In the logs do you see Wowza making chunks for iOS (Cupertino Packetizers).
    If this doesn't happen then it could be that the data isn't being received or Wowza thinks the data isn't compatible for some reason.

    Jason

  5. #5

    Default

    Quote Originally Posted by JasonH View Post
    Hi
    In the logs do you see Wowza making chunks for iOS (Cupertino Packetizers).
    If this doesn't happen then it could be that the data isn't being received or Wowza thinks the data isn't compatible for some reason.

    Jason
    What would cause WOWZA to not see it as compatible if ffmpeg (taking the rtmp feed coming from the WOWZA server) and VLC see it as proper AAC (and play the audio accordingly) and WOWZA itself also registers it as AAC incoming and compatible? Are there any further checks I can do as to what is causing WOWZA to not play out the audio?

Similar Threads

  1. rtsp android audio is not coming
    By vinodkumarc in forum Media Players and Devices Discussion
    Replies: 6
    Last Post: 05-29-2013, 12:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •