Results 1 to 6 of 6

Thread: Flash 11.3.x + Firefox (protected mode) - Failed to connect to RTMPS stream

  1. #1
    Join Date
    Jul 2012
    Posts
    6

    Question Flash 11.3.x + Firefox (protected mode) - Failed to connect to RTMPS stream

    Hello!

    Opening a netconnection to an RTMPS stream fails without any notice (netstatus or error). This happens for Flash Player 11.3.x with the new protected mode for Firefox (only with the release Flash Player versions, only on Windows).

    On our wowza media server (version 3.1.1), we can see the SSL handshake failing.

    Has anyone a solution or workaround for that problem? Or had the same problem and can share how you solved it?

    (There are also already posts in the Adobe forum about that problem but no responses, e.g. http://forums.adobe.com/message/4576128?tstart=0))

    Any suggestions are greatly appreciated! Thanks!

  2. #2
    Join Date
    Jul 2012
    Posts
    6

    Default

    For completeness, here is the wowza log of the handshake. This is very urgent for us, since it stops our production system from working!
    So every input is valuable.

    DEBUG server comment - null Data Read: org.apache.mina.filter.support.SSLHandler@1e14de0 (HeapBuffer[pos=0 l
    E 25 E7 32 B7 8F F4 33 9E D5 58 26 85 25 47 A2 F6 B5 CE C1 39 C2 72 B3 7E 0D CB 46 30 C6 BA 11 54 3C 11 BC 7
    93 1D 46 BE CD 62 90 09 5E 3E 58 A5 79 D0 15 32 0F 5F A6 66 11 48 FA BB 3E E2 47 AE 78 E7 DB 4E 0A D5 AE AC
    60 D5 44 61 63 52 E3 82 BE 35 FE C0 4A 8A 57 09 18 AB 1F F8 A1 03 C3 7A A1 2C DF A3 93 E4 0D 75 61 C0 18 25
    7 C6 B6 DF 1A 5D 83 1B 26 24 68 09 E7 21 C3 52 D2 AE 06 55 0C 7E C9 AD CA 53 AA 15 ED 0F 33 F3 68 A7 63 26 E
    94 A9 1D 56 2A 59 79 CB 9C 56 D3 36 45 B2 F9 66 62 33 F6 F2 2D D8 5F B2 C1 64 BF 9A 05 FD 41 ED 76 3D 6F 36
    84 7A BB 3C 57 DD 2E 96 41 3B 82 FF A1 36 07 B5 52 47 B0 3C 15 49 48 A0 7B 17 C3 72 15 26 33 89 5E 3E 81 91
    C 7F EB F7 B4 FC 1A A9 92 2A 68 8D 1C 50 F5 2D E5 77 06 80 F3 46 A0 8C BB FB 02 BF DB 72 B5 6D E2 77 64 D2 7
    62 C5 97 57 BD 6D 8A D9 92 E4 0F F2 E4 D6 21 56 5C 9A B8 06 F8 39 DF 47 3A 59 59 0A 49 04 E8 5F AA 0E F5 E5
    95 64 1A 33 A7 1B A0 66 33 8F 96 10 32 14 C1 CB 80 B9 7A D7 85 B4 15 EF E8 11 81])
    DEBUG server comment - null unwrap()
    DEBUG server comment - null inNetBuffer: java.nio.DirectByteBuffer[pos=0 lim=2565 cap=16665]
    DEBUG server comment - null appBuffer: java.nio.DirectByteBuffer[pos=0 lim=33330 cap=33330]
    DEBUG server comment - null Unwrap res:Status = OK HandshakeStatus = NOT_HANDSHAKING
    bytesConsumed = 2565 bytesProduced = 2532
    DEBUG server comment - null inNetBuffer: java.nio.DirectByteBuffer[pos=2565 lim=2565 cap=16665]
    DEBUG server comment - null appBuffer: java.nio.DirectByteBuffer[pos=2532 lim=33330 cap=33330]
    DEBUG server comment - null Unwrap res:Status = BUFFER_UNDERFLOW HandshakeStatus = NOT_HANDSHAKING
    bytesConsumed = 0 bytesProduced = 0
    DEBUG server comment - null appBuffer: java.nio.DirectByteBuffer[pos=0 lim=2532 cap=33330]
    DEBUG server comment - null app data read: HeapBuffer[pos=0 lim=2532 cap=2532: B4 EC D8 86 B0 7C 8D 42 21 2F
    2 5C 25 82 13 98 1A 45 16 E8 4D DF 12 BB DE 8C A0 86 3A 53 A7 71 EA 54 0C 1C F3 69 69 6C 21 8D D7 17 9F 49 8
    46 98 59 AF B7 24 BB B6 54 0B 7B 20 BC 87 EC D4 77 9C 97 A3 3A 8E FC 4D FA 68 F3 D8 3D 6A CC 2E 17 24 86 FC
    F2 F1 5A E4 EB 18 C5 99 CF 67 16 84 4B BA C7 22 36 A6 65 54 F2 35 59 01 CB 8C 7D A4 60 11 C8 32 A3 C6 A9 97
    C B1 D6 1F 73 29 4B F8 86 4F 25 FF 6C 6A 19 1B D7 62 B5 06 0F BB AC 48 CD C5 40 19 05 B1 04 A3 B4 9F 44 F1 6

  3. #3

    Default

    The bug report mentioned in your link says the problem is happening with Chrome. Please consider going there and reporting your information about Firefox as it might help them identify the issue and/or a fix.

  4. #4
    Join Date
    Jul 2012
    Posts
    6

    Default

    We setup an Adobe Flash Media Server 4.5 with SSL and managed to connect with the mentioned setup (firefox/release player 11.3.x/rtmps).
    On other browsers we did not experience the problem.

  5. #5

    Default

    We have a test RTMPS server with a stream setup. Does this stream play for you with Firefox and 11.3.x. It does for me:

    Server: rtmps://positive01.wowzatest01.com/vod
    Stream: mp4:sample.mp4
    I am running Firefox 14.0.1 and Flash 11,3,300,265.

    Charlie

  6. #6
    Join Date
    Jul 2012
    Posts
    6

    Default

    Thanks for your help.
    It turned out, setting the proxyType of the netConnection to "best" created the problem. According to the documentation, when setting it to "best" the player tries to create a native SSL connection. It seems that fails with the new protected mode. Also on the new Mac OSX 10.8, with every browser, we got a "SSLNotAvailable" net status. The documentation says the player would try different approaches in creating the connection, but it seems that it doesn't if the native SSL approach fails.
    Setting the proxyType to "none" (the default), solves the problem.

    Best regards,
    Roman

Similar Threads

  1. How to check source stream status - MediaCasterConnection.connect: Failed to connect
    By herkules in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 11-20-2013, 07:11 PM
  2. Wowza StreamLock RTMPS vs Adobe FMS Protected HDS
    By bennyfatwai in forum AddOn: Other AddOns
    Replies: 2
    Last Post: 09-08-2013, 11:56 AM
  3. Flash Player on Linux fails to connect over RTMPS (StreamLock)
    By drupaler in forum AddOn: Other AddOns
    Replies: 1
    Last Post: 07-12-2013, 01:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •