Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Flowplayer + apple

  1. #1

    Lightbulb Flowplayer + apple

    Hi, I'm testing flowplayer with support for ipad. But I have a problem, I'm not know if have that configure some in wowza for I no found the file mp4 or playlist.m3u8

    I added:

    ipadUrl: "http://server_origin/app/name/playlist.m3u8"
    ipadUrl: "http://server_origin/app/_definst_/name/playlist.m3u8"
    ipadUrl: "http://server_origin/app/mp4:name.mp4/playlist.m3u8"

    But nothing

    any help or suggestions?

    Regards

  2. #2

    Default

    Try with the port specified, otherwise it will default to port 80:

    "http://server_origin:1935/app/mp4:name.mp4/playlist.m3u8"

  3. #3

    Default

    Quote Originally Posted by randall View Post
    Try with the port specified, otherwise it will default to port 80:

    "http://server_origin:1935/app/mp4:name.mp4/playlist.m3u8"

    ...

    I tried wuth the port and if I put in the browser download a file. But when I put in the html5 show me "201,unable to load stream or clipo file connect"

  4. #4
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi
    Lets take a look at your HTML5 to be sure it's correct.

    Jason

  5. #5

    Default

    my code is:


    <html>
    <head>
    <title>Live Player</title>
    </head>
    <body>
    <div id='player'>This div will be replaced by the JW Player.</div>
    <script type='text/javascript' src='jwplayer.js'></script>
    <script type='text/javascript'>
    jwplayer('player').setup({
    'id': 'playerID',
    'width': '720',
    'height': '480',
    'provider': 'rtmp',
    'streamer': 'rtmp://server:1935/redirect',
    'file': 'name',
    'modes': [
    {type: 'flash', src: 'player.swf'},
    {
    type: 'html5',
    config: {
    'file': 'http://server:1935/live/mp4:name.mp4/playlist.m3u8',
    'provider': 'video'
    }
    }
    ]
    });
    </script>
    </body>
    </html>

  6. #6
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi
    You said in your original post that the player was FlowPlayer, This is JW Player embed code.

    Which are you using?
    You may have followed the wrong tutorial.

    Jason

  7. #7

    Default

    Sorry, I confused the files.

    ------------------

    <html>
    <head>
    <meta http-equiv="content-type" content="text/html; charset=UTF-8">
    <title> demo</title>

    <script type='text/javascript' src='/js/lib/dummy.js'></script>

    <link rel="stylesheet" type="text/css" href="/css/normalize.css">
    <link rel="stylesheet" type="text/css" href="/css/result-light.css">



    <script type='text/javascript' src="http://server/flowplayer-3.2.6.min.js"></script>




    <script type='text/javascript' src="http://server/flowplayer.ipad-3.2.2.min.js"></script>


    <style type='text/css'>
    #player {
    display: block;
    width: 512px;
    height: 288px;
    margin: 0 auto;
    }
    </style>



    <script type='text/javascript'>//<![CDATA[
    window.onload=function(){
    $f("player", "http://server/flowplayer-3.2.7.swf", {
    plugins: {
    rtmp: {
    url: "http:/server/flowplayer.rtmp-3.2.3.swf",
    netConnectionUrl: 'rtmp://stream:1935/redirect'
    }
    },
    clip: {
    url: "mp4:name",
    provider: "rtmp",
    ipadUrl: "http://server:1935/vod/mp4:name.mp4/playlist.m3u8",
    scaling: "fit",
    autoPlay: false
    }
    }).ipad();
    }//]]>

    </script>


    </head>
    <body>
    <a id="player"></a>

    </body>


    </html>

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    I noticed that you are connecting to a Load Balancer redirect application in the Flash part, but to a vod application in the iOS part.

    And that in the JW Player snip you are also connecting to redirect for the Flash part, then using application named "live" but playing a file "mp4:name.mp4"

    If you want the iOS device to connect to an edge, you have to get least loaded edge with http method and supply the correct location

    Richard

  9. #9

    Default

    Quote Originally Posted by rrlanham View Post
    If you want the iOS device to connect to an edge, you have to get least loaded edge with http method and supply the correct location

    Richard
    Sorry but This part, I dont understand. Do you have any manual or how to? I dont know what is the correct location . I try with http://server:1935/vod/mp4:name.mp4/playlist.m3u8 or http://edge:1935/vod/mp4:name.mp4/playlist.m3u8 but nothing

    Regards

  10. #10
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi
    Have you configured the vod application on both server and edge?
    If you're trying to connect to an application it needs to be built on the server you're connected to.

    How many edge servers do you have?
    You must have all the same files in each content directory for this to work on any of the edge servers or main server.

    Jason

Page 1 of 2 12 LastLast

Similar Threads

  1. Flowplayer
    By rob6894 in forum General Forum
    Replies: 1
    Last Post: 05-01-2012, 02:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •