Results 1 to 3 of 3

Thread: Live Stream Audio Works for FLV Missing for RTSP on Android

  1. #1
    Join Date
    Aug 2012

    Default Live Stream Audio Works for FLV Missing for RTSP on Android


    I have a live stream being encoded with Adobe Flash Media Live Encoder 3.2 publishing to a Wowza 3 server. When connecting to the stream via Flash on the desktop, RTSP on the desktop, or on an iPad I get the stream video and audio. However, when I connect to the stream via Android devices (I've tested it on multiple), I am able to get the video but no audio can be heard. I tried to investigate this a bit and came across the following thread:

    Which says
    Android devices cannot play MP3 streams over RTSP/RTP in any combination (audio/video or audio only).
    which would possibly explain my issues since I am publishing audio as MP3 from FMLE, however, I have also tried transcoding to AAC audio and have still had no luck.

    When I go to the mobile test RTSP stream ( on the Android devices I do get audio so clearly it been done before. Does anything stand out as a reason why I'd be having this issue? Or is there maybe some setting I am missing in my Application.xml/transrate.xml files?

    Any help or guidance would be greatly appreciated. Thanks!
    Last edited by complexcarb; 08-14-2012 at 10:42 PM. Reason: Adding new details

  2. #2
    Join Date
    Dec 2007


    I would continue with AAC. Try different, probably lower, bitrates.


  3. #3
    Join Date
    Aug 2012



    Thanks for your reply. I stuck with AAC and tried lowering the bitrate gradually all the way to 32, I still had no luck with the sound. I used a program called MediaInfo to read the encoding data from the Wowza mobile test page and used the settings of .mov file that is being streamed with RTSP. I used 32Kbps 11025Hz Stereo to match as closely as I could the 32.2Kbps 12000Hz 2 channel AAC encoding of that file. Still no luck.

    According to realistically I should be within the capable ranges of the devices I am using (all 3 are 4.0+).

    Perhaps this is an Android issue as I came across a thread with no response with "Android RTSP request does not send audio SETUP command" but I cannot confirm that behavior as I am streaming directly from the Media Player not from an application.

    Will keep messing around with this to see if I can make any headway.


Similar Threads

  1. Live stream works everywhere except iOS HLS (where only audio works).
    By chocis in forum Live Streaming and Encoders
    Replies: 3
    Last Post: 04-23-2014, 09:24 AM
  2. RTSP audio stream on Android
    By eric2011 in forum General Forum
    Replies: 3
    Last Post: 01-04-2013, 09:57 AM
  3. Live stream works on iPad but not on iPhone or Android.
    By glbntv in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 8
    Last Post: 10-11-2012, 08:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts