Results 1 to 3 of 3

Thread: Transcoder - Source stream frame rate could not be calculated and Audio Bitrate

  1. #1

    Default Transcoder - Source stream frame rate could not be calculated and Audio Bitrate

    Hi There,
    Having a couple issues with the transcoder Add-On.

    I'm using a Sony SNC H.264 IP Camera. The stream settings are 1280x720, 8fps, 1024Kbps bitrate and IFrame Every 2 Seconds.

    When I start wowza in standalone mode, I get the following console output after a successful startup. Take note of two issues I see.

    1. The Audio Bitrate Warnings... Audio <Bitrate> can only be set to ${SourceAudioBitrate} if <Codec> is set to PassThru. Audio <Bitrate> will be set to: 96000

    The transrate.xml template is set for each stream profile as Audio "Disable". If it is Disabled, why am I getting this warning? Is it causing a problem if it sets the audio to 96000??

    2. The frame rate is set in the camera at 8fps. The log errors are giving me:

    "Source stream frame rate could not be calculated. Using default source stream frame rate: 29.97"

    and

    "INFO transcoder encoder-video-start exp-us-wsc {name:"240p", bitrate:350000, codec:H264, profile:Baseline, level:2.1, frameSize:426x240, displaySize:426x240, frameRate:29.97}" for Each profile..

    Why is it not picking up the 8 frames per second?

    See below for code...

    Thanks,

    Tim




    Console Output on Startup: - Below is my transrate.xml code.

    INFO server comment - Wowza Media Server is started!
    INFO server comment - StreamNameAliasFile.load[/usr/local/WowzaMediaServer/conf/aliasmap.stream.txt]: size:50:50 hash:true matchAll:false
    INFO server comment - ModuleStreamNameAlias.nameToAlias[stream]: streamName:exp-us-wsc alias:{pattern: "exp-us-wsc" alias:"rtsp://stream:1pv5stream@108.251.49.177:554/media/video1" wildcardMatches:null} result:rtsp://stream:1pv5stream@108.251.49.177:554/media/video1
    INFO server comment - RTPSessionTracker.add[rtsp://108.251.49.177:554/media/video1]: 1
    INFO server comment - RTPSessionDescriptionDataProviderBasicRTSPWorker.processResponse: SETUP: rtsp://108.251.49.177/media/video1/video
    INFO server comment - RTPSessionDescriptionDataProviderBasicRTSPWorker.buildSDPData: sessionId:1346388076 sessionTimeout:0
    INFO server comment - RTPSessionDescriptionDataProviderBasic.getStreamInfo[transratelive/_definst_]: RTSP/RTP re-streaming. Success, received SDP data.
    INFO stream create - -
    INFO stream publish exp-us-wsc -
    INFO server comment - RTPSessionDescriptionDataProviderBasicRTSPWorker.sessionStart: PLAY: rtsp://108.251.49.177:554/media/video1
    INFO server comment - RTPSessionDescriptionDataProviderBasicRTSPWorker.processResponse: PLAY: rtsp://108.251.49.177/media/video1/
    INFO server comment - RTPMediaCaster.Reconnector[1014900525:transratelive/_definst_:exp-us-wsc]: done: 1
    INFO server comment - firstPacket: TCP:$0
    INFO server comment - TranscoderSessionNative.loadLibrary: Load transcoder list: /usr/local/WowzaMediaServer/lib-native/linux64/transcoder.list
    INFO server comment - LiveStreamTranscoder.init[transratelive/_definst_/exp-us-wsc]: Load transcoder template: file:///usr/local/WowzaMediaServer/transcoder/templates/exp-us-wsc.xml
    WARN server comment - TranscodingStreamUtils.loadTemplateStreamAudio: Error parsing transcoding template: (file:///usr/local/WowzaMediaServer/transcoder/templates/exp-us-wsc.xml:source). Audio <Bitrate> can only be set to ${SourceAudioBitrate} if <Codec> is set to PassThru. Audio <Bitrate> will be set to: 96000
    WARN server comment - TranscodingStreamUtils.loadTemplateStreamAudio: Error parsing transcoding template: (file:///usr/local/WowzaMediaServer/transcoder/templates/exp-us-wsc.xml:720p). Audio <Bitrate> can only be set to ${SourceAudioBitrate} if <Codec> is set to PassThru. Audio <Bitrate> will be set to: 96000
    WARN server comment - TranscodingStreamUtils.loadTemplateStreamAudio: Error parsing transcoding template: (file:///usr/local/WowzaMediaServer/transcoder/templates/exp-us-wsc.xml:576p). Audio <Bitrate> can only be set to ${SourceAudioBitrate} if <Codec> is set to PassThru. Audio <Bitrate> will be set to: 96000
    WARN server comment - TranscodingStreamUtils.loadTemplateStreamAudio: Error parsing transcoding template: (file:///usr/local/WowzaMediaServer/transcoder/templates/exp-us-wsc.xml:530p). Audio <Bitrate> can only be set to ${SourceAudioBitrate} if <Codec> is set to PassThru. Audio <Bitrate> will be set to: 96000
    WARN server comment - TranscodingStreamUtils.loadTemplateStreamAudio: Error parsing transcoding template: (file:///usr/local/WowzaMediaServer/transcoder/templates/exp-us-wsc.xml:450p). Audio <Bitrate> can only be set to ${SourceAudioBitrate} if <Codec> is set to PassThru. Audio <Bitrate> will be set to: 96000
    WARN server comment - TranscodingStreamUtils.loadTemplateStreamAudio: Error parsing transcoding template: (file:///usr/local/WowzaMediaServer/transcoder/templates/exp-us-wsc.xml:360p). Audio <Bitrate> can only be set to ${SourceAudioBitrate} if <Codec> is set to PassThru. Audio <Bitrate> will be set to: 96000
    WARN server comment - TranscodingStreamUtils.loadTemplateStreamAudio: Error parsing transcoding template: (file:///usr/local/WowzaMediaServer/transcoder/templates/exp-us-wsc.xml:240p). Audio <Bitrate> can only be set to ${SourceAudioBitrate} if <Codec> is set to PassThru. Audio <Bitrate> will be set to: 96000
    WARN server comment - TranscodingStreamUtils.loadTemplateStreamAudio: Error parsing transcoding template: (file:///usr/local/WowzaMediaServer/transcoder/templates/exp-us-wsc.xml:160p). Audio <Bitrate> can only be set to ${SourceAudioBitrate} if <Codec> is set to PassThru. Audio <Bitrate> will be set to: 96000
    WARN server comment - TranscodingStreamUtils.loadTemplateStreamAudio: Error parsing transcoding template: (file:///usr/local/WowzaMediaServer/transcoder/templates/exp-us-wsc.xml:120p). Audio <Bitrate> can only be set to ${SourceAudioBitrate} if <Codec> is set to PassThru. Audio <Bitrate> will be set to: 96000
    INFO server comment - JNI:TranscoderSession.isCUDAAvailable[_defaultVHost_:transratelive/_definst_/exp-us-wsc]: NVidia CUDA hardware acceleration is NOT available on Linux
    INFO server comment - JNI:TranscoderSession.isQuickSyncAvailable[_defaultVHost_:transratelive/_definst_/exp-us-wsc]: Intel Quick Sync hardware acceleration is NOT available on Linux
    INFO stream create - -
    INFO stream publish exp-us-wsc_576p -
    INFO stream create - -
    INFO stream publish exp-us-wsc_source -
    INFO stream create - -
    INFO stream publish exp-us-wsc_450p -
    INFO stream create - -
    INFO stream publish exp-us-wsc_530p -
    INFO stream create - -
    INFO stream publish exp-us-wsc_240p -
    INFO stream create - -
    INFO stream publish exp-us-wsc_120p -
    INFO stream create - -
    INFO stream publish exp-us-wsc_360p -
    INFO stream create - -
    INFO stream publish exp-us-wsc_160p -
    INFO stream create - -
    INFO stream publish exp-us-wsc_720p -
    WARN server comment - TranscoderWorkerVideoDecoder.handlePacket[_defaultVHost_:transratelive/_definst_/exp-us-wsc]: Source stream frame rate could not be calculated. Using default source stream frame rate: 29.97
    INFO server comment - JNI:TranscoderSession.videoDecoderCreate[_defaultVHost_:transratelive/_definst_/exp-us-wsc]: Create video decoder: H.264: default
    INFO transcoder decoder-video-start exp-us-wsc {codec:H264, profile:Baseline, level:3.1, frameSize:1280x720, displaySize:1280x720, frameRate:0.0}
    INFO server comment - JNI:VideoDecoderH264.updateDecodeInfo[global]: aspect:16x9 frame:1280x720 display:1280x720 frameRate:29.97
    INFO server comment - JNI:TranscoderSession.videoEncoderAdd[_defaultVHost_:transratelive/_definst_/exp-us-wsc:576p]: Create video encoder: H.264: default
    WARN server comment - JNI:VideoEncoderH264::setDefaults: CPUID vendor:GenuineIntel isMMX:1 isSSE:1 isSSE2:1 isSSE3:1 cpu_opt:6
    INFO server comment - JNI:TranscoderSession.videoEncoderAdd[_defaultVHost_:transratelive/_definst_/exp-us-wsc:450p]: Create video encoder: H.264: default
    WARN server comment - JNI:VideoEncoderH264::setDefaults: CPUID vendor:GenuineIntel isMMX:1 isSSE:1 isSSE2:1 isSSE3:1 cpu_opt:6
    INFO server comment - JNI:TranscoderSession.videoEncoderAdd[_defaultVHost_:transratelive/_definst_/exp-us-wsc:530p]: Create video encoder: H.264: default
    WARN server comment - JNI:VideoEncoderH264::setDefaults: CPUID vendor:GenuineIntel isMMX:1 isSSE:1 isSSE2:1 isSSE3:1 cpu_opt:6
    INFO server comment - JNI:TranscoderSession.videoEncoderAdd[_defaultVHost_:transratelive/_definst_/exp-us-wsc:240p]: Create video encoder: H.264: default
    WARN server comment - JNI:VideoEncoderH264::setDefaults: CPUID vendor:GenuineIntel isMMX:1 isSSE:1 isSSE2:1 isSSE3:1 cpu_opt:6
    INFO server comment - JNI:TranscoderSession.videoEncoderAdd[_defaultVHost_:transratelive/_definst_/exp-us-wsc:120p]: Create video encoder: H.264: default
    WARN server comment - JNI:VideoEncoderH264::setDefaults: CPUID vendor:GenuineIntel isMMX:1 isSSE:1 isSSE2:1 isSSE3:1 cpu_opt:6
    INFO server comment - JNI:TranscoderSession.videoEncoderAdd[_defaultVHost_:transratelive/_definst_/exp-us-wsc:360p]: Create video encoder: H.264: default
    WARN server comment - JNI:VideoEncoderH264::setDefaults: CPUID vendor:GenuineIntel isMMX:1 isSSE:1 isSSE2:1 isSSE3:1 cpu_opt:6
    INFO server comment - JNI:TranscoderSession.videoEncoderAdd[_defaultVHost_:transratelive/_definst_/exp-us-wsc:160p]: Create video encoder: H.264: default
    WARN server comment - JNI:VideoEncoderH264::setDefaults: CPUID vendor:GenuineIntel isMMX:1 isSSE:1 isSSE2:1 isSSE3:1 cpu_opt:6
    INFO server comment - JNI:TranscoderSession.videoEncoderAdd[_defaultVHost_:transratelive/_definst_/exp-us-wsc:720p]: Create video encoder: H.264: default
    WARN server comment - JNI:VideoEncoderH264::setDefaults: CPUID vendor:GenuineIntel isMMX:1 isSSE:1 isSSE2:1 isSSE3:1 cpu_opt:6
    INFO server comment - firstPacket: TCP:$1
    INFO transcoder encoder-video-start exp-us-wsc {name:"240p", bitrate:350000, codec:H264, profile:Baseline, level:2.1, frameSize:426x240, displaySize:426x240, frameRate:29.97}
    INFO transcoder encoder-video-start exp-us-wsc {name:"160p", bitrate:200000, codec:H264, profile:Baseline, level:1.2, frameSize:284x160, displaySize:284x160, frameRate:29.97}
    INFO transcoder encoder-video-start exp-us-wsc {name:"120p", bitrate:60000, codec:H264, profile:Baseline, level:1.2, frameSize:214x120, displaySize:214x120, frameRate:29.97}
    INFO transcoder encoder-video-start exp-us-wsc {name:"450p", bitrate:850000, codec:H264, profile:Main, level:3.1, frameSize:800x450, displaySize:800x450, frameRate:29.97}
    INFO transcoder encoder-video-start exp-us-wsc {name:"530p", bitrate:1024000, codec:H264, profile:Main, level:3.1, frameSize:942x530, displaySize:942x530, frameRate:29.97}
    INFO transcoder encoder-video-start exp-us-wsc {name:"360p", bitrate:600000, codec:H264, profile:Main, level:3.0, frameSize:640x360, displaySize:640x360, frameRate:29.97}
    INFO server comment - TranscoderStreamNameGroup.addInternal[_defaultVHost_:transratelive/_definst_/exp-us-wsc]: Add name group: exp-us-wsc_mobile
    INFO transcoder encoder-video-start exp-us-wsc {name:"576p", bitrate:1150000, codec:H264, profile:Main, level:3.1, frameSize:1024x576, displaySize:1024x576, frameRate:29.97}
    INFO transcoder encoder-video-start exp-us-wsc {name:"720p", bitrate:1500000, codec:H264, profile:Main, level:3.1, frameSize:1280x720, displaySize:1280x720, frameRate:29.97}
    INFO server comment - TranscoderStreamNameGroup.addInternal[_defaultVHost_:transratelive/_definst_/exp-us-wsc]: Add name group: exp-us-wsc_all
    Trasrate.xml Code:

    <!-- Example template for transrate, producing four new streams at different bitrates. Resultant streams can be played back individually or as a group. source, 360p and 160p encode blocks are enabled through the Enable property, other examples are not enabled. Add additional encode blocks to your template as needed. -->
    <Root>
            <Transcode>
                    <Encodes>
                            <!-- Example Encode block for source, not required unless Member of StreamNameGroup. --> 
                            <Encode>
                                    <Enable>true</Enable>
                                    <Name>source</Name>
                                    <StreamName>mp4:${SourceStreamName}_source</StreamName>
                                    <Video>
                                            <!-- H.264, PassThru, Disable -->
                                            <Codec>PassThru</Codec>
                                            <Bitrate>${SourceVideoBitrate}</Bitrate>
                                            <Parameters>
                                            </Parameters>
                                    </Video>
                                    <Audio>
                                            <!-- AAC, PassThru, Disable -->
                                            <Codec>Disable</Codec>
                                            <Bitrate>${SourceAudioBitrate}</Bitrate>
                                            <Parameters>
                                            </Parameters>
                                    </Audio>
                                    <Properties>
                                    </Properties>
                            </Encode>
                            <!-- Setup for 720p, high bandwith, main profile for desktop or set-top box -->
                            <Encode>
                                    <Enable>true</Enable>
                                    <Name>720p</Name>
                                    <StreamName>mp4:${SourceStreamName}_720p</StreamName>
                                    <Video>
                                            <!-- H.264, PassThru, Disable -->
                                            <Codec>H.264</Codec>
                                            <!-- default, CUDA, QuickSync -->
                                            <Transcoder>default</Transcoder>
                                            <GPUID>-1</GPUID>
                                            <FrameSize>
                                                    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
                                                    <FitMode>fit-height</FitMode>
                                                    <Width>1280</Width>
                                                    <Height>720</Height>
                                                    <!-- <Crop>0,0,0,0</Crop> -->
                                                    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
                                            </FrameSize>
                                            <Profile>main</Profile>
                                            <Bitrate>1500000</Bitrate>
                                            <KeyFrameInterval>
                                                    <FollowSource>true</FollowSource>
                                                    <Interval>60</Interval>
                                            </KeyFrameInterval>
                                            <Overlays>
                                                    <Overlay>
                                                            <Enable>false</Enable>
                                                            <Index>0</Index>
                                                            <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
                                                            <Opacity>100</Opacity>
                                                            <Location>
                                                                    <X>5</X>
                                                                    <Y>5</Y>
                                                                    <Width>${ImageWidth}</Width>
                                                                    <Height>${ImageHeight}</Height>
                                                                    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
                                                                    <Align>left,top</Align>
                                                            </Location>
                                                    </Overlay>
                                            </Overlays>
                                            <Parameters>
                                            </Parameters>
                                    </Video>
                                    <Audio>
                                            <!-- AAC, PassThru, Disable -->
                                            <Codec>Disable</Codec>
                                            <Bitrate>${SourceAudioBitrate}</Bitrate>
                                            <Parameters>
                                            </Parameters>
                                    </Audio>
                                    <Properties>
                                    </Properties>
                            </Encode>
              <!-- Setup for 576p, high bandwith, main profile for desktop or set-top box -->
                            <Encode>
                                    <Enable>true</Enable>
                                    <Name>576p</Name>
                                    <StreamName>mp4:${SourceStreamName}_576p</StreamName>
                                    <Video>
                                            <!-- H.264, PassThru, Disable -->
                                            <Codec>H.264</Codec>
                                            <!-- default, CUDA, QuickSync -->
                                            <Transcoder>default</Transcoder>
                                            <GPUID>-1</GPUID>
                                            <FrameSize>
                                                    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
                                                    <FitMode>fit-height</FitMode>
                                                    <Width>1024</Width>
                                                    <Height>576</Height>
                                                    <!-- <Crop>0,0,0,0</Crop> -->
                                                    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
                                            </FrameSize>
                                            <Profile>main</Profile>
                                            <Bitrate>1150000</Bitrate>
                                            <KeyFrameInterval>
                                                    <FollowSource>true</FollowSource>
                                                    <Interval>60</Interval>
                                            </KeyFrameInterval>
                                            <Overlays>
                                                    <Overlay>
                                                            <Enable>false</Enable>
                                                            <Index>0</Index>
                                                            <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
                                                            <Opacity>100</Opacity>
                                                            <Location>
                                                                    <X>5</X>
                                                                    <Y>5</Y>
                                                                    <Width>${ImageWidth}</Width>
                                                                    <Height>${ImageHeight}</Height>
                                                                    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
                                                                    <Align>left,top</Align>
                                                            </Location>
                                                    </Overlay>
                                            </Overlays>
                                            <Parameters>
                                            </Parameters>
                                    </Video>
                                    <Audio>
                                            <!-- AAC, PassThru, Disable -->
                                            <Codec>Disable</Codec>
                                            <Bitrate>${SourceAudioBitrate}</Bitrate>
                                            <Parameters>
                                            </Parameters>
                                    </Audio>
                                    <Properties>
                                    </Properties>
                            </Encode>
    i         <!-- Setup for 530p, high bandwith, main profile for desktop or set-top box -->
                            <Encode>
                                    <Enable>true</Enable>
                                    <Name>530p</Name>
                                    <StreamName>mp4:${SourceStreamName}_530p</StreamName>
                                    <Video>
                                            <!-- H.264, PassThru, Disable -->
                                            <Codec>H.264</Codec>
                                            <!-- default, CUDA, QuickSync -->
                                            <Transcoder>default</Transcoder>
                                            <GPUID>-1</GPUID>
                                            <FrameSize>
                                                    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
                                                    <FitMode>fit-height</FitMode>
                                                    <Width>942</Width>
                                                    <Height>530</Height>
                                                    <!-- <Crop>0,0,0,0</Crop> -->
                                                    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
                                            </FrameSize>
                                            <Profile>main</Profile>
                                            <Bitrate>1024000</Bitrate>
                                            <KeyFrameInterval>
                                                    <FollowSource>true</FollowSource>
                                                    <Interval>60</Interval>
                                            </KeyFrameInterval>
                                            <Overlays>
                                                    <Overlay>
                                                            <Enable>false</Enable>
                                                            <Index>0</Index>
                                                            <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
                                                            <Opacity>100</Opacity>
                                                            <Location>
                                                                    <X>5</X>
                                                                    <Y>5</Y>
                                                                    <Width>${ImageWidth}</Width>
                                                                    <Height>${ImageHeight}</Height>
                                                                    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
                                                                    <Align>left,top</Align>
                                                            </Location>
                                                    </Overlay>
                                            </Overlays>
                                            <Parameters>
                                            </Parameters>
                                    </Video>
                                    <Audio>
                                            <!-- AAC, PassThru, Disable -->
                                            <Codec>Disable</Codec>
                                            <Bitrate>${SourceAudioBitrate}</Bitrate>
                                            <Parameters>
                                            </Parameters>
                                    </Audio>
                                    <Properties>
                                    </Properties>
                            </Encode>
         <!-- Setup for 450p, high bandwith, main profile for desktop or set-top box -->
                            <Encode>
                                    <Enable>true</Enable>
                                    <Name>450p</Name>
                                    <StreamName>mp4:${SourceStreamName}_450p</StreamName>
                                    <Video>
                                            <!-- H.264, PassThru, Disable -->
                                            <Codec>H.264</Codec>
                                            <!-- default, CUDA, QuickSync -->
                                            <Transcoder>default</Transcoder>
                                            <GPUID>-1</GPUID>
                                            <FrameSize>
                                                    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
                                                    <FitMode>crop</FitMode>
                                                    <Width>800</Width>
                                                    <Height>450</Height>
                                                    <!-- <Crop>0,0,15,15</Crop> -->
                                                    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
                                            </FrameSize>
                                            <Profile>main</Profile>
                                            <Bitrate>850000</Bitrate>
                                            <KeyFrameInterval>
                                                    <FollowSource>true</FollowSource>
                                                    <Interval>60</Interval>
                                            </KeyFrameInterval>
                                            <Overlays>
                                                    <Overlay>
                                                            <Enable>false</Enable>
                                                            <Index>0</Index>
                                                            <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
                                                            <Opacity>100</Opacity>
                                                            <Location>
                                                                    <X>5</X>
                                                                    <Y>5</Y>
                                                                    <Width>${ImageWidth}</Width>
                                                                    <Height>${ImageHeight}</Height>
                                                                    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
                                                                    <Align>left,top</Align>
                                                            </Location>
                                                    </Overlay>
                                            </Overlays>
                                            <Parameters>
                                            </Parameters>
                                    </Video>
                                    <Audio>
                                            <!-- AAC, PassThru, Disable -->
                                            <Codec>Disable</Codec>
                                            <Bitrate>${SourceAudioBitrate}</Bitrate>
                                            <Parameters>
                                            </Parameters>
                                    </Audio>
                                    <Properties>
                                    </Properties>
                            </Encode>
                            <!-- Setup for 360p, high bandwith, main profile for desktop -->
                            <Encode>
                                    <Enable>true</Enable>
                                    <Name>360p</Name>
                                    <StreamName>mp4:${SourceStreamName}_360p</StreamName>
                                    <Video>
                                            <!-- H.264, PassThru, Disable -->
                                            <Codec>H.264</Codec>
                                            <!-- default, CUDA, QuickSync -->
                                            <Transcoder>default</Transcoder>
                                            <GPUID>-1</GPUID>
                                            <FrameSize>
                                                    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
                                                    <FitMode>fit-height</FitMode>
                                                    <Width>640</Width>
                                                    <Height>360</Height>
                                                    <!-- <Crop>0,0,0,0</Crop> -->
                                                    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
                                            </FrameSize>
                                            <Profile>main</Profile>
                                            <Bitrate>600000</Bitrate>
                                            <KeyFrameInterval>
                                                    <FollowSource>true</FollowSource>
                                                    <Interval>60</Interval>
                                            </KeyFrameInterval>
                                            <Overlays>
                                                    <Overlay>
                                                            <Enable>false</Enable>
                                                            <Index>0</Index>
                                                            <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
                                                            <Opacity>100</Opacity>
                                                            <Location>
                                                                    <X>5</X>
                                                                    <Y>5</Y>
                                                                    <Width>${ImageWidth}</Width>
                                                                    <Height>${ImageHeight}</Height>
                                                                    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
                                                                    <Align>left,top</Align>
                                                            </Location>
                                                    </Overlay>
                                            </Overlays>
                                            <Parameters>
                                            </Parameters>
                                    </Video>
                                    <Audio>
                                            <!-- AAC, PassThru, Disable -->
                                            <Codec>Disable</Codec>
                                            <Bitrate>${SourceAudioBitrate}</Bitrate>
                                            <Parameters>
                                            </Parameters>
                                    </Audio>
                                    <Properties>
                                    </Properties>
                            </Encode>
                            <!-- Setup for 240p, medium bandwidth, baseline profile -->
                            <Encode>
                                    <Enable>true</Enable>
                                    <Name>240p</Name>
                                    <StreamName>mp4:${SourceStreamName}_240p</StreamName>
                                    <Video>
                                            <!-- H.264, PassThru, Disable -->
                                            <Codec>H.264</Codec>
                                            <!-- default, CUDA, QuickSync -->
                                            <Transcoder>default</Transcoder>
                                            <GPUID>-1</GPUID>
                                            <FrameSize>
                                                    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source  -->
                                                    <FitMode>fit-height</FitMode>
                                                    <Width>360</Width>
                                                    <Height>240</Height>
                                                    <!-- <Crop>0,0,0,0</Crop> -->
                                                    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
                                            </FrameSize>
                                            <Profile>baseline</Profile>
                                            <Bitrate>350000</Bitrate>
                                            <KeyFrameInterval>
                                                    <FollowSource>true</FollowSource>
                                                    <Interval>60</Interval>
                                            </KeyFrameInterval>
                                            <Overlays>
                                                    <Overlay>
                                                            <Enable>false</Enable>
                                                            <Index>0</Index>
                                                            <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
                                                            <Opacity>100</Opacity>
                                                            <Location>
                                                                    <X>5</X>
                                                                    <Y>5</Y>
                                                                    <Width>${ImageWidth}</Width>
                                                                    <Height>${ImageHeight}</Height>
                                                                    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
                                                                    <Align>left,top</Align>
                                                            </Location>
                                                    </Overlay>
                                            </Overlays>
                                            <Parameters>
                                            </Parameters>
                                    </Video>
                                    <Audio>
                                            <!-- AAC, PassThru, Disable -->
                                            <Codec>Disable</Codec>
                                            <Bitrate>${SourceAudioBitrate}</Bitrate>
                                            <Parameters>
                                            </Parameters>
                                    </Audio>
                                    <Properties>
                                    </Properties>
                            </Encode>
                            <!-- Setup for 160p, low bandwith, baseline profile for 3G mobile devices such as iOS, Android, Blackberry -->
                            <Encode>
                                    <Enable>true</Enable>
                                    <Name>160p</Name>
                                    <StreamName>mp4:${SourceStreamName}_160p</StreamName>
                                    <Video>
                                            <!-- H.264, PassThru, Disable -->
                                            <Codec>H.264</Codec>
                                            <!-- default, CUDA, QuickSync -->
                                            <Transcoder>default</Transcoder>
                                            <GPUID>-1</GPUID>
                                            <FrameSize>
                                                    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source  -->
                                                    <FitMode>fit-height</FitMode>
                                                    <Width>284</Width>
                                                    <Height>160</Height>
                                                    <!-- <Crop>0,0,0,0</Crop> -->
                                                    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
                                            </FrameSize>
                                            <Profile>baseline</Profile>
                                            <Bitrate>200000</Bitrate>
                                            <KeyFrameInterval>
                                                    <FollowSource>true</FollowSource>
                                                    <Interval>60</Interval>
                                            </KeyFrameInterval>
                                            <Overlays>
                                                    <Overlay>
                                                            <Enable>false</Enable>
                                                            <Index>0</Index>
                                                            <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
                                                            <Opacity>100</Opacity>
                                                            <Location>
                                                                    <X>5</X>
                                                                    <Y>5</Y>
                                                                    <Width>${ImageWidth}</Width>
                                                                    <Height>${ImageHeight}</Height>
                                                                    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
                                                                    <Align>left,top</Align>
                                                            </Location>
                                                    </Overlay>
                                            </Overlays>
                                            <Parameters>
                                            </Parameters>
                                    </Video>
                                    <Audio>
                                            <!-- AAC, PassThru, Disable -->
                                            <Codec>Disable</Codec>
                                            <Bitrate>${SourceAudioBitrate}</Bitrate>
                                            <Parameters>
                                            </Parameters>
                                    </Audio>
                                    <Properties>
                                    </Properties>
                            </Encode>
                  <!-- Setup for 120p, low bandwith, baseline profile for 3G mobile devices such as iOS, Android, Blackberry -->
                            <Encode>
                                    <Enable>true</Enable>
                                    <Name>120p</Name>
                                    <StreamName>mp4:${SourceStreamName}_120p</StreamName>
                                    <Video>
                                            <!-- H.264, PassThru, Disable -->
                                            <Codec>H.264</Codec>
                                            <!-- default, CUDA, QuickSync -->
                                            <Transcoder>default</Transcoder>
                                            <GPUID>-1</GPUID>
                                            <FrameSize>
                                                    <!-- letterbox, fit-width, fit-height, crop, stretch, match-source  -->
                                                    <FitMode>fit-height</FitMode>
                                                    <Width>213</Width>
                                                    <Height>120</Height>
                                                    <!-- <Crop>0,0,0,0</Crop> -->
                                                    <!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
                                            </FrameSize>
                                            <Profile>baseline</Profile>
                                            <Bitrate>60000</Bitrate>
                                            <KeyFrameInterval>
                                                    <FollowSource>true</FollowSource>
                                                    <Interval>60</Interval>
                                            </KeyFrameInterval>
                                            <Overlays>
                                                    <Overlay>
                                                            <Enable>false</Enable>
                                                            <Index>0</Index>
                                                            <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
                                                            <Opacity>100</Opacity>
                                                            <Location>
                                                                    <X>5</X>
                                                                    <Y>5</Y>
                                                                    <Width>${ImageWidth}</Width>
                                                                    <Height>${ImageHeight}</Height>
                                                                    <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
                                                                    <Align>left,top</Align>
                                                            </Location>
                                                    </Overlay>
                                            </Overlays>
                                            <Parameters>
                                            </Parameters>
                                    </Video>
                                    <Audio>
                                            <!-- AAC, PassThru, Disable -->
                                            <Codec>Disable</Codec>
                                            <Bitrate>${SourceAudioBitrate}</Bitrate>
                                            <Parameters>
                                            </Parameters>
                                    </Audio>
                                    <Properties>
                                    </Properties>
                            </Encode>
                    </Encodes>
                    <Decode>
                            <Video>
                                    <Deinterlace>false</Deinterlace>
                                    <Overlays>
                                            <Overlay>
                                                    <Enable>false</Enable>
                                                    <Index>0</Index>
                                                    <ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
                                                    <Opacity>100</Opacity>
                                                    <Location>
                                                            <X>5</X>
                                                            <Y>5</Y>
                                                            <Width>${ImageWidth}</Width>
                                                            <Height>${ImageHeight}</Height>
                                                            <!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
                                                            <Align>left,top</Align>
                                                    </Location>
                                            </Overlay>
                                    </Overlays>
                                    <Parameters>
                                    </Parameters>
                            </Video>
                            <Properties>
                            </Properties>
                    </Decode>
                    <StreamNameGroups>
                            <!-- Note: Play stream using stream name ngrp:[stream-name] -->
                            <StreamNameGroup>
                                    <Name>${SourceStreamName}_all</Name>
                                    <Members>
                                            <Member>
                                                    <EncodeName>source</EncodeName>
                                            </Member>
                                            <Member>
                                                    <EncodeName>720p</EncodeName>
                                            </Member>
                                            <Member>
                                                    <EncodeName>576p</EncodeName>
                                            </Member>
                                            <Member>
                                                    <EncodeName>530p</EncodeName>
                                            </Member>
                                            <Member>
                                                    <EncodeName>450p</EncodeName>
                                            </Member>
                                            <Member>
                                                    <EncodeName>360p</EncodeName>
                                            </Member>
                                            <Member>
                                                    <EncodeName>240p</EncodeName>
                                            </Member>
                                            <Member>
                                                    <EncodeName>160p</EncodeName>
                                            </Member>
                                            <Member>
                                                    <EncodeName>120p</EncodeName>
                                            </Member>
                                    </Members>
                            </StreamNameGroup>
                            <StreamNameGroup>
                                    <Name>${SourceStreamName}_mobile</Name>
                                    <Members>
                                            <Member>
                                                    <EncodeName>360p</EncodeName>
                                            </Member>
                                            <Member>
                                                    <EncodeName>240p</EncodeName>
                                            </Member>
                                            <Member>
                                                    <EncodeName>160p</EncodeName>
                                            </Member>
                                            <Member>
                                                    <EncodeName>120p</EncodeName>
                                            </Member>
                                    </Members>
                            </StreamNameGroup>
                    </StreamNameGroups>
                    <Properties>
                    </Properties>
            </Transcode>
    </Root>

  2. #2

    Default

    Audio bit rate issue solved. I read the trancoder instructions again...

    ${SourceAudioBitrate}: Variable that will be replaced with the audio bitrate of the source stream (can only be used if Audio/Codec is PassThru)


    Still having an issue with the "Source stream frame rate could not be calculated. Using default source stream frame rate: 29.97"

    Thanks,

    Tim

  3. #3
    Join Date
    May 2011
    Posts
    456

    Default

    There was a recent fix that may address this issue. Please try this patch and let us know if that resolves it.

    -Lisa

Similar Threads

  1. Replies: 3
    Last Post: 12-05-2013, 05:32 PM
  2. stream frame rate could not be calculated
    By pburke in forum AddOn: Transcoder
    Replies: 2
    Last Post: 09-16-2013, 02:07 PM
  3. Error- Source stream frame rate could not be calculated
    By markmn12 in forum Live Streaming and Encoder Discussion
    Replies: 3
    Last Post: 07-23-2013, 07:12 AM
  4. Replies: 1
    Last Post: 02-13-2012, 03:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •