Results 1 to 6 of 6

Thread: Record using H264 profile issues

  1. #1

    Default Record using H264 profile issues

    Hi,

    I was trying to record the video stream using the LiveStreamRecord_3.0 module.
    Everything works great, I applies the new H264VideoStreamSettings with different H264Profile(swapping between main and baseline profiles) and it plays the live stream perfectly.
    However, when I tried to play the recorded stream file, the stream got stuck at the time when I swapped different profiles(either from main to baseline or baseline to main).
    Any ideas? Thank you in advance.

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Some players cannot handle abrupt codec changes

    Richard

  3. #3

    Default

    Hi Richard,

    I found that even I changed different level with the same profile, the recorded stream still didn't play properly.
    it is the problem of packetising the video during recording to file?

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    It's a player issue. There isn't anything you can do except to avoid codec changes that the player cannot handle.

    Richard

  5. #5

    Default

    Hi Richard,

    I found a way to get around it by closing the netstream and republish the stream when the new profile settings changed. It works fine.
    Thank you Richard.

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Sounds good, glad it's working. Thanks for the update.

    Richard

Similar Threads

  1. Why wowza not support high profile h264
    By jacklam in forum Live Streaming and Encoder Discussion
    Replies: 12
    Last Post: 10-28-2013, 09:33 PM
  2. How wowza calculates H264 profile?
    By greenf in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 02-14-2012, 05:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •