Results 1 to 4 of 4

Thread: Nokia Devices and Blacberry cannot play Live stream but Andriod and Iphone can play

  1. #1
    Join Date
    Sep 2012
    Posts
    2

    Default Nokia Devices and Blacberry cannot play Live stream but Andriod and Iphone can play

    Hi ,

    I am using FLME 3.2 as an encoder and downloaded a Free trial of Latest Wowza server .

    I am able to play using these links and FMLE settings mentioned below on my Iphone and Andriod Mobile phones .

    rtsp://182.71.17.197:1935/live/livestream.sdp ...................for Android

    [url]http://182.71.17.197:1935/live/livestream.sdp/playlist.m3u8.............for Apple iOS Devices

    In FMLE I am using following settings
    Audio Format AAC
    Vedio Format H264
    Link : rtmp://192.168.0.22:1935
    Streamname : livestream.sdp


    But I am not able to play on Nokia Mobile and Blacberry Mobile Phones .
    On both these Phone it say " Unable to Play Vedio "


    Pls suggest what can I do to play my Live Stream on Nokia Mobile and Blacberry Mobile Phones ???.


    Thanks









    Pls help .

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Make sure you are using Baseline Profile. Low bitrate and frame size might help.

    But it is probably UDP ports. Playback the rtsp output from Wowza in VLC and look at Tools > Codec Info. If there are two sets of audio and video info then UDP ports are blocked between the client and Wowza somewhere, either a firewall or not mapped in your network to Wowza server. You can see this in the access log too. Look for a pattern of RTPUDPTransport.bind lines in the access log followed by unbind when you try to play a stream on the device, something like this.

    RTPUDPTransport.bind[live/_definst_]: /10.0.167.8:6982
    RTPUDPTransport.bind[live/_definst_]: /10.0.167.8:6983

    -- might be a few intervening log lines here but not= firstPacket, then:

    RTPUDPTransport.unbind[live/_definst_]: /10.0.167.8:6982
    RTPUDPTransport.unbind[live/_definst_]: /10.0.167.8:6983

    It might sets of 2, as above, or 4

    Richard

  3. #3
    Join Date
    Sep 2012
    Posts
    2

    Default

    Hi Richard
    Thanks for quick Response

    I am using the Baseline Profile and bitrate is set to 100kbps .
    Audio bit rate is 20kbps

    I have copied the Codec info below when I play my Live stream from VLC .
    Stream 0
    Type:Audio
    Codec: MPEG AACAudio(mp4a)
    Channels: Stereo
    Sample rate:44100 Hz
    Stream 1
    Type: Vedio
    Codec:H264-MPEG-4 AVC(part10)(h264)
    Resolution:240*180
    Frame rate:50
    Decoded format: Planar 4:2:0 YUV


    From above I can See that it just show one set of Audio and Vedio .
    I have also tested with low bit rate as 50 kbps .

    Pls note that I am able to play Live streaming on Andriod and Iphone Mobile devices .

    But not able to play Live streaming on Nokia and Blackberry .

    Pls Suggest the necessary steps or configuration required to play Live streaming on Nokia and Blackberry ??

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Zip up and send the conf and logs folders to support@wowza.com. But first re-start Wowza and test a device that works then test the devices that don't work.

    Include a link to this thread for reference

    Richard

Similar Threads

  1. How to play live stream on mobile devices with html5 video tag?
    By vosovskiy in forum Live Streaming and Encoder Discussion
    Replies: 7
    Last Post: 08-28-2013, 07:12 PM
  2. unable to play my live streaming url in Nokia mobiles
    By rajkumar4334 in forum Live Streaming and Encoder Discussion
    Replies: 7
    Last Post: 07-25-2013, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •