Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Problems with HLS and Panasonic WV-SC385

  1. #1

    Default Problems with HLS and Panasonic WV-SC385

    I have about 15-20 IP cameras running right now. Some are Axis and most are Panasonic WV-SC385. I've noticed that I cannot get the HLS stream to work on Android (I'm using 4.1 Jelly Bean right now). I get a "can't play video" error. However, the HLS streams work fine for the Axis cameras. I've also noticed that even though I adjust the max frame rate setting in the Panasonic cams, it always shows up as 29.97 in VLC. The frame rate for the Axis cams does not show up at all. Does anyone have a clue as to why the Panasonic HLS streams aren't working correctly?

  2. #2
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi
    Can you give us the video and audio codec information of the streams being sent to Wowza from the Panasonic cams?
    Are you using the Wowza transcoder in your set-up?

    Does the OSMF player, iOS devices or Silverlight play the streams from the Panasonic cams?

    Jason

  3. #3

    Default

    Audio is turned off and video is h.264. I am not using the transcoder at all. The streams work in all players except on Android 4.1. That's the only issue I'm having. Here is a stream if you want to test it.
    http://appnetjobs.com:1935/live/blow.../playlist.m3u8

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Does RTSP playback work in that device?

    Richard

  5. #5

    Default

    Quote Originally Posted by rrlanham View Post
    Does RTSP playback work in that device?

    Richard
    RTSP from the cam or from Wowza?

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Either one.

    Richard

  7. #7

    Default

    So after doing some reading, I found out that Google dropped support for HLS streaming with the h.264 codec in Android 4.1. Only WebM video will work. What a stupid decision. Is Wowza going to support this anytime soon?

    RTSP doesn't work in either the stock internet browser or in Chrome using JW Player. It actually causes Chrome to crash. However, http://fl2.viastreaming.net:1935/smr.../playlist.m3u8 that stream works fine in both Chrome and stock browser. I have on idea what is going on.

  8. #8

    Default

    Bump. Anybody from Wowza know why some m3u8 streams work and some don't?

  9. #9
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    For Android the only reliable option at present is RTSP streaming. I don't think JW Player is useful in Android. You just open the RTSP url directly in Android browser.

    Richard

  10. #10

    Default

    I figured out something...on the Panasonic cams half of my TS chunks have a negative duration.

    #EXTM3U
    #EXT-X-VERSION:3
    #EXT-X-ALLOW-CACHE:NO
    #EXT-X-TARGETDURATION:18
    #EXT-X-MEDIA-SEQUENCE:3649
    #EXTINF:10.048,
    media_3649.ts?wowzasessionid=534878348
    #EXTINF:-0.033,
    media_3650.ts?wowzasessionid=534878348
    #EXTINF:10.048,
    media_3651.ts?wowzasessionid=534878348

    I noticed this when testing out HLS streams in the new JW6 flash player. The stream cuts out after a few seconds. However, the Axis cams do not do this. Does anyone have an idea why the Panasonic cams do this?

Page 1 of 2 12 LastLast

Similar Threads

  1. APPLE HLS Memory Consuption problems - need help
    By oomworld in forum General Forum
    Replies: 3
    Last Post: 08-19-2014, 05:33 PM
  2. Panasonic HX-A100
    By hc2hunter in forum General Forum
    Replies: 2
    Last Post: 09-04-2013, 02:07 AM
  3. Problems with HLS streaming - weird behaviours
    By alexco in forum Video On Demand Streaming Discussion
    Replies: 1
    Last Post: 06-28-2012, 03:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •