Results 1 to 5 of 5

Thread: Live Stream Repeater edge not working

  1. #1
    Join Date
    Sep 2010
    Posts
    15

    Unhappy Live Stream Repeater edge not working

    Encoder set

    url : rtmp://192.168.99.10/liveorigin
    Name myStream


    192.168.99.10
    Origin application is named liveorigin /conf/liveorigin/Application.xml

    <StreamType>liverepeater-origin</StreamType>

    /conf/liveorigin/Application.xml /LiveStreamPacketizers

    <LiveStreamPacketizers>cupertinostreamingpacketizer, smoothstreamingpacketizer, sanjosestreamingpacketizer</LiveStreamPacketizers>


    test it ok LiveVideoStreaming/client/live.html

    Server: rtmp://192.168.99.10/liveorigin
    Stream: myStream


    192.168.99.11

    Edge application is named liveedge /conf/liveedge/Application.xml

    <StreamType>liverepeater-edge</StreamType>

    /conf/liveedge/Application.xml /LiveStreamPacketizers

    <LiveStreamPacketizers>sanjosestreamingrepeater, cupertinostreamingrepeater, smoothstreamingrepeater</LiveStreamPacketizers>

    <originURL>rtmp://192.168.99.10/liveorigin</originURL>

    and

    creating a .stream file in the edge content folder

    test it not work LiveVideoStreaming/client/live.html

    Server: rtmp://192.168.99.11/liveedge
    Stream: myStream.stream


    Thanks in advance for your help.

    DaY

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Run the edge in stand-alone (/bin/startup.bat) mode so you can see log output in the console. What do you see when you try the edge test?

    Check the extension, it might have a .txt extension. myStream.stream.txt

    Richard

  3. #3
    Join Date
    Sep 2010
    Posts
    15

    Unhappy

    Quote Originally Posted by rrlanham View Post
    Run the edge in stand-alone (/bin/startup.bat) mode so you can see log output in the console. What do you see when you try the edge test?

    Check the extension, it might have a .txt extension. myStream.stream.txt

    Richard
    you can see normal


  4. #4
    Join Date
    Sep 2010
    Posts
    15

    Default

    2012-10-05 07:26:37 ICT comment server INFO 200 - LiveMediaStreamHandler.connect: rtmp://192.168.99.10:1935/liveorigin/_definst_/myStream:rtmp://192.168.99.10:1935/liveorigin/_definst_[myStream] _defaultVHost_ liveedge _definst_ 68.583 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-10-05 07:26:37 ICT comment server INFO 200 - LivePlayer.play[liveedge/_definst_/rtmp://192.168.99.10:1935/liveorigin/_definst_/myStream]: Dynamic Stream Markers are on. _defaultVHost_ liveedge _definst_ 68.599 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-10-05 07:26:42 ICT comment server WARN 200 - Failed to connect: org.apache.mina.common.RuntimeIOException: Failed to get the session[ConnectException: null]. - - - 72.748 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-10-05 07:26:46 ICT comment server WARN 200 - Failed to connect: org.apache.mina.common.RuntimeIOException: Failed to get the session[ConnectException: null]. - - - 76.914 - - - - - - - - - - - - - - - - - - - - - - - - -

  5. #5
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    The log messages indicate network connectivity problem between the edge and origin. Can you open a browser on the edge? If so, what do see in a browser running on the edge at this url:
    http://192.168.99.10:1935
    Is the edge in the same LAN? If not, the edge will need to use a public IP to connect to the origin.

    Richard

Similar Threads

  1. Stream Name Group URL on Live Edge Repeater
    By rwpeng in forum AddOn: Transcoder
    Replies: 3
    Last Post: 09-13-2013, 08:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •