Results 1 to 8 of 8

Thread: Flash HTTP Streaming plays then keeps stopping?

  1. #1

    Default Flash HTTP Streaming plays then keeps stopping?

    I'm using Wowza 3.1.2 with a developer license.

    In Flex I have the following code:

    <s:VideoPlayer id="vp" width="100%" height="100%" source="rtmp://myserver/project/mp4:video.mp4/manifest.f4m?wowzaplaystart=10000" autoPlay="false"/>

    When the project runs the video loads and starts at 10 seconds as I'd expect ready to play. When I click play, it plays fine for a few seconds then just stops. If I skip ahead and try playing from there it does the same thing - it plays then stops.

    Is there a reason why this is happening?

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    You have to use http url, not rtmp, and I don't think that component supports Flash HTTP streaming. You need a OSMF player, like Flash Playback Player:

    http://www.wowza.com/forums/content....a-Media-Server

    Follow the instruction for Flash HTTP (Sanjose) Streaming at the bottom of the guide. The playback URL is in this form:

    http://[wowza-address]:1935/[app-name]/mp4:video.mp4/manifest.f4m?wowzaplaystart=10000
    Richard

  3. #3

    Default

    Sorry my bad I mis typed the address. I am using HTTP and not RTMP. Are there any options to configure because the only thing I've set is the storage path in the Application.xml under conf/project/.

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    I do not think that Flex component player will work.

    Richard

  5. #5

    Default

    Ok what if I used VideoDisplay instead? The Flex SDK uses OSMF 1.0. Do I need to be running a specific version? I tried overlaying the OSMF 2.0 SWC but the VideoPlayer component would always start at the end of the stream. So I rolled back to 1.0 which fixed that problem but now the video keeps pausing.

    RTMP streaming plays fine but I want to specify a start and end position. Is it not possible to do his with RTMP?

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    It's not possible to do Wowza sanjose (Flash HTTP) over rtmp. I understand that Flex comes with osmf.swc, but I don't think that component player uses it. Use that player I link to, it is hosted, copy embed to web page, super easy. If you need to use that component for other reasons, you will have to use rtmp streams.

    Richard

  7. #7

    Default

    Looks like it was a buffering issue. For some reason VideoPlayer and VideoDisplay has a default buffer time of 0.1 seconds. I tried changing it using:

    videoDisplay.mx_internal::videoPlayer.bufferTime = 4;

    This has fixed the problem.

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Cool. Thanks for the update.

    Richard

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •