Results 1 to 10 of 10

Thread: Scheduled streaming issue

  1. #1

    Default Scheduled streaming issue

    Hi,

    Im trying to scheduled streams using this guide: http://www.wowza.com/forums/content....cation-module)

    I was able to scheduled static videos with no problem, but i find trouble when trying to use a live stream.

    My smil looks like this:

    <smil>
        <head>
        </head>
        <body>
            <stream name="playlist1"></stream>
             <playlist name="pl1" playOnStream="playlist1" repeat="true" scheduled="2012-10-22 13:30:00">
                <video src="mp4:sample.mp4" start="150" length="3"/>
                <video src="mp4:mona4.mp4" start="20" length="3"/>
                <video src="mp4:vigo.mp4" start="50" length="3"/>
                <video src="instance/livestream" start="-2" length="15"/>
            </playlist>
        </body>
    </smil>
    In the Server.xml:
                            <Property>
                                    <Name>PublishToApplication</Name>
                                    <Value>live</Value>
                            </Property>

    The problem seems to be that my live stream is not running on the "_definst_" of "live" app.

    Could you please help me with the config?
    Ive tried different options, also using a ".stream" file, but I got no luck.

    Thanks!!!

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    The live stream has to be published to the same app instance. Make the src "livesteam"

    Richard

  3. #3

    Default

    Quote Originally Posted by rrlanham View Post
    The live stream has to be published to the same app instance. Make the src "livesteam"

    Richard
    Ive tried changing
    <video src="instance/livestream" start="-2" length="15"/>
    to
    <video src="livestream" start="-2" length="15"/>
    but i see the same issue.

    FYI
    • My stream in being publish on "rtmp://server/live/instance/livestream"
    • Im using the JW player for this with "streamer: rtmp://server/live" and "file: playlist1"


    Thanks!!!

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Publish to rtmp://server/live/_definst_/livestream, or make the streamer rtmp://server/live/instance. One way or the other, it has to be the same or it won't work

    Richard

  5. #5

    Default

    Quote Originally Posted by rrlanham View Post
    Publish to rtmp://server/live/_definst_/livestream, or make the streamer rtmp://server/live/instance. One way or the other, it has to be the same or it won't work
    If i change the streamer on JW, i get "stream not found: playlist1".

    Is there anything else I should change?
    • The "PublishToApplication" value?
    • The smil file location?


    Thanks!

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Can't you publish to the default application instance?

    Restart Wowza, test what you are trying to do, then zip up conf folder and current access and error logs and send to support@wowza.com. Include a link to this thread for reference.

    Richard

  7. #7

    Default

    Quote Originally Posted by rrlanham View Post
    Can't you publish to the default application instance?
    Restart Wowza, test what you are trying to do, then zip up conf folder and current access and error logs and send to support@wowza.com. Include a link to this thread for reference.
    Mail sent, thanks


    Could you tell me if it is possible to
    • schedule media for a specific day of the week (Monday, Tuesday, etc.)?
    • schedule media to play everyday in specfic time (ex: everyday at 00:00; scheduled repetition) ?

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Looking at you at your logs, I see you are starting the live stream on the "live13" application, and specifying an application instance of "ubbitv"

    app-start application INFO 200 ubbitv live13/ubbitv

    I also can see that you are using an RTMP encoder, probably fmle (but not necessarily) according the the user agent. If so, the FMS URL is being set to:

    rtmp://[wowza-address]/live13/ubbitv

    Meanwhile, the scheduler use the application instance "_definst_", it is hard-coded, there is no Property setting for this. To make this work for you, either change the FMS URL to simply:

    rtmp://[wowza-address]/live13

    Or, if you are unable to do that for any reason, you will have to build the example and change the application instance in the Java code of the scheduler, which is available here:
    http://www.wowza.com/forums/content....rver-listener)

    Richard

  9. #9

    Default

    Richard,

    Could you tell me if it is possible to
    • schedule media for a specific day of the week (Monday, Tuesday, etc.)?
    • schedule media to play everyday in specfic time (ex: everyday at 00:00; scheduled repetition) ?

  10. #10
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Neither is possible with the scheduler that is included in the Wowza Modules Collection, but it is possible to create something else to do those things. The scheduler source should be a good starting place

    Richard

Similar Threads

  1. Replies: 4
    Last Post: 07-16-2014, 11:59 PM
  2. Resolution issue during scheduled vod streaming
    By weichung in forum On-Demand Streaming
    Replies: 2
    Last Post: 03-19-2014, 07:29 PM
  3. scheduled streaming
    By oletinani in forum Wowza Streaming Engine functionality
    Replies: 5
    Last Post: 02-07-2014, 01:49 AM
  4. scheduled streaming
    By oletinani in forum Wowza Streaming Engine functionality
    Replies: 1
    Last Post: 01-28-2014, 07:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •