Results 1 to 9 of 9

Thread: Does anyone know why changing timeout settings doesn't work

  1. #1

    Default Does anyone know why changing timeout settings doesn't work

    Hi guys,

    Does anyone know why the timeout settings for HTTP streaming doesn't work? I changed both of them at "[app]/Application.xml/Application/ApplicationTimeout" and "VHost.xml/Application/ApplicationTimeout". But the session was always disconnected after pausing for 30 seconds.

    Please help. Thank you in advance.
    L

  2. #2
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi
    Did you restart Wowza after making the changes?

    Jason

  3. Default

    I find the same issue to be true as well... no effect in either Application.xml file. I've always had to resort to doing it in HTTPStreamers.xml

  4. #4

    Default

    Quote Originally Posted by jay_charles View Post
    I find the same issue to be true as well... no effect in either Application.xml file. I've always had to resort to doing it in HTTPStreamers.xml
    Yes, you're right Jay, HTTPStreamers.xml does the job. Thank you guys.

  5. #5
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi
    I'll have someone take a look at why this doesn't work as expected.
    Thanks for letting us know.

    Jason

  6. #6
    Join Date
    May 2011
    Posts
    456

    Default

    Modifying [install-dir]/conf/HTTPStreamers.xml is the correct way to adjust the HTTP timeout settings.

    -Lisa

  7. Default

    Thanks Lisa.

    In a perfect world, wouldn't the same settings found in an application level Application.xml override those settings for a specific application? I have use cases where I'd like longer timeouts on some applications, but changing those settings in HTTPStreamers.xml is global.

  8. #8

    Default

    leposy, Jay,

    It works as it's supposed to. The ApplicationTimeout refers to these lines:

    INFO application app-start ...
    INFO application app-stop ...
    Try setting:
    <ApplicationTimeout>5000</ApplicationTimeout>

    Then publish an RTMP stream to Wowza. Then stop the stream. You will see the application stop after 5 seconds.

    Jay, Application.xml values do override global settings as far as I know.

  9. Default

    Thanks, but the thread has to do with session timeouts on HTTPStreamers not application timeout, and in the case of http streamer timeout settings in Application.xml, no effect.

Similar Threads

  1. Replies: 5
    Last Post: 06-12-2014, 07:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •