Results 1 to 4 of 4

Thread: SMIL Live Streaming problem.

  1. #1
    Join Date
    Oct 2012
    Posts
    3

    Default SMIL Live Streaming problem.

    Hello All,

    I am using the Wowza 3.1.2 for multibitrate live streams. Standalone streams work but not adaptive live streams.

    <smil>
    <head>
    </head>
    <body>
    <switch>
    <video src="livestream_1" system-bitrate="700000"/>
    <video src="livestream_2" system-bitrate="350000"/>
    <video src="livestream_3" system-bitrate="200000"/>
    </switch>
    </body>
    </smil>

    These streams are are playable individually

    How ever they do not play with the manifest ( sanjose with adaptive feature).


    http://localhost:1935/live/smil:live...l/manifest.f4m

    Configuration : As given here

    http://www.wowza.com/forums/content.php?36#ABR

    Note:

    The curpertino streaming works just great on the iPAD

    Client use is : From example provided by wowza and flex4 spark player that based on OSMF.

    Any ideas. Thanks in advance.
    regards
    RG.
    Last edited by webreg; 10-29-2012 at 04:14 AM.

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    How are you producing these streams? Each of them must be key frame aligned for switching to work. You can debug alignment to see if they are:

    http://www.wowza.com/forums/content....rame-alignment

    Richard

  3. #3
    Join Date
    Oct 2012
    Posts
    3

    Default

    Hello Richard,
    Still stuck. Streams are created via FMLE 3 (O/S: Windows). Could you help please?


    After setup instructed properties currently looks like this :

    <Properties>
    <Property>
    <Property>
    <Name>debugKeyFrameTimecodes</Name>
    <Value>true</Value>
    <Type>Boolean</Type>
    </Property>
    <Name>enableDynamicStreamMarkers</Name>
    <Value>true</Value>
    <Type>Boolean</Type>
    </Property>
    <Property>
    <Name>maxChunkLogCount</Name>
    <Value>0</Value>
    <Type>Integer</Type>
    </Property>
    <Property>
    <Name>smoothStreamingUseSMILBitrates</Name>
    <Value>true</Value>
    <Type>Boolean</Type>
    </Property>
    </Properties>

    Thanks and regards,
    RG

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    RG,

    smoothStreamingUseSMILBitrates belongs in /HTTPStream /Properties. enableDynamicStreamMarkers would go in /Streams /Properties list, but it is on by default in recent versions, so not necessary.

    First, restart Wowza, then publish these streams and try to playback using the Wowza OSMF example player. Then zip up conf and logs and send them to support@wowza.com. Include a link to this thread for reference

    Richard

Similar Threads

  1. Stream not found [live/smil:myStream.smil/manifest.f4m]: myStream.smil
    By viet_fpt in forum Live Streaming and Encoder Discussion
    Replies: 12
    Last Post: 04-08-2013, 07:22 AM
  2. IMediaStreamNameAliasProvider2 with SMIL files for live streaming
    By Kovach in forum Server-side Modules and Code Samples Discussion
    Replies: 0
    Last Post: 12-20-2012, 07:55 AM
  3. problem with multibitrate http streaming with smil file
    By ManGood in forum Live Streaming and Encoder Discussion
    Replies: 4
    Last Post: 05-16-2012, 04:18 PM
  4. SMIL Problem
    By Mayol25 in forum General Forum
    Replies: 6
    Last Post: 04-21-2012, 05:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •