Results 1 to 2 of 2

Thread: stream AAC audio to wowza

  1. #1
    Join Date
    Nov 2012

    Default stream AAC audio to wowza

    Hi! I am developing application that should be able to stream audio/video in AAC/h264 encoding over rtp to wowza. I used x264 for video and libfaac for audio encoding. Here is the sdp file:
    o=- 0 0 IN IP4 Encoder
    c=IN IP4
    m=video 10202 RTP/AVP 96
    a=rtpmap:96 H264/90000
    a=fmtp:96 packetization-mode=1; sprop-parameter-sets=Z0LAHraAoD2hAAADAAEAAAMAPA8WLqA=,aM4fIA==
    m=audio 10204 RTP/AVP 97
    a=rtpmap:97 mpeg4-generic/44100/2
    a=fmtp:97 streamtype=5; config=4210; profile-level-id=15; mode=AAC-hbr; sizeLength=13; indexLength=3; indexDeltaLength=3; constantDuration=1024
    The video without audio is streamed from webcam without issues. But when both audio/video is streamed to wowza not video neither audio is played. If audio only streamed sometimes played a short part. The log for audio in wowza server seems slowly updated. For capture video/audio was used DirectShowNet.lib and SampleGraber filter. For streaming custom rtp implementation and winsocks. The custom DirectShow filter didn't made streaming faster.

    Can you help find out the problem?
    Is it DirectShow filter works slowly for render audio data over network?

  2. #2
    Join Date
    Nov 2012


    Problem was resolved.

Similar Threads

  1. AAC audio not coming through WOWZA, but working in vlc
    By peterb in forum Live Streaming and Encoder Discussion
    Replies: 4
    Last Post: 09-11-2012, 04:14 AM
  2. RTSP stream ip camera -> audio only to AAC+
    By Egbert in forum AddOn: Transcoder
    Replies: 4
    Last Post: 05-01-2012, 05:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts