Results 1 to 8 of 8

Thread: Setting Up nDvr on EC2

  1. #1
    Join Date
    Jan 2011

    Default Setting Up nDvr on EC2


    My users are requesting the ability to do live rewind playback. I'm interested in implementing the Wowza nDvr AddOn. I have Wowza v2.x EC2 paid instance deployed on Amazon EC2. Is there an easy upgrade path on EC2 for Wowza Media Server v3.x? I can take the server down for an install but I don't want to loose all my configurations and some custom modules we've written. Also, is there an option to purchase a Wowza EC2 instance that is all setup with the nDvr option installed?

    Currently, we use rtmp streaming from the source camera to Wowza. Would I need to change this to Http Streaming in order to support the nDvr feature? Lastly, we use FlowPlayer on the client for video playback. Will FlowPlayer easily integrate with the Wowza nDvr feature or would I need to change video players?

    Sorry for barrage of questions. I'm just trying to see if the feature request is worth the upgrade effort.

    Thanks much,


  2. #2
    Join Date
    May 2011


    You would need to use a version 3.x AMI with a license key (lickey) to be provisioned for nDVR AddOn. You can select an AMI from second table named "Wowza Media Server 3 lickey licensing" on this page. When you stop an EC2 instance you will lose all changes or files you have on the server. If you have anything you donít want to lose, save it to Amazon S3 or to a local machine before stopping the instance.

    You need to select a player that support HTTP playback. Silverlight and OSFM player are commonly used with nDVR workflows. We provide samples players for both in [install-dir]/examples/LiveDVRStreaming directory.


  3. #3



    I am using EC2 with the proper lickey for nDVR and here is my problem.

    Everything works fine, records and plays live stream... using LiveDVRStreaming/FlashHTTPPlayer

    Then after the live stream ends we can still play the recorded stream using the player but we lose the ability to fast forward and rewind.

    So we tried the Silverlight player which worked fine when we self-hosted the server but does not work at all with EC2.

    I looked everywhere and wasted so many hours on trying to get these things working. Please tell me you know what's wrong and how to fix this.

    We're trying to get things finalized for a client and this is holding us back.

    On the server side we created a new application so we can track usage from the client.
    We called the app dvrMahwah
    We set the app up using the nDVR settings and saved it to the /conf folder
    Its dumping the recording on EC2 into: /usr/local/WowzaMediaServer/dvrMahwah/dvrMahwah/_definst_/myShabbat-4-26-13.sdp.0
    It plays fine using the url: http://ec2-54-242-152-138.compute-1....nifest.f4m?DVR (with the Flash Player but can't fast forward or rewind)

    Best Regards,

  4. #4
    Join Date
    Dec 2007



    hm, I see that. Do you think the usage tracking is a factor? How did you configure nDVR?

    You might want to open a ticket. Can you zip up the /conf folder and the logs from the recording and send to

    But only if the configuration is the same as when the recording was done. Otherwise, and it might be better anyway, to do a new test with clean logs: delete the current access log then re-start Wowza and test. It would also be a good idea to remove the tracking module for the test.

    Send those files to, include a link to this thread for reference.


  5. #5
    Join Date
    Dec 2007



    Actually, I tried it again, and it does seek forward and back. Not sure why it didn't seem to work before. There is no fast-forward, but you can seek forward and back. In the Wowza LiveDVRStreaming/FlashHTTPPlayer


  6. #6



    What browser are you using? I tried it in both Firefox and Explorer and cannot get it to seek forward or back, just pause and play.

    Do you recommend a better player to use for DVR? And did you happen to get it to work with Silverlight?

    I'm trying out WMSPanel, could this actually cause this kind of issue?



  7. #7
    Join Date
    Dec 2007



    I'm using Chrome and Flash 11,7,700,179.

    Did you open a ticket? We are curious about this. I went back to it a couple of times and could not replicate seek, it was stuck again as I first observed and you describe, but it was definitely working at one point. It has been open for sometime.

    Do you set a very long /DVR /WindowDuration?

    Can you replicate this in a short test? If you can, delete the current access log, start Wowza and run through test. Confirm that the dvr recording is not seekable. Then zip up the whole /conf folder and the current access log showing these tests to


  8. #8


    Its not working for either in any of my browsers. I ran a short test, about 3 minutes... and it seemed to work. But after the recording had ended and a few minutes went by, the ability to seek stopped working. When the player loads it shows the total time of the video. Then you hit play and the time goes to 0:00. It plays but you have no control other than play and pause.

    Again all this worked fine on our local server. It has to be a way that Amazon stores the files or something after the stream broadcast stops. All the DVR functions work fine when the stream is live. As soon as we stop broadcasting.... the seek stops working.

    I'm still learning about all the tweaking you can do to the /conf files for the apps. Other than the basic setting to use DVR function, where to record it to and the archive feature... I have nothing else configured for DVR properties.

    The recordings that we will be doing will be anywhere between 1.5 to 3 hours long.
    We are using Quicktime broadcaster.
    Quality = Best
    Frames Per Second: 25
    Key Frames: 48 Frames
    Limit Data to 2000 kbits/sec
    Packet Size: 1438 bytes
    MPEG-4 Audio AAC (Low Complexity) 16kbits/sec Encoder Quality: Best

    I sent in the server stats to support for them to look at.

Similar Threads

  1. Setting up the trial version in EC2 for live streaming. Requiring assitance
    By aman.alam in forum Wowza Streaming Engine in the Cloud
    Replies: 8
    Last Post: 09-30-2014, 01:54 PM
  2. is there a (video) tutorial available to show setting up EC2 wowza for large audience
    By yarekc in forum Wowza Streaming Engine in the Cloud
    Replies: 1
    Last Post: 09-26-2014, 02:01 AM
  3. Setting up Wowza on Amazon EC2
    By wscalontheweb in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 4
    Last Post: 11-16-2011, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts