Results 1 to 4 of 4

Thread: Audio transcoding problem

  1. #1
    Join Date
    Aug 2011
    Posts
    4

    Default Audio transcoding problem

    I try to transcode stream from IP camera(H264/G711-mulaw) to H264/AAC.
    With video transcoding all right while the audio transcoding displays the following message:

    TranscoderStreamNameGroup.validateMembers[_defaultVHost_:rtp-live/_definst_/rtsp://root:root@192.230.1.35:554/cam0_0]: StreamNameGroup[source] audio codec is not valid for name group: G711_MULAW (g711.mulaw)
    TranscoderStreamNameGroup.validateMembers[_defaultVHost_:rtp-live/_definst_/rtsp://root:root@192.230.1.35:554/cam0_0]: StreamNameGroup[360p] audio codec is not valid for name group: G711_MULAW (g711.mulaw)
    TranscoderStreamNameGroup.validateMembers[_defaultVHost_:rtp-live/_definst_/rtsp://root:root@192.230.1.35:554/cam0_0]: StreamNameGroup[160p] audio codec is not valid for name group: G711_MULAW (g711.mulaw)
    TranscoderStreamNameGroup.addInternal[_defaultVHost_:rtp-live/_definst_/rtsp://root:root@192.230.1.35:554/cam0_0]: Name group was not added, it is empty: rtsp://root:root@192.230.1.35:554/cam0_0_all

    How can i fix this?

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Are you using the transrate.xml template? You should start with the transcode.xml template. Change that in the Application.xml /Transcoder /Templates. The source stream should not be included in the StreamNameGroup but the others should work if the audio is transcoded to AAC

    Richard

  3. #3
    Join Date
    Aug 2011
    Posts
    4

    Default

    Thanks for help! I did not notice that <Templates> was set to transrate.xml.

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Great, thanks for the update

    Richard

Similar Threads

  1. Transcoding Audio Only not working
    By Darkhors in forum Wowza Transcoder
    Replies: 1
    Last Post: 08-11-2014, 10:40 AM
  2. Audio transcoding problems
    By AlSoft in forum AddOn: Transcoder
    Replies: 5
    Last Post: 01-26-2013, 07:15 AM
  3. Flash 11 Transcoding audio
    By kleelof in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 08-18-2012, 02:36 AM
  4. Audio transcoding and repacking problem
    By shadowlin in forum AddOn: Transcoder
    Replies: 1
    Last Post: 07-13-2012, 04:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •