Results 1 to 6 of 6

Thread: stream from mpeg ts encoder: video not working, audio OK

  1. #1

    Default stream from mpeg ts encoder: video not working, audio OK

    I am streaming from mpegts encoder multicast stream to wowza:
    - input stream udp://239.192.1.2:9001
    -output stream: rtsp://x.x.x.x:1935/live/mpegts.stream
    However audio is ok, but video is not working.
    This is the message I get, and it seems video codec is ok:
    LiveStreamPacketizerSanJose.handlePacket[live/_definst_/mpegts.stream]: Video codec: H264 - - - 238113.742 - - - - - - - - - - - - - - - - - - - - - - - - -
    2012-11-26 09:03:03 CET comment server INFO 200 - LiveStreamPacketizerSanJose.handlePacket[live/_definst_/mpegts.stream]: Audio codec: MP3

    and this is the error:
    WARN 200 - RTPPacketFragmentListReader.skip: Bad skip count:

    CPU is almost idle
    Any idea?

  2. #2

    Default

    I'm stuck here forever

  3. #3
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    What is the source video and audio encoding details?

    Play the source in VLC and check Tools > Codec Info

    Then play Wowza rtsp output in VLC and check Tools > Codec info.

    Richard

  4. #4

    Default

    Hello Richard,
    OK, the codec info from VLC:
    Stream 0
    Type Audio
    Original ID:256
    Codec: MPEG Audio Layer 1/2/3 (mpga)
    Channels: Stereo
    Sample rate: 44 kHz
    Bitrate: 80 kb/s

    Stream1
    Type: Video
    Original ID: 257
    Codec: H264 - MPEG-4 AVC (part 10) (h264)
    Resolutio: 704x576
    Decoded format: Planar 4:2:0 YUV

    and codec info from rtsp outpur in VLC:
    Stream 0
    Type Audio
    Codec: MPEG Audio Layer 1/2/3 (mpga)
    Channels: Stereo
    Sample rate: 44 kHz
    Bitrate 80 kb/s

    A you can see - there is no vidio output in rtsp stream. And I can't make out why because I don't see any errors considering video in logs.

  5. #5

    Default

    Anyone?

  6. #6
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Try setting audioIsAligned to "false" in the Application.xml /RTP Properties container:

    <Property>
    	<Name>audioIsAligned</Name>
    	<Value>false</Value>
    	<Type>Boolean</Type>
    </Property>
    If that doesn't work, follow this guide to make a recording and send to support@wowza.com

    http://www.wowza.com/forums/showthre...gging-purposes

    Richard
    Last edited by rrlanham; 11-28-2012 at 09:10 AM.

Similar Threads

  1. Replies: 4
    Last Post: 08-05-2015, 03:44 PM
  2. Replies: 7
    Last Post: 04-23-2013, 01:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •