Results 1 to 5 of 5

Thread: JConsole not showing wowza when running as Service (3.5 on 2008R2)

  1. #1

    Default JConsole not showing wowza when running as Service (3.5 on 2008R2)

    I already had this problem with version 3.1.1 - only when running the server in interactive mode was I able to get the Wowza bootstrap thingie in JConsole. Swiched to service and all I get is the sun.tool.jconsol.JConsole local process. I played wiht enable JMX and other stuff I read in the instructions, but no change.

    Same now on version 3.5. System is a Server 2008 R2 enterprise Edition, perpetural Edition Wowza 3.5.0 with Trancoder license installed. I changed the account the Wowza service runs under from System to a local admin account, but no change. Everything seems to work fine, but I have no way to monitor the server. In fact, since version 3.5, I can't even see a console when running it as an interactice program from the start menu - it just fires up the service. Do I have to completely disable the service, not just stop and set to manual startup, so that I can run the console version?

  2. #2
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    I tested JMX/JConsole stand-alone, service and running Wowza IDE (on Windows 7) and all worked.

    Did you try running /bin/startupJConsole.bat /bin/startupJConsole.vbs ?

    Richard

  3. #3

    Default

    I am running straight from the start menu:

    "C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.5.0\bin\startupJConsole.bat"

    whcih starts in

    "C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.5.0\bin\"


    screen recording from the server in question

    https://nms.doit.wisc.edu/embedders/...deo_height=800

  4. #4
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Here are the steps:

    http://www.wowza.com/forums/content.php?217#jconsole

    You have to use the service url that is shown in the /conf/Server.xml file where you enable JMX. Enter it in the remote box:

    service:jmx:rmi://localhost:8084/jndi/rmi://localhost:8085/jmxrmi

    auth: admin/admin

    Richard

  5. #5

    Default

    this works, thanks.

Similar Threads

  1. Replies: 3
    Last Post: 02-28-2012, 06:13 PM
  2. Transcoder AddOn when Wowza running as service
    By jarrype in forum AddOn: Transcoder
    Replies: 1
    Last Post: 01-12-2012, 08:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •