Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Cannot get live stream to play.....

  1. #1

    Question Cannot get live stream to play.....

    Hello Wowza staff,

    Hope you can help. I am trying to get a live stream running with JW Player.

    Following the instructions on :

    How to use Longtail JW Player 5.x with Wowza Media Server
    Published on 10-02-2010 02:17 AM Number of Views: 26133
    24 Comments Comments
    To use JW Player to stream from Wowza, first setup JW Player following one these guides

    Using SWFObject and other methods
    Using JWEmbedder

    Once you have JW Player working following any of the options, you can configure it for streaming by changing the "file" to a video or live stream you want to display and adding "streamer" and "provider" Flashvars.

    For example, if you used the Embed Tag method (JWEmbedder), you would change this:

    Code:

    <embed
    flashvars="file=/data/bbb.mp4"
    allowfullscreen="true"
    allowscripaccess="always"
    id="player1"
    name="player1"
    src="player.swf"
    width="480"
    height="270"
    />

    To this:

    Code:

    <embed
    flashvars="file=sample.mp4&streamer=rtmp://localhost:1935/vod&provider=rtmp"
    allowfullscreen="true"
    allowscripaccess="always"
    id="player1"
    name="player1"
    src="player.swf"
    width="480"
    height="270"
    />

    Or a live stream in this example:

    Code:

    <embed
    flashvars="file=myStream&streamer=rtmp://localhost:1935/live&provider=rtmp"
    allowfullscreen="true"
    allowscripaccess="always"
    id="player1"
    name="player1"
    src="player.swf"
    width="480"
    height="270"
    />

    I am able to get the "vod" to play fine, but cannot get the live stream running.

    here is are the codes i am using:

    <embed
    flashvars="file=radiostation.stream&streamer=rtmp://75.125.146.66:1935/live&provider=rtmp"
    allowfullscreen="true"
    allowscripaccess="always"
    id="player1"
    name="player1"
    src="player.swf"
    width="480"
    height="270"
    />

    <p>
    <hr><embed
    flashvars="file=sample.mp4&streamer=rtmp://75.125.146.66:1935/vod&provider=rtmp"
    allowfullscreen="true"
    allowscripaccess="always"
    id="player1"
    name="player1"
    src="player.swf"
    width="480"
    height="270"

    you can see the sample at www.elsol980.net


    Thank you
    Tim Keenan
    Last edited by timkjabar; 01-02-2013 at 03:04 PM.

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Does radiostation.stream exist in content folder, and (I assume) contain a http url to a shoutcast stream? And is /conf/Application.xml /StreamType "live"? If so, then start "radiostation.stream" in StreamManager with MediaCasterType "shoutcast". Or you can change the StreamType to "shoutcast" and not have to start in StreamManager. You can use /conf/StartUpStreams.xml instead of StreamManager,.

    Richard

  3. #3

    Default

    yes radiostation.stream does exist in content folder. yes it contains a http url to a icecast stream not shoutcast stream. yes stream type is "live." Does the fact that it is an icecast stream have any reason why it is not working?

  4. #4

    Default

    when i go to www.elsol980.net and start the JW Player all I get is a buffering and no connection.

  5. #5
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Again, in that case, you have to start the stream in StreamManager or /conf/StartupStreams.xml, as I explained.

    Or, if you are only going to use Flash clients (like JW Player) you can change the Application.xml /StreamType to "shoutcast"

    It is very helpful to run Wowza in stand-alone (/bin/startup.bat) mode so that you can see log output in a console.

    Richard

  6. #6

    Default

    have changed my application.xml to shoutcast -

    this is the error log:

    #Version: 1.0
    #Start-Date: 2013-01-03 08:28:02 EST
    #Software: Wowza Media Server 3.1.2 build1624
    #Date: 2013-01-03
    #Fields: x-severity x-category x-event date time c-client-id c-ip c-port cs-bytes sc-bytes x-duration x-sname x-stream-id x-spos sc-stream-bytes cs-stream-bytes x-file-size x-file-length x-ctx x-comment
    WARN server comment 2013-01-03 08:28:02 - - - - - 2.152 - - - - - - - - HTTProvider2Base.QuickFilter: Cannot handle this filter: serverinfo.xml
    #Version: 1.0
    #Start-Date: 2013-01-03 09:04:57 EST
    #Software: Wowza Media Server 3.1.2 build1624
    #Date: 2013-01-03
    #Fields: x-severity x-category x-event date time c-client-id c-ip c-port cs-bytes sc-bytes x-duration x-sname x-stream-id x-spos sc-stream-bytes cs-stream-bytes x-file-size x-file-length x-ctx x-comment
    WARN server comment 2013-01-03 09:04:59 - - - - - 2.191 - - - - - - - - HTTProvider2Base.QuickFilter: Cannot handle this filter: serverinfo.xml

    do you need the access log too?

  7. #7
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi
    Try changing the streamType back to "live" and starting the stream using stream manager which can be found here:
    http://[Wowza-IP]:8086/streammanager

    Please post any results.

    Jason

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Have you made changes to /conf/Server.xml ?

    Richard

  9. #9

    Default

    nope I have not..here is my server.xml

    <Root>
    <Server>
    <CommandInterface>
    <HostPort>
    <IpAddress>*</IpAddress>
    <Port>8083</Port>
    </HostPort>
    </CommandInterface>
    <AdminInterface>
    <!-- Objects exposed through JMX interface: Server, VHost, VHostItem, Application, ApplicationInstance, MediaCaster, Module, Client, MediaStream, SharedObject, Acceptor, IdleWorker -->
    <ObjectList>Server,VHost,VHostItem,Application,ApplicationInstance,MediaCaster,Module,IdleWorker</ObjectList>
    </AdminInterface>
    <!-- JMXUrl: service:jmx:rmi://localhost:8084/jndi/rmi://localhost:8085/jmxrmi -->
    <JMXRemoteConfiguration>
    <Enable>false</Enable>
    <IpAddress>localhost</IpAddress> <!-- set to localhost or internal ip address if behind NAT -->
    <RMIServerHostName>75.125.146.66</RMIServerHostName> <!-- set to external ip address or domain name if behind NAT -->
    <RMIConnectionPort>8084</RMIConnectionPort>
    <RMIRegistryPort>8085</RMIRegistryPort>
    <Authenticate>true</Authenticate>
    <PasswordFile>${com.wowza.wms.ConfigHome}/conf/jmxremote.password</PasswordFile>
    <AccessFile>${com.wowza.wms.ConfigHome}/conf/jmxremote.access</AccessFile>
    <SSLSecure>false</SSLSecure>
    </JMXRemoteConfiguration>
    <UserAgents>Shockwave Flash|CFNetwork|MacNetwork/1.0 (Macintosh)</UserAgents>
    <ServerListeners>
    <!--
    <ServerListener>
    <BaseClass>com.wowza.wms.plugin.loadbalancer.ServerListenerLoadBalancerListener</BaseClass>
    </ServerListener>
    -->
    <!--
    <ServerListener>
    <BaseClass>com.wowza.wms.plugin.loadbalancer.ServerListenerLoadBalancerSender</BaseClass>
    </ServerListener>
    -->
    </ServerListeners>
    <VHostListeners>
    <!--
    <VHostListener>
    <BaseClass></BaseClass>
    </VHostListener>
    -->
    </VHostListeners>
    <HandlerThreadPool>
    <PoolSize>10</PoolSize>
    </HandlerThreadPool>
    <TransportThreadPool>
    <PoolSize>10</PoolSize>
    </TransportThreadPool>
    <RTP>
    <DatagramStartingPort>6970</DatagramStartingPort>
    <DatagramPortSharing>false</DatagramPortSharing>
    </RTP>
    <!-- Properties defined here will be added to the IServer.getProperties() collection -->
    <Properties>
    </Properties>
    </Server>
    </Root>

  10. #10
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Have you made changes to /conf/VHost.xml?

    Have you copied that or other configuration files from a previous version/install of Wowza?

    Richard

Page 1 of 3 123 LastLast

Similar Threads

  1. Nokia Devices and Blacberry cannot play Live stream but Andriod and Iphone can play
    By ravish in forum Live Streaming and Encoder Discussion
    Replies: 3
    Last Post: 09-11-2012, 06:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •